summaryrefslogtreecommitdiffstats
path: root/trinity-base/tdepim-tdeioslaves/tdepim-tdeioslaves-14.0.12.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'trinity-base/tdepim-tdeioslaves/tdepim-tdeioslaves-14.0.12.ebuild')
-rw-r--r--trinity-base/tdepim-tdeioslaves/tdepim-tdeioslaves-14.0.12.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/trinity-base/tdepim-tdeioslaves/tdepim-tdeioslaves-14.0.12.ebuild b/trinity-base/tdepim-tdeioslaves/tdepim-tdeioslaves-14.0.12.ebuild
new file mode 100644
index 00000000..30a07da0
--- /dev/null
+++ b/trinity-base/tdepim-tdeioslaves/tdepim-tdeioslaves-14.0.12.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2022 Gentoo Authors
+# Copyright 2022 The Trinity Desktop Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+TRINITY_MODULE_NAME="tdepim"
+TRINITY_MODULE_TYPE="core"
+TRINITY_SUBMODULE="tdeioslave"
+TSM_EXTRACT_ALSO="libtdepim/ libemailfunctions/ libkmime/ translations/"
+inherit trinity-meta-2
+
+DESCRIPTION="PIM Trinity TDEIOslaves"
+
+if [[ ${PV} != *9999* ]] ; then
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+
+IUSE="sasl sieve"
+
+# The Sieve TDEIOslave won't build without SASL and
+# the IMAP4 TDEIOslave will lose the ability of SASL
+# authentification. To fulfill any expectation of users,
+# we offer two USE flags, which depend on each other.
+
+REQUIRED_USE="
+ sasl? ( sieve )
+ sieve? ( sasl )
+"
+
+DEPEND="
+ net-libs/libtirpc
+ ~trinity-base/libkmime-${PV}
+ sasl? ( dev-libs/cyrus-sasl )"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DWITH_SASL=$(usex sieve)
+ )
+ trinity-meta-2_src_configure
+}