summaryrefslogtreecommitdiffstats
path: root/arch/tde-core/tde-tdebase/PKGBUILD
diff options
context:
space:
mode:
authorMichael J. Manley <mjmanley@ntge.net>2021-09-29 19:43:06 -0700
committerSlávek Banko <slavek.banko@axis.cz>2021-09-30 23:47:59 +0200
commit9de6b0c309093bd2f61d5289b6750d03cd5893de (patch)
treeed5af5983dbb05db051f22e0015f2040cd2a8f7e /arch/tde-core/tde-tdebase/PKGBUILD
parentb7b1cc650177a9fa6d1e5e409a26abba1859344e (diff)
downloadtde-packaging-9de6b0c309093bd2f61d5289b6750d03cd5893de.tar.gz
tde-packaging-9de6b0c309093bd2f61d5289b6750d03cd5893de.zip
ArchLinux: Fixed tdebase to create correct PAM files. This resolves issue TDE/tdebase#225
Signed-off-by: Michael J. Manley <mjmanley@ntge.net> (cherry picked from commit 1449cb652508e9448aa82f0a752912f200c073f8)
Diffstat (limited to 'arch/tde-core/tde-tdebase/PKGBUILD')
-rw-r--r--arch/tde-core/tde-tdebase/PKGBUILD19
1 files changed, 5 insertions, 14 deletions
diff --git a/arch/tde-core/tde-tdebase/PKGBUILD b/arch/tde-core/tde-tdebase/PKGBUILD
index 9033e78a5..85f569247 100644
--- a/arch/tde-core/tde-tdebase/PKGBUILD
+++ b/arch/tde-core/tde-tdebase/PKGBUILD
@@ -3,7 +3,7 @@
pkgname='tde-tdebase'
pkgver=14.0.10
-pkgrel=1
+pkgrel=2
pkgdesc="Trinity Desktop Enviroment base components"
arch=('i686' 'x86_64')
url='https://scm.trinitydesktop.org/scm/git/tdebase'
@@ -50,8 +50,6 @@ options=('staticlibs' 'libtool' '!strip')
install='trinity-tdebase.install'
source=("https://mirror.ppa.trinitydesktop.org/trinity/releases/R${pkgver}/main/core/tdebase-trinity-${pkgver}.tar.xz"
- 'arch-kdeshutdown.png'
- 'kdm-default-face.png'
'agent-shutdown.sh'
'agent-startup.sh'
'tdm-trinity'
@@ -60,8 +58,6 @@ source=("https://mirror.ppa.trinitydesktop.org/trinity/releases/R${pkgver}/main/
'xsession.patch')
md5sums=('bca895dfc2b88c4b74e307d5690108bf'
- '2dac928c6177b9fa0f4e751d7dddc62e'
- '81eb97f16b66a2152e592358727a30c7'
'18e8d01124b19f7df2937c06e177bf7f'
'c963ef6e37c9051119972a58c67f05fb'
'bb4c25e560fa719e8e8f49ef80bd1c99'
@@ -110,7 +106,10 @@ build() {
-DWITH_TDEHWLIB=ON \
-DWITH_UPOWER=ON \
-DBUILD_ALL=ON \
- -DWITH_GCC_VISIBILITY=ON
+ -DWITH_GCC_VISIBILITY=ON \
+ -DKCHECKPASS_PAM_SERVICE=tde-checkpass \
+ -DTDM_PAM_SERVICE=tde \
+ -DTDESCREENSAVER_PAM_SERVICE=tde-screensaver
make $NUMJOBS
}
@@ -133,11 +132,6 @@ package() {
install -D -m644 "${srcdir}"/tdm.service \
"${pkgdir}"/usr/lib/systemd/system/tdm.service
- # Add image for default user avatar. This removes kdm complains about missing
- # default avatar from kdm.log
- install -D -m 644 $srcdir/kdm-default-face.png ${pkgdir}$TDEDIR/share/apps/tdm/faces/.default.face.icon
- install -D -m 644 $srcdir/kdm-default-face.png ${pkgdir}$TDEDIR/share/apps/tdm/pics/users/arch-kdm.png
-
# create the starttrinity link
# do we need this? wouldn't be better to rename startkde script
# to starttrinity? (renamed to starttde) Create for compatibility sake.
@@ -146,9 +140,6 @@ package() {
# install mkpamserv script, so we can auto-generate pam.d configs in post_install()
install -D -m755 ${srcdir}/${pkgname#*-}-trinity-${pkgver}/mkpamserv ${pkgdir}${TDEDIR}/bin/mkpamserv
- # Install nice arch logo to use in the shutdown dialog
- install -D -m 644 $srcdir/arch-kdeshutdown.png ${pkgdir}$TDEDIR/share/apps/ksmserver/pics/shutdownkonq.png
-
# add startup/shutdown agents for ssh and gpg-agent
install -m644 -D $srcdir/agent-startup.sh ${pkgdir}$TDEDIR/env/agent-startup.sh
install -m755 -D $srcdir/agent-shutdown.sh ${pkgdir}$TDEDIR/shutdown/agent-shutdown.sh