summaryrefslogtreecommitdiffstats
path: root/debian/_base/kdenetwork/debian/rules
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2019-04-03 18:05:50 +0200
committerSlávek Banko <slavek.banko@axis.cz>2019-04-03 18:05:50 +0200
commitaf5c905ec49085b7c396caf2c5166f0c34cbeb3f (patch)
tree56463d31ace48f127ed61169fdc2b4b8aedfcc56 /debian/_base/kdenetwork/debian/rules
parente43172a6e74706afc06ff8d11cbfa769bc949cc1 (diff)
downloadtde-packaging-af5c905ec49085b7c396caf2c5166f0c34cbeb3f.tar.gz
tde-packaging-af5c905ec49085b7c396caf2c5166f0c34cbeb3f.zip
DEB: use _base folder for a distro instead of specific distros (squeeze and maverick).
Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'debian/_base/kdenetwork/debian/rules')
-rwxr-xr-xdebian/_base/kdenetwork/debian/rules67
1 files changed, 67 insertions, 0 deletions
diff --git a/debian/_base/kdenetwork/debian/rules b/debian/_base/kdenetwork/debian/rules
new file mode 100755
index 000000000..1b8ccc627
--- /dev/null
+++ b/debian/_base/kdenetwork/debian/rules
@@ -0,0 +1,67 @@
+#!/usr/bin/make -f
+
+DEB_HOST_ARCH_OS=$(shell dpkg-architecture -qDEB_HOST_ARCH_OS)
+DEB_HOST_ARCH=$(shell dpkg-architecture -qDEB_HOST_ARCH)
+
+ifeq ($(DEB_HOST_ARCH),s390)
+DONT_BUILD+= kwifimanager
+endif
+ifneq ($(DEB_HOST_ARCH_OS),linux)
+DONT_BUILD+= kwifimanager kdnssd
+endif
+export DH_OPTIONS
+
+include /usr/share/cdbs/1/rules/debhelper.mk
+include /usr/share/cdbs/1/class/cmake.mk
+include debian/cdbs/debian-qt-kde.mk
+#include /usr/share/cdbs/1/rules/patchsys-quilt.mk
+include /usr/share/cdbs/1/rules/utils.mk
+
+DEB_CONFIGURE_INCLUDEDIR := /opt/trinity/include
+DEB_CONFIGURE_MANDIR := /opt/trinity/share/man
+DEB_CONFIGURE_PREFIX := /opt/trinity
+DEB_CONFIGURE_INFODIR := /opt/trinity/share/info
+
+cdbs_configure_flags := --with-qt-dir=/usr/share/qt3 --disable-rpath --with-xinerama $(cdbs_kde_enable_final) $(cdbs_kde_enable_debug)
+
+DEB_CONFIGURE_EXTRA_FLAGS := --prefix=/opt/trinity --with-extra-libs=/opt/trinity/lib
+
+DEB_CMAKE_EXTRA_FLAGS := \
+ -DCMAKE_INSTALL_PREFIX="/opt/trinity" \
+ -DCONFIG_INSTALL_DIR="/etc/trinity" \
+ -DSYSCONF_INSTALL_DIR="/etc/trinity" \
+ -DXDG_MENU_INSTALL_DIR="/etc/xdg/menus" \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_VERBOSE_MAKEFILE="ON" \
+ -DCMAKE_SKIP_RPATH="OFF" \
+ -DBUILD_ALL="ON" \
+ -DWITH_WEBCAM="ON" \
+ -DWITH_ARTS="ON" \
+ -DWITH_SLP="ON" \
+ -DBUILD_KOPETE_PROTOCOL_ALL="ON" \
+ -DBUILD_KOPETE_PLUGIN_ALL="ON"
+
+DEB_DH_STRIP_ARGS := --dbg-package=kdenetwork-trinity-dbg
+
+DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
+ && echo xz || echo bzip2)
+
+PACKAGES_WITH_LIBS := librss1-trinity kopete-trinity ksirc-trinity kwifimanager-trinity
+
+DEB_DH_MAKESHLIBS_ARGS_librss1-trinity := -V'librss1-trinity (>= 4:3.5.8-1)'
+DEB_DH_MAKESHLIBS_ARGS_kopete-trinity := -V'kopete-trinity (>= 4:3.5.8-1)'
+
+#shlibs_ver = 4:3.5.0-1
+#$(foreach p,$(PACKAGES_WITH_LIBS),$(eval DEB_DH_MAKESHLIBS_ARGS_$(p) := -V'$(p) (>= $(shlibs_ver))'))
+
+DEB_FIXPERMS_EXCLUDE := opt/trinity/bin/kppp opt/trinity/bin/kppplogview \
+ opt/trinity/etc/ppp/peers/kppp-options
+
+DOC_HTML_PRUNE := kcontrol
+
+binary-install/kppp-trinity::
+ chown root:dip debian/kppp-trinity/opt/trinity/bin/kppp*
+ chown root:dip debian/kppp-trinity/opt/trinity/etc/ppp/peers/kppp-options
+ chmod 4754 debian/kppp-trinity/opt/trinity/bin/kppp
+ chmod 0754 debian/kppp-trinity/opt/trinity/bin/kppplogview
+ chmod 0640 debian/kppp-trinity/opt/trinity/etc/ppp/peers/kppp-options