summaryrefslogtreecommitdiffstats
path: root/redhat/dependencies/sip4-tqt/sip4-tqt.spec
diff options
context:
space:
mode:
authorFrançois Andriot <albator78@libertysurf.fr>2013-07-19 20:47:36 +0200
committerFrançois Andriot <albator78@libertysurf.fr>2013-07-19 20:47:36 +0200
commit81cfe3de65065da2e9693971b05ee35cca6bf483 (patch)
treefa557dc984def90bd9bcbc44e8c98c65923ecd94 /redhat/dependencies/sip4-tqt/sip4-tqt.spec
parent04dea0b400cc28566c4a09214a332a2360f8ed3b (diff)
downloadtde-packaging-81cfe3de65065da2e9693971b05ee35cca6bf483.tar.gz
tde-packaging-81cfe3de65065da2e9693971b05ee35cca6bf483.zip
RPM Packaging: more updates
Diffstat (limited to 'redhat/dependencies/sip4-tqt/sip4-tqt.spec')
-rw-r--r--redhat/dependencies/sip4-tqt/sip4-tqt.spec136
1 files changed, 136 insertions, 0 deletions
diff --git a/redhat/dependencies/sip4-tqt/sip4-tqt.spec b/redhat/dependencies/sip4-tqt/sip4-tqt.spec
new file mode 100644
index 000000000..2de637176
--- /dev/null
+++ b/redhat/dependencies/sip4-tqt/sip4-tqt.spec
@@ -0,0 +1,136 @@
+# Some distribution already provides this package.
+# Mageia 3
+
+%{!?python_sitearch:%global python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
+
+# Always install under standard prefix
+%define tde_prefix /usr
+
+%define tde_includedir %{tde_prefix}/include
+%define tde_libdir %{tde_prefix}/%{_lib}
+
+Name: trinity-sip4-tqt
+Epoch: 2
+Version: 14.0.0
+Release: %{?!preversion:1}%{?preversion:0_%{preversion}}%{?dist}%{?_variant}
+License: GPL
+Summary: Python/C++ bindings generator runtime library
+Group: System Environment/Libraries
+
+Vendor: Trinity Project
+Packager: Francois Andriot <francois.andriot@free.fr>
+
+Prefix: %{tde_prefix}
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
+
+Source0: %{name}-%{version}%{?preversion:~%{preversion}}.tar.gz
+
+BuildRequires: trinity-tqtinterface-devel >= %{version}
+
+# TDE specific building variables
+BuildRequires: cmake >= 2.8
+BuildRequires: trinity-tqt3-devel >= %{version}
+
+%description
+
+##########
+
+%package -n python-sip
+Summary: Python/C++ bindings generator runtime library
+Epoch: 2
+
+%description -n python-sip
+SIP is a tool for generating bindings for C++ classes with some ideas
+borrowed from SWIG, but capable of tighter bindings because of its
+specificity towards C++ and Python.
+
+%post -n python-sip
+/sbin/ldconfig || :
+
+%postun -n python-sip
+/sbin/ldconfig || :
+
+%files -n python-sip
+%defattr(-,root,root,-)
+%{python_sitearch}/sip.so
+%{python_sitearch}/sipconfig.py
+%{python_sitearch}/sipdistutils.py
+
+
+##########
+
+%package -n python-sip-devel
+Summary: Python/C++ bindings generator development files
+Group: Development/Libraries
+Requires: python-sip = %{version}-%{release}
+
+%description -n python-sip-devel
+SIP is a tool for generating bindings for C++ classes with some ideas
+borrowed from SWIG, but capable of tighter bindings because of its
+specificity towards C++ and Python.
+
+SIP was originally designed to generate Python bindings for KDE and so
+has explicit support for the signal slot mechanism used by the Qt/KDE
+class libraries.
+
+Features:
+- connecting Qt signals to Python functions and class methods
+- connecting Python signals to Qt slots
+- overloading virtual member functions with Python class methods
+- protected member functions
+- abstract classes
+- enumerated types
+- global class instances
+- static member functions.
+
+This package contains the code generator tool and the development headers
+needed to develop Python bindings with sip.
+
+%post -n python-sip-devel
+/sbin/ldconfig || :
+
+%postun -n python-sip-devel
+/sbin/ldconfig || :
+
+%files -n python-sip-devel
+%defattr(-,root,root,-)
+%{_bindir}/sip
+%{_includedir}/python*/sip.h
+
+##########
+
+%if 0%{?suse_version} || 0%{?pclinuxos}
+%debug_package
+%endif
+
+
+%prep
+%setup -q -n %{name}-%{version}%{?preversion:~%{preversion}}
+
+
+%build
+unset QTDIR QTINC QTLIB
+export PKG_CONFIG_PATH="%{tde_libdir}/pkgconfig"
+
+mkdir build
+cd build
+python ../configure.py \
+ -d %{python_sitearch} \
+ -u STRIP="" \
+ CFLAGS="${RPM_OPT_FLAGS} -I%{_includedir}/tqt -I%{_includedir}/tqt3" \
+ CFLAGS_RELEASE="" \
+ CXXFLAGS="${RPM_OPT_FLAGS} -I%{_includedir}/tqt -I%{_includedir}/tqt3" \
+ CXXFLAGS_RELEASE=""
+
+
+%install
+%__rm -rf %{?buildroot}
+%__make install DESTDIR=%{?buildroot} -C build
+
+%clean
+%__rm -rf %{?buildroot}
+
+
+%changelog
+* Thu Feb 16 2012 Francois Andriot <francois.andriot@free.fr> - 14.0.0-1
+- Initial build for TDE R14, using 'tqt3' instead of 'qt3'