summaryrefslogtreecommitdiffstats
path: root/arch/3.5.13/trinity-base/trinity-arts/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'arch/3.5.13/trinity-base/trinity-arts/PKGBUILD')
-rw-r--r--arch/3.5.13/trinity-base/trinity-arts/PKGBUILD80
1 files changed, 80 insertions, 0 deletions
diff --git a/arch/3.5.13/trinity-base/trinity-arts/PKGBUILD b/arch/3.5.13/trinity-base/trinity-arts/PKGBUILD
new file mode 100644
index 000000000..3edb15cde
--- /dev/null
+++ b/arch/3.5.13/trinity-base/trinity-arts/PKGBUILD
@@ -0,0 +1,80 @@
+# $Id$
+# Maintainer: David C. Rankin <drankinatty@gmail.com>
+#
+# All modifications and uses of this file are licensed under
+# the software for which this file was made for, should the software
+# be under an Open Source License, at least version 1.9, defined
+# by the Open Source Initiative. In other cases, this file is automatically
+# released to the Public Domain.
+#
+
+pkgname=trinity-arts
+pkgver=3513
+pkgrel=1
+arch=('i686' 'x86_64')
+url='http://www.kde.org'
+license=('GPL')
+groups=('trinity-base')
+pkgdesc="Trinity - arts"
+depends=('audiofile'
+ 'alsa-lib'
+ 'libmad'
+ 'libvorbis'
+ 'trinity-tqtinterface')
+makedepends=('pkgconfig' 'cmake' 'autoconf')
+provides=('trinity-arts')
+conflicts=('trinity-arts')
+replaces=('trinity-arts')
+options=('libtool' '!strip')
+source=(http://mirror.its.uidaho.edu/pub/trinity/releases/3.5.13/dependencies/arts-3.5.13.tar.gz)
+md5sums=('109124dabb1aaa9d44eb32e43b549142')
+
+# set Qt location (not needed if profile.d/q3.sh present, set prefix (not used)
+_qtdir=/opt/qt
+_prefix=${_qtdir}
+
+build() {
+
+
+ msg "Setting PATH, CMAKE and Trinity Environment variables"
+ if [[ -r /etc/profile.d/qt3.sh ]]; then
+ . /etc/profile.d/qt3.sh
+ [[ -n $QTDIR ]] && _qtdir=$QTDIR
+ else
+ [[ ${PATH%%:*} =~ ${_qtdir}/bin ]] || export PATH=${_qtdir}/bin:$PATH
+ fi
+
+ # exports not required with /opt/qt/include in the right place
+ # export CMAKE_PREFIX_PATH=$QTDIR
+ # export CMAKE_INCLUDE_PATH=/opt/qt/include:/opt/qt/include/tqt
+
+ trinity_prefix="/opt/trinity"
+
+ cd $srcdir
+ msg "Creating out-of-source build directory: ${srcdir}/build"
+ mkdir -p build
+ cd build
+
+ msg "Starting cmake..."
+ cmake ${srcdir}/dependencies/arts/ \
+ -DCMAKE_INSTALL_PREFIX=${trinity_prefix} \
+ -DQT_VERSION=3 || return 1
+
+# -DQT_VERSION=3 \
+# -DWITH_QT3=ON \
+# -DQT_LIBRARY_DIRS=/opt/qt/lib
+
+ make VERBOSE=1
+
+}
+
+package() {
+ msg "Packaging - $pkgname-$pkgver"
+
+# cd ${srcdir}/${_svnmod}
+ cd ${srcdir}/build
+
+ make DESTDIR="$pkgdir/" install
+
+# rm -r ${srcdir}/${_svnmod}
+}