summaryrefslogtreecommitdiffstats
path: root/arch/3.5.13/trinity-extras/trinity-kpowersave/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'arch/3.5.13/trinity-extras/trinity-kpowersave/PKGBUILD')
-rw-r--r--arch/3.5.13/trinity-extras/trinity-kpowersave/PKGBUILD68
1 files changed, 68 insertions, 0 deletions
diff --git a/arch/3.5.13/trinity-extras/trinity-kpowersave/PKGBUILD b/arch/3.5.13/trinity-extras/trinity-kpowersave/PKGBUILD
new file mode 100644
index 000000000..566bb4d98
--- /dev/null
+++ b/arch/3.5.13/trinity-extras/trinity-kpowersave/PKGBUILD
@@ -0,0 +1,68 @@
+# $Id$
+# Maintainer: David C. Rankin <drankinatty@gmail.com>
+#
+# All modifications and uses of this file are licensed under
+# the software for which this file was made for, should the software
+# be under an Open Source License, at least version 1.9, defined
+# by the Open Source Initiative. In other cases, this file is automatically
+# released to the Public Domain.
+#
+
+pkgname=trinity-kpowersave
+pkgver=3513
+pkgrel=1
+arch=('i686' 'x86_64')
+url='http://www.trinitydesktop.org'
+license=('GPL')
+groups=('trinity-extras')
+pkgdesc="Trinity - kpowersave"
+depends=('xscreensaver'
+ 'libxss'
+ 'trinity-kdebase')
+makedepends=('pkgconfig' 'cmake' 'autoconf' 'imake')
+options=('libtool' '!strip')
+source=(http://mirror.its.uidaho.edu/pub/trinity/releases/3.5.13/applications/kpowersave-3.5.13.tar.gz)
+md5sums=('c887eb282fd035655b370f133ce58664')
+
+_svnmod=applications/kpowersave
+
+build() {
+
+ msg "Setting PATH, CMAKE and Trinity Environment variables"
+ export CMAKE_PREFIX_PATH=/opt/qt:/opt/trinity
+ export CMAKE_INCLUDE_PATH=/opt/qt/include:/opt/qt/include/tqt:/usr/include/dbus-1.0:/opt/trinity/include:/opt/trinity/include/libkrandr
+ export LD_LIBRARY_PATH=/opt/trinity/lib:/opt/trinity/lib/kde3:$LD_LIBRARY_PATH
+ export PKG_CONFIG_PATH=:/opt/trinity/lib/pkgconfig:/opt/qt/lib/pkgconfig
+
+ # patch for inactivity.cpp
+ # patch -p0 -i ${srcdir}/kpowersave-app-inactivity.cpp.patch || return 1
+
+ trinity_prefix="/opt/trinity"
+
+ cd $srcdir
+ msg "Creating out-of-source build directory: ${srcdir}/build"
+ mkdir -p build
+ cd build
+
+ msg "Starting cmake..."
+ cmake ${srcdir}/${_svnmod} \
+ -DCMAKE_INSTALL_PREFIX=${trinity_prefix} \
+ -DCMAKE_VERBOSE_MAKEFILE=ON \
+ -DQT_VERSION=3 \
+ -DWITH_QT3=ON \
+ -DQTDIR=/opt/qt \
+ -DQT_DOCDIR=/opt/qt/man \
+ -DQT_LIBRARY_DIRS=/opt/qt/lib \
+ -DBUILD_ALL=ON
+ make
+}
+
+package() {
+ msg "Packaging - $pkgname-$pkgver"
+# cd ${srcdir}/${_svnmod}
+ cd ${srcdir}/build
+
+ make DESTDIR="$pkgdir/" install
+
+# rm -r ${srcdir}/${_svnmod}
+}