summaryrefslogtreecommitdiffstats
path: root/debian/_base/applications/kasablanca
diff options
context:
space:
mode:
Diffstat (limited to 'debian/_base/applications/kasablanca')
-rw-r--r--debian/_base/applications/kasablanca/debian/cdbs/debian-qt-kde.mk115
-rw-r--r--debian/_base/applications/kasablanca/debian/cdbs/kde.mk89
-rw-r--r--debian/_base/applications/kasablanca/debian/cdbs/versions.pl19
-rw-r--r--debian/_base/applications/kasablanca/debian/changelog25
-rw-r--r--debian/_base/applications/kasablanca/debian/compat1
-rw-r--r--debian/_base/applications/kasablanca/debian/control24
-rw-r--r--debian/_base/applications/kasablanca/debian/copyright28
-rw-r--r--debian/_base/applications/kasablanca/debian/docs1
-rw-r--r--debian/_base/applications/kasablanca/debian/kasablanca.xml149
-rw-r--r--debian/_base/applications/kasablanca/debian/manpages1
-rw-r--r--debian/_base/applications/kasablanca/debian/menu7
-rw-r--r--debian/_base/applications/kasablanca/debian/patches/04_am_maintainer_mode.diff11
-rw-r--r--debian/_base/applications/kasablanca/debian/patches/06_disable_no_undefined.diff18
-rw-r--r--debian/_base/applications/kasablanca/debian/patches/series2
-rwxr-xr-xdebian/_base/applications/kasablanca/debian/rules45
-rw-r--r--debian/_base/applications/kasablanca/debian/source.lintian-overrides2
-rw-r--r--debian/_base/applications/kasablanca/debian/source/format1
-rw-r--r--debian/_base/applications/kasablanca/debian/source/options6
18 files changed, 544 insertions, 0 deletions
diff --git a/debian/_base/applications/kasablanca/debian/cdbs/debian-qt-kde.mk b/debian/_base/applications/kasablanca/debian/cdbs/debian-qt-kde.mk
new file mode 100644
index 000000000..9f8f97776
--- /dev/null
+++ b/debian/_base/applications/kasablanca/debian/cdbs/debian-qt-kde.mk
@@ -0,0 +1,115 @@
+ifndef _cdbs_bootstrap
+_cdbs_scripts_path ?= /usr/lib/cdbs
+_cdbs_rules_path ?= /usr/share/cdbs/1/rules
+_cdbs_class_path ?= /usr/share/cdbs/1/class
+endif
+
+ifndef _cdbs_class_debian-qt-kde
+_cdbs_class_debian-qt-kde := 1
+
+# Note: This _must_ be included before autotools.mk, or it won't work.
+common-configure-arch common-configure-indep:: debian/stamp-cvs-make
+debian/stamp-cvs-make:
+ cp -Rp /usr/share/aclocal/libtool.m4 admin/libtool.m4.in
+ifneq "$(wildcard /usr/share/libtool/config/ltmain.sh)" ""
+ cp -Rp /usr/share/libtool/config/ltmain.sh admin/ltmain.sh
+endif
+ifneq "$(wildcard /usr/share/libtool/build-aux/ltmain.sh)" ""
+ cp -Rp /usr/share/libtool/build-aux/ltmain.sh admin/ltmain.sh
+endif
+ $(MAKE) -C $(DEB_SRCDIR) -f admin/Makefile.common dist;
+ touch debian/stamp-cvs-make
+
+include debian/cdbs/kde.mk$(_cdbs_makefile_suffix)
+
+ifndef _cdbs_rules_patchsys_quilt
+DEB_PATCHDIRS := debian/patches/common debian/patches
+endif
+
+DEB_KDE_ENABLE_FINAL := yes
+DEB_INSTALL_DOCS_ALL :=
+
+DEB_DH_MAKESHLIBS_ARGS_ALL := -V
+DEB_SHLIBDEPS_INCLUDE = $(foreach p,$(PACKAGES_WITH_LIBS),debian/$(p)/usr/lib)
+
+ifeq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
+ cdbs_treat_me_gently_arches := arm m68k alpha ppc64 armel armeb
+ ifeq (,$(filter $(DEB_HOST_ARCH_CPU),$(cdbs_treat_me_gently_arches)))
+ cdbs_kde_enable_final = $(if $(DEB_KDE_ENABLE_FINAL),--enable-final,)
+ else
+ cdbs_kde_enable_final =
+ endif
+endif
+
+common-build-arch:: debian/stamp-man-pages
+debian/stamp-man-pages:
+ if ! test -d debian/man/out; then mkdir -p debian/man/out; fi
+ for f in $$(find debian/man -name '*.sgml'); do \
+ docbook-to-man $$f > debian/man/out/`basename $$f .sgml`.1; \
+ done
+ for f in $$(find debian/man -name '*.man'); do \
+ soelim -I debian/man $$f \
+ > debian/man/out/`basename $$f .man`.`head -n1 $$f | awk '{print $$NF}'`; \
+ done
+ touch debian/stamp-man-pages
+
+common-binary-indep::
+ ( set -e; \
+ tmpf=`mktemp debian/versions.XXXXXX`; \
+ perl debian/cdbs/versions.pl >$$tmpf; \
+ for p in $(DEB_INDEP_PACKAGES); do \
+ cat $$tmpf >>debian/$$p.substvars; \
+ done; \
+ rm -f $$tmpf )
+
+common-binary-arch::
+ ( set -e; \
+ tmpf=`mktemp debian/versions.XXXXXX`; \
+ perl debian/cdbs/versions.pl >$$tmpf; \
+ for p in $(DEB_ARCH_PACKAGES); do \
+ cat $$tmpf >>debian/$$p.substvars; \
+ done; \
+ rm -f $$tmpf )
+
+clean::
+ rm -rf debian/man/out
+ -rmdir debian/man
+ rm -f debian/stamp-man-pages
+ rm -rf debian/shlibs-check
+
+$(patsubst %,binary-install/%,$(DEB_PACKAGES)) :: binary-install/%:
+ if test -x /usr/bin/dh_desktop; then dh_desktop -p$(cdbs_curpkg) $(DEB_DH_DESKTOP_ARGS); fi
+ if test -e debian/$(cdbs_curpkg).lintian; then \
+ install -p -D -m644 debian/$(cdbs_curpkg).lintian \
+ debian/$(cdbs_curpkg)/usr/share/lintian/overrides/$(cdbs_curpkg); \
+ fi
+ if test -e debian/$(cdbs_curpkg).presubj; then \
+ install -p -D -m644 debian/$(cdbs_curpkg).presubj \
+ debian/$(cdbs_curpkg)/usr/share/bug/$(cdbs_curpkg)/presubj; \
+ fi
+
+binary-install/$(DEB_SOURCE_PACKAGE)-doc-html::
+ set -e; \
+ for doc in `cd $(DEB_DESTDIR)/opt/trinity/share/doc/tde/HTML/en; find . -name index.docbook`; do \
+ pkg=$${doc%/index.docbook}; pkg=$${pkg#./}; \
+ echo Building $$pkg HTML docs...; \
+ mkdir -p $(CURDIR)/debian/$(DEB_SOURCE_PACKAGE)-doc-html/opt/trinity/share/doc/tde/HTML/en/$$pkg; \
+ cd $(CURDIR)/debian/$(DEB_SOURCE_PACKAGE)-doc-html/opt/trinity/share/doc/tde/HTML/en/$$pkg; \
+ /opt/trinity/bin/meinproc $(DEB_DESTDIR)/opt/trinity/share/doc/tde/HTML/en/$$pkg/index.docbook; \
+ done
+ for pkg in $(DOC_HTML_PRUNE) ; do \
+ rm -rf debian/$(DEB_SOURCE_PACKAGE)-doc-html/opt/trinity/share/doc/tde/HTML/en/$$pkg; \
+ done
+
+clean::
+ if test -n "$(DEB_KDE_CVS_MAKE)" && test -d $(DEB_SRCDIR); then \
+ cd $(DEB_SRCDIR); \
+ find . -name Makefile.in -print | \
+ xargs --no-run-if-empty rm -f; \
+ rm -f Makefile.am acinclude.m4 aclocal.m4 config.h.in \
+ configure configure.files configure.in stamp-h.in \
+ subdirs; \
+ fi
+ rm -f debian/stamp-cvs-make
+
+endif
diff --git a/debian/_base/applications/kasablanca/debian/cdbs/kde.mk b/debian/_base/applications/kasablanca/debian/cdbs/kde.mk
new file mode 100644
index 000000000..1ac26c4b7
--- /dev/null
+++ b/debian/_base/applications/kasablanca/debian/cdbs/kde.mk
@@ -0,0 +1,89 @@
+# -*- mode: makefile; coding: utf-8 -*-
+# Copyright © 2003 Christopher L Cheney <ccheney@debian.org>
+# Description: A class for KDE packages; sets KDE environment variables, etc
+#
+# This program is free software; you can redistribute it and/or
+# modify it under the terms of the GNU General Public License as
+# published by the Free Software Foundation; either version 2, or (at
+# your option) any later version.
+#
+# This program is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA
+# 02111-1307 USA.
+
+_cdbs_scripts_path ?= /usr/lib/cdbs
+_cdbs_rules_path ?= /usr/share/cdbs/1/rules
+_cdbs_class_path ?= /usr/share/cdbs/1/class
+
+ifndef _cdbs_class_kde
+_cdbs_class_kde := 1
+
+# for dh_icons
+CDBS_BUILD_DEPENDS := $(CDBS_BUILD_DEPENDS), debhelper (>= 5.0.7ubuntu4)
+
+include $(_cdbs_rules_path)/buildcore.mk$(_cdbs_makefile_suffix)
+
+ifdef _cdbs_tarball_dir
+DEB_BUILDDIR = $(_cdbs_tarball_dir)/obj-$(DEB_BUILD_GNU_TYPE)
+else
+DEB_BUILDDIR = obj-$(DEB_BUILD_GNU_TYPE)
+endif
+
+include $(_cdbs_class_path)/autotools.mk$(_cdbs_makefile_suffix)
+
+export kde_cgidir = \$${libdir}/cgi-bin
+export kde_confdir = \$${sysconfdir}/trinity
+export kde_htmldir = \$${datadir}/doc/tde/HTML
+
+ifeq (,$(filter noopt,$(DEB_BUILD_OPTIONS)))
+ cdbs_kde_enable_final = $(if $(DEB_KDE_ENABLE_FINAL),--enable-final,)
+endif
+
+ifneq (,$(filter nostrip,$(DEB_BUILD_OPTIONS)))
+ cdbs_kde_enable_final =
+ cdbs_kde_enable_debug = --enable-debug=yes
+else
+ cdbs_kde_enable_debug = --disable-debug
+endif
+
+ifneq (,$(filter debug,$(DEB_BUILD_OPTIONS)))
+ cdbs_kde_enable_debug = --enable-debug=full
+endif
+
+cdbs_configure_flags += --with-qt-dir=/usr/share/qt3 --disable-rpath --with-xinerama $(cdbs_kde_enable_final) $(cdbs_kde_enable_debug)
+
+DEB_AC_AUX_DIR = $(DEB_SRCDIR)/admin
+DEB_CONFIGURE_INCLUDEDIR = "\$${prefix}/include/tde"
+DEB_COMPRESS_EXCLUDE = .dcl .docbook -license .tag .sty .el
+
+$(patsubst %,binary-install/%,$(DEB_PACKAGES)) :: binary-install/%:
+ if test -x /usr/bin/dh_icons; then dh_icons -p$(cdbs_curpkg) $(DEB_DH_ICONCACHE_ARGS); fi
+
+cleanbuilddir::
+ -$(if $(call cdbs_streq,$(DEB_BUILDDIR),$(DEB_SRCDIR)),,rm -rf $(DEB_BUILDDIR))
+
+common-build-arch common-build-indep:: debian/stamp-kde-apidox
+debian/stamp-kde-apidox:
+ $(if $(DEB_KDE_APIDOX),+$(DEB_MAKE_INVOKE) apidox)
+ touch $@
+
+common-install-arch common-install-indep:: common-install-kde-apidox
+common-install-kde-apidox::
+ $(if $(DEB_KDE_APIDOX),+$(DEB_MAKE_INVOKE) install-apidox DESTDIR=$(DEB_DESTDIR))
+
+clean::
+ rm -f debian/stamp-kde-apidox
+
+# This is a convenience target for calling manually. It's not part of
+# the build process.
+buildprep: clean apply-patches
+ $(MAKE) -f admin/Makefile.common dist
+ debian/rules clean
+
+endif
diff --git a/debian/_base/applications/kasablanca/debian/cdbs/versions.pl b/debian/_base/applications/kasablanca/debian/cdbs/versions.pl
new file mode 100644
index 000000000..1b110f7af
--- /dev/null
+++ b/debian/_base/applications/kasablanca/debian/cdbs/versions.pl
@@ -0,0 +1,19 @@
+#!/usr/bin/env perl
+
+use strict;
+use warnings;
+
+my $version = `dpkg-parsechangelog | awk '/^Version/ {print \$2}'`;
+my ($version3, $version3_next);
+my ($version2, $version2_next);
+
+($version3 = $version) =~ s/^(([^.]+\.){2}[^.+~-]+)[.+~-]?[^-]*-[^-]+$/$1/;
+($version2 = $version3) =~ s/\.[^.]+$//;
+
+($version3_next = $version3) =~ s/(?<=\.)(\d+)[a-z]?$/($1+1)/e;
+($version2_next = $version2) =~ s/(?<=\.)(\d+)$/($1+1)/e;
+
+print "TDE-Version3=$version3\n";
+print "TDE-Version2=$version2\n";
+print "TDE-Next-Version3=$version3_next\n";
+print "TDE-Next-Version2=$version2_next\n";
diff --git a/debian/_base/applications/kasablanca/debian/changelog b/debian/_base/applications/kasablanca/debian/changelog
new file mode 100644
index 000000000..22010973d
--- /dev/null
+++ b/debian/_base/applications/kasablanca/debian/changelog
@@ -0,0 +1,25 @@
+kasablanca-trinity (0.4.0.2-2ubuntu1) feisty; urgency=low
+
+ * Initial Release for TDE
+
+ -- Slávek Banko <slavek.banko@axis.cz> Fri, 26 Jul 2013 03:25:28 +0200
+
+kasablanca (0.4.0.2-2ubuntu1) feisty; urgency=low
+
+ * Fake sync.
+
+ -- Scott James Remnant <scott@ubuntu.com> Wed, 8 Nov 2006 15:32:58 -0800
+
+kasablanca (0.4.0.2-2) unstable; urgency=low
+
+ * Add menu file (Closes: #387328)
+ * Bump Standards-Version to 3.7.2
+
+ -- Fathi Boudra <fboudra@free.fr> Sun, 17 Sep 2006 01:17:16 +0200
+
+kasablanca (0.4.0.2-1) unstable; urgency=low
+
+ * Initial release Closes: #292874
+
+ -- Fathi Boudra <fboudra@free.fr> Tue, 21 Mar 2006 18:07:59 +0100
+
diff --git a/debian/_base/applications/kasablanca/debian/compat b/debian/_base/applications/kasablanca/debian/compat
new file mode 100644
index 000000000..7f8f011eb
--- /dev/null
+++ b/debian/_base/applications/kasablanca/debian/compat
@@ -0,0 +1 @@
+7
diff --git a/debian/_base/applications/kasablanca/debian/control b/debian/_base/applications/kasablanca/debian/control
new file mode 100644
index 000000000..7bb456127
--- /dev/null
+++ b/debian/_base/applications/kasablanca/debian/control
@@ -0,0 +1,24 @@
+Source: kasablanca-trinity
+Section: tde
+Priority: optional
+Maintainer: Debian TDE Extras Team <pkg-tde-extras@lists.alioth.debian.org>
+Uploaders: Fathi Boudra <fboudra@free.fr>, Mark Purcell <msp@debian.org>
+Build-Depends: cdbs, debhelper (>= 7.0.50~), quilt, automake, libtool, tdelibs14-trinity-dev, docbook2x, docbook-xml, libssl-dev
+Standards-Version: 3.8.3
+
+Package: kasablanca-trinity
+Architecture: any
+Depends: ${shlibs:Depends}, ${misc:Depends}
+Description: fast and free ftp client for TDE
+ Kasablanca is an ftp client, written in c++, using the tde libraries.
+ .
+ Features:
+ * ftps encryption via AUTH TLS
+ * fxp (direct server to server transfer), supporting alternative mode
+ * advanced bookmarking system
+ * fast responsive multithreaded engine
+ * concurrent connections to multiple hosts
+ * interactive transfer queue, movable by drag and drop
+ * small nifty features, like a skiplist
+ .
+ Homepage: http://kasablanca.berlios.de
diff --git a/debian/_base/applications/kasablanca/debian/copyright b/debian/_base/applications/kasablanca/debian/copyright
new file mode 100644
index 000000000..1424088cd
--- /dev/null
+++ b/debian/_base/applications/kasablanca/debian/copyright
@@ -0,0 +1,28 @@
+This package was debianized by Fathi Boudra <fboudra@free.fr> on
+Tue, 21 Mar 2006 18:07:59 +0100.
+
+It was downloaded from http://kasablanca.berlios.de
+
+Copyright Holder: (C) 2003-2004 Magnus Kulke <sikor_sxe@radicalapproach.de>
+
+Copyright for ftplib: (C) 1996-1998 Thomas Pfau <pfau@cnj.digex.net>
+
+Kasablanca and ftplib are under same license:
+
+ This package is free software; you can redistribute it and/or modify
+ it under the terms of the GNU General Public License as published by
+ the Free Software Foundation; either version 2 of the License, or
+ (at your option) any later version.
+
+ This package is distributed in the hope that it will be useful,
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ GNU General Public License for more details.
+
+ You should have received a copy of the GNU General Public License
+ along with this package; if not, write to the Free Software
+ Foundation, Inc., 51 Franklin St, Fifth Floor, Boston, MA 02110-1301 USA
+
+On Debian systems, the complete text of the GNU General
+Public License can be found in `/usr/share/common-licenses/GPL-2'.
+
diff --git a/debian/_base/applications/kasablanca/debian/docs b/debian/_base/applications/kasablanca/debian/docs
new file mode 100644
index 000000000..1333ed77b
--- /dev/null
+++ b/debian/_base/applications/kasablanca/debian/docs
@@ -0,0 +1 @@
+TODO
diff --git a/debian/_base/applications/kasablanca/debian/kasablanca.xml b/debian/_base/applications/kasablanca/debian/kasablanca.xml
new file mode 100644
index 000000000..5f142fd2b
--- /dev/null
+++ b/debian/_base/applications/kasablanca/debian/kasablanca.xml
@@ -0,0 +1,149 @@
+<?xml version='1.0' encoding='ISO-8859-1'?>
+<!DOCTYPE refentry PUBLIC "-//OASIS//DTD DocBook XML V4.2//EN"
+"http://www.oasis-open.org/docbook/xml/4.2/docbookx.dtd" [
+ <!ENTITY dhfirstname "<firstname>Fathi</firstname>">
+ <!ENTITY dhsurname "<surname>Boudra</surname>">
+ <!ENTITY dhdate "<date>mars 22, 2006</date>">
+ <!ENTITY dhsection "<manvolnum>1</manvolnum>">
+ <!ENTITY dhemail "<email>fboudra@free.fr</email>">
+ <!ENTITY dhusername "Fathi Boudra">
+ <!ENTITY dhucpackage "<refentrytitle>kasablanca</refentrytitle>">
+ <!ENTITY dhpackage "kasablanca">
+ <!ENTITY debian "<productname>Debian</productname>">
+ <!ENTITY gnu "<acronym>GNU</acronym>">
+ <!ENTITY gpl "&gnu; <acronym>GPL</acronym>">
+]>
+
+<refentry>
+ <refentryinfo>
+ <address>
+ &dhemail;
+ </address>
+ <author>
+ &dhfirstname;
+ &dhsurname;
+ </author>
+ <copyright>
+ <year>2006</year>
+ <holder>&dhusername;</holder>
+ </copyright>
+ &dhdate;
+ </refentryinfo>
+ <refmeta>
+ &dhucpackage;
+
+ &dhsection;
+ </refmeta>
+ <refnamediv>
+ <refname>&dhpackage;</refname>
+
+ <refpurpose>fast and free ftp client for TDE</refpurpose>
+ </refnamediv>
+ <refsynopsisdiv>
+ <cmdsynopsis>
+ <command>&dhpackage;</command>
+
+ <arg><option><replaceable>options</replaceable></option></arg>
+
+ </cmdsynopsis>
+ </refsynopsisdiv>
+ <refsect1>
+ <title>DESCRIPTION</title>
+
+ <para><command>&dhpackage;</command> is an ftp client, written in c++, using the tde libraries.</para>
+
+ <para>Features:
+ <simplelist>
+ <member>* ftps encryption via AUTH TLS</member>
+ <member>* fxp (direct server to server transfer), supporting alternative mode</member>
+ <member>* advanced bookmarking system</member>
+ <member>* fast responsive multithreaded engine</member>
+ <member>* concurrent connections to multiple hosts</member>
+ <member>* interactive transfer queue, movable by drag and drop</member>
+ <member>* small nifty features, like a skiplist</member>
+ </simplelist>
+ </para>
+
+ </refsect1>
+ <refsect1>
+ <title>OPTIONS</title>
+
+ <para>All TDE and Qt programs accept some common command-line options.
+ <command>&dhpackage;</command> has no application-specific options.</para>
+
+ <variablelist>
+ <varlistentry>
+ <term>
+ <option>--help</option>
+ </term>
+ <listitem>
+ <para>Show help about options</para>
+ </listitem>
+ </varlistentry>
+ <varlistentry>
+ <term>
+ <option>--help-qt</option>
+ </term>
+ <listitem>
+ <para>Show Qt specific options</para>
+ </listitem>
+ </varlistentry>
+ <varlistentry>
+ <term>
+ <option>--help-tde</option>
+ </term>
+ <listitem>
+ <para>Show TDE specific options</para>
+ </listitem>
+ </varlistentry>
+ <varlistentry>
+ <term>
+ <option>--help-all</option>
+ </term>
+ <listitem>
+ <para>Show all options</para>
+ </listitem>
+ </varlistentry>
+ <varlistentry>
+ <term>
+ <option>--author</option>
+ </term>
+ <listitem>
+ <para>Show author information</para>
+ </listitem>
+ </varlistentry>
+ <varlistentry>
+ <term><option>-v</option>
+ <option>--version</option>
+ </term>
+ <listitem>
+ <para>Show version information</para>
+ </listitem>
+ </varlistentry>
+ <varlistentry>
+ <term>
+ <option>--license</option>
+ </term>
+ <listitem>
+ <para>Show license information</para>
+ </listitem>
+ </varlistentry>
+ </variablelist>
+ </refsect1>
+ <refsect1>
+ <title>AUTHOR</title>
+
+ <para>This manual page was written by &dhusername; &lt;&dhemail;&gt; for
+ the &debian; system (but may be used by others). Permission is
+ granted to copy, distribute and/or modify this document under
+ the terms of the &gnu; General Public License, Version 2 any
+ later version published by the Free Software Foundation.
+ </para>
+ <para>
+ On Debian systems, the complete text of the GNU General Public
+ License can be found in /usr/share/common-licenses/GPL.
+ </para>
+
+ </refsect1>
+</refentry>
+
diff --git a/debian/_base/applications/kasablanca/debian/manpages b/debian/_base/applications/kasablanca/debian/manpages
new file mode 100644
index 000000000..8ae2d25f3
--- /dev/null
+++ b/debian/_base/applications/kasablanca/debian/manpages
@@ -0,0 +1 @@
+kasablanca.1
diff --git a/debian/_base/applications/kasablanca/debian/menu b/debian/_base/applications/kasablanca/debian/menu
new file mode 100644
index 000000000..2b2588878
--- /dev/null
+++ b/debian/_base/applications/kasablanca/debian/menu
@@ -0,0 +1,7 @@
+?package(kasablanca-trinity):\
+ needs="X11" \
+ hints="TDE" \
+ section="Apps/Net"\
+ title="kasablanca" \
+ longtitle="kasablanca - ftp client" \
+ command="/opt/trinity/bin/kasablanca"
diff --git a/debian/_base/applications/kasablanca/debian/patches/04_am_maintainer_mode.diff b/debian/_base/applications/kasablanca/debian/patches/04_am_maintainer_mode.diff
new file mode 100644
index 000000000..391a80285
--- /dev/null
+++ b/debian/_base/applications/kasablanca/debian/patches/04_am_maintainer_mode.diff
@@ -0,0 +1,11 @@
+--- a/admin/configure.in.min
++++ b/admin/configure.in.min
+@@ -38,6 +38,8 @@
+ dnl Automake doc recommends to do this only here. (Janos)
+ AM_INIT_AUTOMAKE(@MODULENAME@, @VERSION@) dnl searches for some needed programs
+
++AM_MAINTAINER_MODE
++
+ KDE_SET_PREFIX
+
+ dnl generate the config header
diff --git a/debian/_base/applications/kasablanca/debian/patches/06_disable_no_undefined.diff b/debian/_base/applications/kasablanca/debian/patches/06_disable_no_undefined.diff
new file mode 100644
index 000000000..05c932c3c
--- /dev/null
+++ b/debian/_base/applications/kasablanca/debian/patches/06_disable_no_undefined.diff
@@ -0,0 +1,18 @@
+--- a/admin/acinclude.m4.in
++++ b/admin/acinclude.m4.in
+@@ -1689,15 +1689,6 @@
+ KDE_USE_CLOSURE_TRUE="#"
+ KDE_USE_CLOSURE_FALSE=""
+ KDE_NO_UNDEFINED=""
+- case $host in
+- *-*-linux-gnu)
+- KDE_CHECK_COMPILER_FLAG([Wl,--no-undefined],
+- [KDE_CHECK_COMPILER_FLAG([Wl,--allow-shlib-undefined],
+- [KDE_NO_UNDEFINED="-Wl,--no-undefined -Wl,--allow-shlib-undefined"],
+- [KDE_NO_UNDEFINED=""])],
+- [KDE_NO_UNDEFINED=""])
+- ;;
+- esac
+ fi
+ AC_SUBST(KDE_USE_CLOSURE_TRUE)
+ AC_SUBST(KDE_USE_CLOSURE_FALSE)
diff --git a/debian/_base/applications/kasablanca/debian/patches/series b/debian/_base/applications/kasablanca/debian/patches/series
new file mode 100644
index 000000000..b8743ddd9
--- /dev/null
+++ b/debian/_base/applications/kasablanca/debian/patches/series
@@ -0,0 +1,2 @@
+04_am_maintainer_mode.diff
+06_disable_no_undefined.diff
diff --git a/debian/_base/applications/kasablanca/debian/rules b/debian/_base/applications/kasablanca/debian/rules
new file mode 100755
index 000000000..da587ae58
--- /dev/null
+++ b/debian/_base/applications/kasablanca/debian/rules
@@ -0,0 +1,45 @@
+#!/usr/bin/make -f
+
+include /usr/share/cdbs/1/rules/debhelper.mk
+include debian/cdbs/kde.mk
+#include /usr/share/cdbs/1/rules/patchsys-quilt.mk
+
+DEB_CONFIGURE_INCLUDEDIR := /opt/trinity/include
+DEB_CONFIGURE_MANDIR := /opt/trinity/share/man
+DEB_CONFIGURE_PREFIX := /opt/trinity
+DEB_CONFIGURE_INFODIR := /opt/trinity/share/info
+
+DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
+ && echo xz || echo bzip2)
+
+post-patches:: debian/stamp-bootstrap
+
+debian/stamp-bootstrap:
+ dh_testdir
+
+ # Regenerate build system
+ifneq "$(wildcard /usr/share/libtool/ltmain.sh)" ""
+ cp -f /usr/share/libtool/ltmain.sh admin/ltmain.sh
+endif
+ifneq "$(wildcard /usr/share/libtool/config/ltmain.sh)" ""
+ cp -f /usr/share/libtool/config/ltmain.sh admin/ltmain.sh
+endif
+ifneq "$(wildcard /usr/share/libtool/build-aux/ltmain.sh)" ""
+ cp -f /usr/share/libtool/build-aux/ltmain.sh admin/ltmain.sh
+endif
+ cp -f /usr/share/aclocal/libtool.m4 admin/libtool.m4.in
+
+ autoreconf --install && automake -f && \
+ $(MAKE) -f admin/Makefile.common && \
+ touch debian/stamp-bootstrap
+
+build/kasablanca-trinity::
+ /usr/bin/docbook2x-man debian/kasablanca.xml
+
+binary-install/kasablanca-trinity::
+ mv debian/$(cdbs_curpkg)/usr/share/man debian/$(cdbs_curpkg)/opt/trinity/share/
+
+clean::
+ dh_testdir
+ rm -f kasablanca.1
+ rm -f debian/stamp-bootstrap
diff --git a/debian/_base/applications/kasablanca/debian/source.lintian-overrides b/debian/_base/applications/kasablanca/debian/source.lintian-overrides
new file mode 100644
index 000000000..7349addb4
--- /dev/null
+++ b/debian/_base/applications/kasablanca/debian/source.lintian-overrides
@@ -0,0 +1,2 @@
+# Upstream distributes it like this ATM but cleans it in next release
+kasablanca-trinity source: source-contains-CVS-dir admin/CVS
diff --git a/debian/_base/applications/kasablanca/debian/source/format b/debian/_base/applications/kasablanca/debian/source/format
new file mode 100644
index 000000000..163aaf8d8
--- /dev/null
+++ b/debian/_base/applications/kasablanca/debian/source/format
@@ -0,0 +1 @@
+3.0 (quilt)
diff --git a/debian/_base/applications/kasablanca/debian/source/options b/debian/_base/applications/kasablanca/debian/source/options
new file mode 100644
index 000000000..72f1f5450
--- /dev/null
+++ b/debian/_base/applications/kasablanca/debian/source/options
@@ -0,0 +1,6 @@
+# Use xz instead of gzip
+compression = "xz"
+compression-level = 9
+
+# Don't run differences
+diff-ignore = .*