summaryrefslogtreecommitdiffstats
path: root/debian/_base/applications/kbarcode
diff options
context:
space:
mode:
Diffstat (limited to 'debian/_base/applications/kbarcode')
-rw-r--r--debian/_base/applications/kbarcode/debian/README.Debian107
-rw-r--r--debian/_base/applications/kbarcode/debian/cdbs/debian-qt-kde.mk119
-rw-r--r--debian/_base/applications/kbarcode/debian/cdbs/kde.mk91
-rw-r--r--debian/_base/applications/kbarcode/debian/cdbs/versions.pl19
-rw-r--r--debian/_base/applications/kbarcode/debian/changelog163
-rw-r--r--debian/_base/applications/kbarcode/debian/compat1
-rw-r--r--debian/_base/applications/kbarcode/debian/control35
-rw-r--r--debian/_base/applications/kbarcode/debian/copyright75
-rw-r--r--debian/_base/applications/kbarcode/debian/docs4
-rw-r--r--debian/_base/applications/kbarcode/debian/menu6
-rw-r--r--debian/_base/applications/kbarcode/debian/patches/.gitignore0
-rwxr-xr-xdebian/_base/applications/kbarcode/debian/rules20
-rw-r--r--debian/_base/applications/kbarcode/debian/source/format1
-rw-r--r--debian/_base/applications/kbarcode/debian/source/options6
14 files changed, 647 insertions, 0 deletions
diff --git a/debian/_base/applications/kbarcode/debian/README.Debian b/debian/_base/applications/kbarcode/debian/README.Debian
new file mode 100644
index 000000000..b0302c211
--- /dev/null
+++ b/debian/_base/applications/kbarcode/debian/README.Debian
@@ -0,0 +1,107 @@
+Debian kde-extras Team
+----------------------
+
+1. Contacts
+-----------
+
+General help requests
+ <debian-kde@lists.debian.org> mailing list
+ #debian-kde on irc
+
+Packaging queries
+ <debian-qt-kde@lists.debian.org> mailing list
+ #debian-qt-kde on irc
+
+Maintainers
+ <pkg-kde-extras@lists.alioth.debian.org> mailing list
+
+
+2. Subversion repository
+------------------------
+
+You can browse it only at:
+
+http://svn.debian.org/wsvn/pkg-kde/kde-extras/
+
+To "checkout" the repository use these commands:
+
+ $ svn co svn+ssh://${ALIOTH_USERNAME}@svn.debian.org/svn/pkg-kde/kde-extras
+
+Authorized SSH keys are controlled at https://alioth.debian.org/account/
+
+The repository layout is:
+
+- packagename/
+    - trunk/
+    - branches/
+    - tags/
+        - 0.7.2-1/
+        - 0.7.2-2/
+        - 0.7.2-2ubuntu1/
+        - 0.7.2-2ubuntu2/
+        - 0.7.2-2ubuntu3/
+        - 0.8.0/
+        ...
+
+If only one version of the package is available at the time, development must
+be made at trunk/ dir, copying the dir to tags/'pkg-version' each time a new
+release is made.
+
+When, at some point, the need to have two different versions at the same time
+arises (for example, if we need a version to be in unstable and a different one
+to be in experimental), experimental development will be made in trunk/ and
+if a new unstable package needs to be cooked, copying
+tag/'latest_version_in_sid' to tag/'latest_version_in_sid'+1 will make the
+trick.
+
+3. Using svn-buildpackage
+--------------------------
+
+Packages with an upstream tarball will require you to set the mergeWithUpstream
+property first (from the package root) so that svn-buildpackage will look for
+the .orig.tar.gz in the ../tarballs directory.
+
+ % svn propset mergeWithUpstream 1 debian
+
+Please note that this only works for packages which have only the debian/
+directory committed. Consequently, you must use CDBS's simple-patchsys.mk or
+dpatch to modify the upstream sources.
+
+After you have finished and committed your Debian patches via
+
+ % svn commit [PACKAGE]
+
+as well as copying the orig.tar.gz to ../tarballs/ if necessary, you may build
+your package with the following commands:
+
+ % svn-buildpackage --svn-ignore-new -rfakeroot
+
+Please, don't commit tarballs/ or build-area/ directories to SVN.
+
+4. Tarballs and Build-area directories
+------------------------------------
+
+During pkg development before uploaded to debian the tarballs can be found at:
+
+ http://pkg-kde.alioth.debian.org/kde-extra/orig.tar.gz/
+
+You need to place those dirs in the parent directory of the one from which you're
+running svn-buildpackage. Usually this means placing tarballs/ and build-area/ dirs
+in 'pkgname'/ dir, at the same level as trunk/
+
+If you want to compile inside one version in tags/ dir, you'll need to place those
+dirs inside that dir. Of course the easiest and cleanest way of doing it is
+by making a symlink of those dirs inside tags/ dir.
+
+5. Using svn-inject
+-------------------
+
+To inject a new package into the Debian KDE Extras svn archive you should use svn-inject(1)
+as follows:
+
+ svn-inject -o <package>.dsc svn+ssh://${ALIOTH_USERNAME}@svn.debian.org/svn/pkg-kde/kde-extras
+
+Type in your alioth password a few hundred times :-) and your package should be
+uploaded to the archive. Note you will also need to manually copy the
+package.orig.tar.gz to your tarballs directory. The -o option is important as
+this ensures that we 'Only keep modified files under SVN control'
diff --git a/debian/_base/applications/kbarcode/debian/cdbs/debian-qt-kde.mk b/debian/_base/applications/kbarcode/debian/cdbs/debian-qt-kde.mk
new file mode 100644
index 000000000..60310a01a
--- /dev/null
+++ b/debian/_base/applications/kbarcode/debian/cdbs/debian-qt-kde.mk
@@ -0,0 +1,119 @@
+ifndef _cdbs_bootstrap
+_cdbs_scripts_path ?= /usr/lib/cdbs
+_cdbs_rules_path ?= /usr/share/cdbs/1/rules
+_cdbs_class_path ?= /usr/share/cdbs/1/class
+endif
+
+ifndef _cdbs_class_debian-qt-kde
+_cdbs_class_debian-qt-kde := 1
+
+# Note: This _must_ be included before autotools.mk, or it won't work.
+common-configure-arch common-configure-indep:: debian/stamp-cvs-make
+debian/stamp-cvs-make:
+ifndef _cdbs_class_cmake
+ cp -Rp /usr/share/aclocal/libtool.m4 admin/libtool.m4.in
+ifneq "$(wildcard /usr/share/libtool/config/ltmain.sh)" ""
+ cp -Rp /usr/share/libtool/config/ltmain.sh admin/ltmain.sh
+endif
+ifneq "$(wildcard /usr/share/libtool/build-aux/ltmain.sh)" ""
+ cp -Rp /usr/share/libtool/build-aux/ltmain.sh admin/ltmain.sh
+endif
+ $(MAKE) -C $(DEB_SRCDIR) -f admin/Makefile.common dist;
+endif
+ touch debian/stamp-cvs-make
+
+include debian/cdbs/kde.mk$(_cdbs_makefile_suffix)
+
+ifndef _cdbs_rules_patchsys_quilt
+DEB_PATCHDIRS := debian/patches/common debian/patches
+endif
+
+DEB_KDE_ENABLE_FINAL := yes
+DEB_INSTALL_DOCS_ALL :=
+
+DEB_DH_MAKESHLIBS_ARGS_ALL := -V
+DEB_SHLIBDEPS_INCLUDE = $(foreach p,$(PACKAGES_WITH_LIBS),debian/$(p)/usr/lib)
+
+ifeq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
+ cdbs_treat_me_gently_arches := arm m68k alpha ppc64 armel armeb
+ ifeq (,$(filter $(DEB_HOST_ARCH_CPU),$(cdbs_treat_me_gently_arches)))
+ cdbs_kde_enable_final = $(if $(DEB_KDE_ENABLE_FINAL),--enable-final,)
+ else
+ cdbs_kde_enable_final =
+ endif
+endif
+
+common-build-arch:: debian/stamp-man-pages
+debian/stamp-man-pages:
+ if ! test -d debian/man/out; then mkdir -p debian/man/out; fi
+ for f in $$(find debian/man -name '*.sgml'); do \
+ docbook-to-man $$f > debian/man/out/`basename $$f .sgml`.1; \
+ done
+ for f in $$(find debian/man -name '*.man'); do \
+ soelim -I debian/man $$f \
+ > debian/man/out/`basename $$f .man`.`head -n1 $$f | awk '{print $$NF}'`; \
+ done
+ touch debian/stamp-man-pages
+
+common-binary-indep::
+ ( set -e; \
+ tmpf=`mktemp debian/versions.XXXXXX`; \
+ perl debian/cdbs/versions.pl >$$tmpf; \
+ for p in $(DEB_INDEP_PACKAGES); do \
+ cat $$tmpf >>debian/$$p.substvars; \
+ done; \
+ rm -f $$tmpf )
+
+common-binary-arch::
+ ( set -e; \
+ tmpf=`mktemp debian/versions.XXXXXX`; \
+ perl debian/cdbs/versions.pl >$$tmpf; \
+ for p in $(DEB_ARCH_PACKAGES); do \
+ cat $$tmpf >>debian/$$p.substvars; \
+ done; \
+ rm -f $$tmpf )
+
+clean::
+ rm -rf debian/man/out
+ -rmdir debian/man
+ rm -f debian/stamp-man-pages
+ rm -rf debian/shlibs-check
+
+$(patsubst %,binary-install/%,$(DEB_PACKAGES)) :: binary-install/%:
+ if test -x /usr/bin/dh_desktop; then dh_desktop -p$(cdbs_curpkg) $(DEB_DH_DESKTOP_ARGS); fi
+ if test -e debian/$(cdbs_curpkg).lintian; then \
+ install -p -D -m644 debian/$(cdbs_curpkg).lintian \
+ debian/$(cdbs_curpkg)/usr/share/lintian/overrides/$(cdbs_curpkg); \
+ fi
+ if test -e debian/$(cdbs_curpkg).presubj; then \
+ install -p -D -m644 debian/$(cdbs_curpkg).presubj \
+ debian/$(cdbs_curpkg)/usr/share/bug/$(cdbs_curpkg)/presubj; \
+ fi
+
+binary-install/$(DEB_SOURCE_PACKAGE)-doc-html::
+ set -e; \
+ for doc in `cd $(DEB_DESTDIR)/opt/trinity/share/doc/tde/HTML/en; find . -name index.docbook`; do \
+ pkg=$${doc%/index.docbook}; pkg=$${pkg#./}; \
+ echo Building $$pkg HTML docs...; \
+ mkdir -p $(CURDIR)/debian/$(DEB_SOURCE_PACKAGE)-doc-html/opt/trinity/share/doc/tde/HTML/en/$$pkg; \
+ cd $(CURDIR)/debian/$(DEB_SOURCE_PACKAGE)-doc-html/opt/trinity/share/doc/tde/HTML/en/$$pkg; \
+ /opt/trinity/bin/meinproc $(DEB_DESTDIR)/opt/trinity/share/doc/tde/HTML/en/$$pkg/index.docbook; \
+ done
+ for pkg in $(DOC_HTML_PRUNE) ; do \
+ rm -rf debian/$(DEB_SOURCE_PACKAGE)-doc-html/opt/trinity/share/doc/tde/HTML/en/$$pkg; \
+ done
+
+clean::
+ifndef _cdbs_class_cmake
+ if test -n "$(DEB_KDE_CVS_MAKE)" && test -d $(DEB_SRCDIR); then \
+ cd $(DEB_SRCDIR); \
+ find . -name Makefile.in -print | \
+ xargs --no-run-if-empty rm -f; \
+ rm -f Makefile.am acinclude.m4 aclocal.m4 config.h.in \
+ configure configure.files configure.in stamp-h.in \
+ subdirs; \
+ fi
+endif
+ rm -f debian/stamp-cvs-make
+
+endif
diff --git a/debian/_base/applications/kbarcode/debian/cdbs/kde.mk b/debian/_base/applications/kbarcode/debian/cdbs/kde.mk
new file mode 100644
index 000000000..80176d63e
--- /dev/null
+++ b/debian/_base/applications/kbarcode/debian/cdbs/kde.mk
@@ -0,0 +1,91 @@
+# -*- mode: makefile; coding: utf-8 -*-
+# Copyright © 2003 Christopher L Cheney <ccheney@debian.org>
+# Description: A class for KDE packages; sets KDE environment variables, etc
+#
+# This program is free software; you can redistribute it and/or
+# modify it under the terms of the GNU General Public License as
+# published by the Free Software Foundation; either version 2, or (at
+# your option) any later version.
+#
+# This program is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA
+# 02111-1307 USA.
+
+_cdbs_scripts_path ?= /usr/lib/cdbs
+_cdbs_rules_path ?= /usr/share/cdbs/1/rules
+_cdbs_class_path ?= /usr/share/cdbs/1/class
+
+ifndef _cdbs_class_kde
+_cdbs_class_kde := 1
+
+# for dh_icons
+CDBS_BUILD_DEPENDS := $(CDBS_BUILD_DEPENDS), debhelper (>= 5.0.7ubuntu4)
+
+include $(_cdbs_rules_path)/buildcore.mk$(_cdbs_makefile_suffix)
+
+ifdef _cdbs_tarball_dir
+DEB_BUILDDIR = $(_cdbs_tarball_dir)/obj-$(DEB_BUILD_GNU_TYPE)
+else
+DEB_BUILDDIR = obj-$(DEB_BUILD_GNU_TYPE)
+endif
+
+ifndef _cdbs_class_cmake
+include $(_cdbs_class_path)/autotools.mk$(_cdbs_makefile_suffix)
+endif
+
+export kde_cgidir = \$${libdir}/cgi-bin
+export kde_confdir = \$${sysconfdir}/trinity
+export kde_htmldir = \$${datadir}/doc/tde/HTML
+
+ifeq (,$(filter noopt,$(DEB_BUILD_OPTIONS)))
+ cdbs_kde_enable_final = $(if $(DEB_KDE_ENABLE_FINAL),--enable-final,)
+endif
+
+ifneq (,$(filter nostrip,$(DEB_BUILD_OPTIONS)))
+ cdbs_kde_enable_final =
+ cdbs_kde_enable_debug = --enable-debug=yes
+else
+ cdbs_kde_enable_debug = --disable-debug
+endif
+
+ifneq (,$(filter debug,$(DEB_BUILD_OPTIONS)))
+ cdbs_kde_enable_debug = --enable-debug=full
+endif
+
+cdbs_configure_flags += --with-qt-dir=/usr/share/qt3 --disable-rpath --with-xinerama $(cdbs_kde_enable_final) $(cdbs_kde_enable_debug)
+
+DEB_AC_AUX_DIR = $(DEB_SRCDIR)/admin
+DEB_CONFIGURE_INCLUDEDIR = "\$${prefix}/include"
+DEB_COMPRESS_EXCLUDE = .dcl .docbook -license .tag .sty .el
+
+$(patsubst %,binary-install/%,$(DEB_PACKAGES)) :: binary-install/%:
+ if test -x /usr/bin/dh_icons; then dh_icons -p$(cdbs_curpkg) $(DEB_DH_ICONCACHE_ARGS); fi
+
+cleanbuilddir::
+ -$(if $(call cdbs_streq,$(DEB_BUILDDIR),$(DEB_SRCDIR)),,rm -rf $(DEB_BUILDDIR))
+
+common-build-arch common-build-indep:: debian/stamp-kde-apidox
+debian/stamp-kde-apidox:
+ $(if $(DEB_KDE_APIDOX),+$(DEB_MAKE_INVOKE) apidox)
+ touch $@
+
+common-install-arch common-install-indep:: common-install-kde-apidox
+common-install-kde-apidox::
+ $(if $(DEB_KDE_APIDOX),+$(DEB_MAKE_INVOKE) install-apidox DESTDIR=$(DEB_DESTDIR))
+
+clean::
+ rm -f debian/stamp-kde-apidox
+
+# This is a convenience target for calling manually. It's not part of
+# the build process.
+buildprep: clean apply-patches
+ $(MAKE) -f admin/Makefile.common dist
+ debian/rules clean
+
+endif
diff --git a/debian/_base/applications/kbarcode/debian/cdbs/versions.pl b/debian/_base/applications/kbarcode/debian/cdbs/versions.pl
new file mode 100644
index 000000000..1b110f7af
--- /dev/null
+++ b/debian/_base/applications/kbarcode/debian/cdbs/versions.pl
@@ -0,0 +1,19 @@
+#!/usr/bin/env perl
+
+use strict;
+use warnings;
+
+my $version = `dpkg-parsechangelog | awk '/^Version/ {print \$2}'`;
+my ($version3, $version3_next);
+my ($version2, $version2_next);
+
+($version3 = $version) =~ s/^(([^.]+\.){2}[^.+~-]+)[.+~-]?[^-]*-[^-]+$/$1/;
+($version2 = $version3) =~ s/\.[^.]+$//;
+
+($version3_next = $version3) =~ s/(?<=\.)(\d+)[a-z]?$/($1+1)/e;
+($version2_next = $version2) =~ s/(?<=\.)(\d+)$/($1+1)/e;
+
+print "TDE-Version3=$version3\n";
+print "TDE-Version2=$version2\n";
+print "TDE-Next-Version3=$version3_next\n";
+print "TDE-Next-Version2=$version2_next\n";
diff --git a/debian/_base/applications/kbarcode/debian/changelog b/debian/_base/applications/kbarcode/debian/changelog
new file mode 100644
index 000000000..df15715c2
--- /dev/null
+++ b/debian/_base/applications/kbarcode/debian/changelog
@@ -0,0 +1,163 @@
+kbarcode-trinity (2.0.6-0ubuntu3) karmic; urgency=low
+
+ * Karmic rebuild
+
+ -- Timothy Pearson <kb9vqf@pearsoncomputing.net> Thu, 02 Jul 2009 16:08:00 -0600
+
+kbarcode-trinity (2.0.6-0ubuntu2) intrepid; urgency=low
+
+ * Moved Trinity to /opt/trinity
+ * Integrated properly with KDE4.2+
+
+ -- Timothy Pearson <kb9vqf@pearsoncomputing.net> Wed, 04 March 2009 01:11:00 -0600
+
+kbarcode-trinity (2.0.6-0ubuntu1) intrepid; urgency=low
+
+ * Added -trinity suffix
+
+ -- Timothy Pearson <kb9vqf@pearsoncomputing.net> Mon, 29 Dec 2008 18:47:00 -0600
+
+kbarcode (2.0.6-1) unstable; urgency=low
+
+ * New upstream release. (Closes: #445734, #445738)
+
+ [ Mark Purcell ]
+ * Update ./debian/rules get-orig-source for http://buildserver.net.
+
+ [ Fathi Boudra ]
+ * Update menu file to latest Debian menu policy.
+ * Add makebuilddir target to generate proper configure script with automake.
+ Workaround unsermake generated configure provided by upstream.
+
+ -- Fathi Boudra <fboudra@free.fr> Wed, 17 Oct 2007 15:43:24 +0200
+
+kbarcode (2.0.5-1) unstable; urgency=low
+
+ * New upstream release.
+
+ -- Fathi Boudra <fboudra@free.fr> Thu, 9 Nov 2006 10:09:24 +0100
+
+kbarcode (2.0.4-1) unstable; urgency=low
+
+ [ Mark Purcell ]
+ * New upstream release
+ * Ack NMU's:
+ - FTBFS: ICE on m68k, arm and hppa (Closes: #330937)
+ - FTBFS: build-depends on removed xlibs-dev (Closes: #346743)
+ - kbarcode_1.8.0-2(GNU/k*BSD): out of date config.sub/config.guess
+ (Closes: #303338)
+ - error in doc-base file (Closes: #215385)
+ - Package explicitely build-depends on g++-3.4 (Closes: #342975)
+ - [INTL:de] German PO file corrections (Closes: #314013)
+ - Please update config.* (Closes: #357331)
+
+ [ Fathi Boudra ]
+ * Added to Recommends: libqt3-mt-mysql | libqt3-mt-psql | libqt3-mt-odbc |
+ libqt3-mt-sqlite | libqt3-mt-ibase
+
+ -- Mark Purcell <msp@debian.org> Fri, 28 Jul 2006 21:30:19 +0100
+
+kbarcode (2.0.3-1) unstable; urgency=low
+
+ * New maintainer
+ * Maintainer: KDE Extras Team
+ * Uploaders: Fathi Boudra and Mark Purcell
+ * New upstream release (Closes: #278751, #320912, #345787, #357391)
+ * Converted package to cdbs
+ * compat: bumped to 5
+ * control:
+ * replaced Sections x11 by kde
+ * removed unneeded Build-depends: libx11-dev, libxext-dev, libxpm-dev,
+ libqt3-mt-dev
+ * bumped Standards-Version to 3.7.2
+ * removed unneeded Depends: libqt3-mt
+ * improved short and lon description
+ * copyright:
+ * added missing copyright for barkode and barcode.ps
+ * added barcode.ps license
+ * Added manpage (Closes: #370547)
+ * Added watch file
+ * Fixed menu by deleting kderemove entry
+
+ -- Fathi Boudra <fboudra@free.fr> Tue, 27 Jun 2006 17:59:57 +0200
+
+kbarcode (1.8.0-3.3) unstable; urgency=low
+
+ * Non-maintainer upload.
+ * Move config.{guess,sub} to admin directory (Closes: #357331).
+
+ -- Luk Claes <luk@debian.org> Thu, 16 Mar 2006 23:51:42 +0100
+
+kbarcode (1.8.0-3.2) unstable; urgency=high
+
+ * Non-maintainer upload.
+ * Split xlibs-dev build-dep (Closes: #346743).
+ * Remove explicit build-dep on g++-3.4 (Closes: #342975).
+ * German PO file corrections (Closes: #314013).
+ * Support GNU/kFreeBSD (Closes: #303338).
+
+ -- Luk Claes <luk@debian.org> Wed, 11 Jan 2006 16:05:43 +0100
+
+kbarcode (1.8.0-3.1) unstable; urgency=medium
+
+ * Non-maintainer upload.
+ * Build-dep on g++-3.4 on arm, hppa and m68k (closes: #330937).
+
+ -- Luk Claes <luk@debian.org> Sat, 1 Oct 2005 20:03:32 +0200
+
+kbarcode (1.8.0-3) unstable; urgency=low
+
+ * Fixed the Qt/KDE transition problems (closes: #327942).
+
+ -- Theodore Karkoulis <bilbo@debian.org> Sat, 17 Sep 2005 18:12:10 +0300
+
+kbarcode (1.8.0-2) unstable; urgency=low
+
+ * Applied the patches from Andreas Jochens, closes: #258475, #286981.
+
+ -- Theodore Karkoulis <bilbo@debian.org> Tue, 4 Jan 2005 17:16:05 +0200
+
+kbarcode (1.8.0-1) unstable; urgency=low
+
+ * New upstream release
+
+ -- Theodore Karkoulis <bilbo@debian.org> Sun, 29 Aug 2004 07:25:25 +0300
+
+kbarcode (1.6.2-1) unstable; urgency=low
+
+ * New upstream release
+
+ -- Theodore Karkoulis <bilbo@debian.org> Sun, 15 Feb 2004 19:00:42 +0200
+
+kbarcode (1.6.1-1) unstable; urgency=low
+
+ * New upstream Version
+ * Fixes the /usr/share/doc/kbarcode/html problem, closes: #215385
+
+ -- Theodore Karkoulis <bilbo@debian.org> Tue, 27 Jan 2004 11:05:20 +0200
+
+kbarcode (1.4.1-1) unstable; urgency=low
+
+ * New Upstream Version.
+
+ -- Theodore Karkoulis <bilbo@debian.org> Thu, 30 Oct 2003 23:52:02 +0200
+
+kbarcode (1.2.1-3) unstable; urgency=low
+
+ * Fixes the g++-3.3 compile problem, closes: #216751
+
+ -- Theodore Karkoulis <bilbo@debian.org> Mon, 27 Oct 2003 20:47:33 +0200
+
+kbarcode (1.2.1-2) unstable; urgency=low
+
+ * Fixes the xlibs-dev build dependency, closes: #212501, #212666.
+ * changelog
+
+ -- Theodore Karkoulis <bilbo@debian.org> Mon, 27 Oct 2003 20:47:06 +0200
+
+kbarcode (1.2.1-1) unstable; urgency=low
+
+ * Initial Release.
+
+ -- Theodore Karkoulis <bilbo@debian.org> Tue, 16 Sep 2003 13:36:54 +0300
+
diff --git a/debian/_base/applications/kbarcode/debian/compat b/debian/_base/applications/kbarcode/debian/compat
new file mode 100644
index 000000000..7f8f011eb
--- /dev/null
+++ b/debian/_base/applications/kbarcode/debian/compat
@@ -0,0 +1 @@
+7
diff --git a/debian/_base/applications/kbarcode/debian/control b/debian/_base/applications/kbarcode/debian/control
new file mode 100644
index 000000000..c17f68e8e
--- /dev/null
+++ b/debian/_base/applications/kbarcode/debian/control
@@ -0,0 +1,35 @@
+Source: kbarcode-trinity
+Section: tde
+Priority: optional
+Maintainer: Timothy Pearson <kb9vqf@pearsoncomputing.net>
+Uploaders: Fathi Boudra <fboudra@free.fr>, Mark Purcell <msp@debian.org>
+Build-Depends: cdbs, debhelper (>= 7.0.50~), quilt, cmake, tdelibs14-trinity-dev
+Standards-Version: 3.8.4
+
+Package: kbarcode-trinity
+Architecture: any
+Depends: ${shlibs:Depends}, ${misc:Depends}, barcode, imagemagick
+Replaces: kbarcode-trinity (<< 4:14.0.0~)
+Breaks: kbarcode-trinity (<< 4:14.0.0~)
+Recommends: libtqt3-mt-mysql | libtqt3-mt-psql | libtqt3-mt-odbc | libtqt3-mt-sqlite |
+ libtqt3-mt-ibase
+Description: barcode and label printing application for Trinity
+ KBarcode is a barcode and label printing application for Trinity. It can be used
+ to print everything from simple business cards up to complex labels with
+ several barcodes (e.g. article descriptions).
+ .
+ KBarcode comes with an easy to use WYSIWYG label designer, a setup wizard,
+ batch import of data for batch printing labels (directly from the delivery
+ note), thousands of predefined labels, database management tools and
+ translations in many languages. Even printing more than 10.000 labels in one
+ go is no problem for KBarcode. Data for printing can be imported from several
+ different data sources, including SQL databases, CSV files and the TDE address
+ book.
+ .
+ Additionally it is a simple barcode generator (similar to the old xbarcode you
+ might know). All major types of barcodes like EAN, UPC, CODE39 and ISBN are
+ supported. Even complex 2D barcodes are supported using third party tools. The
+ generated barcodes can be directly printed or you can export them into images
+ to use them in another application.
+ .
+ Homepage: http://www.kbarcode.net
diff --git a/debian/_base/applications/kbarcode/debian/copyright b/debian/_base/applications/kbarcode/debian/copyright
new file mode 100644
index 000000000..37bf717a2
--- /dev/null
+++ b/debian/_base/applications/kbarcode/debian/copyright
@@ -0,0 +1,75 @@
+This package was debianized by Theodore Karkoulis <bilbo@debian.org> on
+Tue, 16 Sep 2003 13:36:54 +0300.
+
+It is now maintained by KDE Extras Team.
+
+It was downloaded from http://www.kbarcode.net
+
+Upstream Author: Dominik Seichter <domseichter@web.de>
+
+Copyright: Copyright (C) 2002-2006 Dominik Seichter <domseichter@web.de>
+
+Copyright for barkode: Copyright (C) 1998-2000 Torben Weis <weis@kde.org>
+
+Copyright for Barcode Writer in Pure PostScript:
+ Copyright (C) 2006 Terry Burton <tez@terryburton.co.uk>
+
+barcode.ps license:
+
+The file kbarcode/barcode.ps which is included in this
+distribution is licensed under the following conditions:
+========================================================
+
+Barcode Writer in Pure PostScript
+http://www.terryburton.co.uk/barcodewriter/
+
+Copyright (c) 2005 Terry Burton - tez@terryburton.co.uk
+
+Permission is hereby granted, free of charge, to any
+person obtaining a copy of this software and associated
+documentation files (the "Software"), to deal in the
+Software without restriction, including without
+limitation the rights to use, copy, modify, merge,
+publish, distribute, sublicense, and/or sell copies of
+the Software, and to permit persons to whom the Software
+is furnished to do so, subject to the following
+conditions:
+
+The above copyright notice and this permission notice
+shall be included in all copies or substantial portions
+of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY
+KIND, EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO
+THE WARRANTIES OF MERCHANTABILITY, FITNESS FOR A
+PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL
+THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM,
+DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION OF
+CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN
+CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS
+IN THE SOFTWARE.
+
+On Debian systems, the complete text of the GNU General
+Public License can be found in `/usr/share/common-licenses/BSD'.
+
+kbarcode license:
+
+ This package is free software; you can redistribute it and/or modify
+ it under the terms of the GNU General Public License as published by
+ the Free Software Foundation; either version 2 of the License, or
+ (at your option) any later version.
+
+ This package is distributed in the hope that it will be useful,
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ GNU General Public License for more details.
+
+ You should have received a copy of the GNU General Public License
+ along with this package; if not, write to the Free Software
+ Foundation, Inc., 51 Franklin St, Fifth Floor, Boston, MA 02110-1301 USA
+
+On Debian systems, the complete text of the GNU General
+Public License can be found in `/usr/share/common-licenses/GPL-2'.
+
+The Debian packaging is (C) 2006, Fathi Boudra <fboudra@free.fr> and
+is licensed under the GPL, see above.
diff --git a/debian/_base/applications/kbarcode/debian/docs b/debian/_base/applications/kbarcode/debian/docs
new file mode 100644
index 000000000..c17f03764
--- /dev/null
+++ b/debian/_base/applications/kbarcode/debian/docs
@@ -0,0 +1,4 @@
+AUTHORS
+NEWS
+README
+TODO
diff --git a/debian/_base/applications/kbarcode/debian/menu b/debian/_base/applications/kbarcode/debian/menu
new file mode 100644
index 000000000..33f4f83da
--- /dev/null
+++ b/debian/_base/applications/kbarcode/debian/menu
@@ -0,0 +1,6 @@
+?package(kbarcode-trinity):\
+ needs="X11"\
+ section="Applications/Graphics"\
+ hints="TDE,Barcode"\
+ title="KBarcode"\
+ command="/opt/trinity/bin/kbarcode"
diff --git a/debian/_base/applications/kbarcode/debian/patches/.gitignore b/debian/_base/applications/kbarcode/debian/patches/.gitignore
new file mode 100644
index 000000000..e69de29bb
--- /dev/null
+++ b/debian/_base/applications/kbarcode/debian/patches/.gitignore
diff --git a/debian/_base/applications/kbarcode/debian/rules b/debian/_base/applications/kbarcode/debian/rules
new file mode 100755
index 000000000..e5c16cf8a
--- /dev/null
+++ b/debian/_base/applications/kbarcode/debian/rules
@@ -0,0 +1,20 @@
+#!/usr/bin/make -f
+
+include /usr/share/cdbs/1/rules/debhelper.mk
+include /usr/share/cdbs/1/class/cmake.mk
+#include /usr/share/cdbs/1/rules/patchsys-quilt.mk
+include debian/cdbs/debian-qt-kde.mk
+
+DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
+ && echo xz || echo bzip2)
+
+DEB_CMAKE_EXTRA_FLAGS := \
+ -DCMAKE_INSTALL_PREFIX="/opt/trinity" \
+ -DCONFIG_INSTALL_DIR="/etc/trinity" \
+ -DSYSCONF_INSTALL_DIR="/etc" \
+ -DXDG_MENU_INSTALL_DIR="/etc/xdg/menus" \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_VERBOSE_MAKEFILE="ON" \
+ -DCMAKE_SKIP_RPATH="OFF" \
+ -DBUILD_ALL="ON" \
+ -DWITH_ALL_OPTIONS="ON"
diff --git a/debian/_base/applications/kbarcode/debian/source/format b/debian/_base/applications/kbarcode/debian/source/format
new file mode 100644
index 000000000..163aaf8d8
--- /dev/null
+++ b/debian/_base/applications/kbarcode/debian/source/format
@@ -0,0 +1 @@
+3.0 (quilt)
diff --git a/debian/_base/applications/kbarcode/debian/source/options b/debian/_base/applications/kbarcode/debian/source/options
new file mode 100644
index 000000000..72f1f5450
--- /dev/null
+++ b/debian/_base/applications/kbarcode/debian/source/options
@@ -0,0 +1,6 @@
+# Use xz instead of gzip
+compression = "xz"
+compression-level = 9
+
+# Don't run differences
+diff-ignore = .*