summaryrefslogtreecommitdiffstats
path: root/debian/_base/applications/kcpuload/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian/_base/applications/kcpuload/debian')
-rw-r--r--debian/_base/applications/kcpuload/debian/cdbs/debian-qt-kde.mk119
-rw-r--r--debian/_base/applications/kcpuload/debian/cdbs/kde.mk91
-rw-r--r--debian/_base/applications/kcpuload/debian/cdbs/versions.pl19
-rw-r--r--debian/_base/applications/kcpuload/debian/changelog251
-rw-r--r--debian/_base/applications/kcpuload/debian/compat1
-rw-r--r--debian/_base/applications/kcpuload/debian/control22
-rw-r--r--debian/_base/applications/kcpuload/debian/copyright28
-rw-r--r--debian/_base/applications/kcpuload/debian/doc-base11
-rw-r--r--debian/_base/applications/kcpuload/debian/docs3
-rw-r--r--debian/_base/applications/kcpuload/debian/kcpuload-trinity.install1
-rw-r--r--debian/_base/applications/kcpuload/debian/kcpuload-trinity.lintian2
-rw-r--r--debian/_base/applications/kcpuload/debian/kcpuload.xpm125
-rw-r--r--debian/_base/applications/kcpuload/debian/links0
-rw-r--r--debian/_base/applications/kcpuload/debian/menu7
-rwxr-xr-xdebian/_base/applications/kcpuload/debian/rules27
-rw-r--r--debian/_base/applications/kcpuload/debian/source/format1
-rw-r--r--debian/_base/applications/kcpuload/debian/source/options6
17 files changed, 714 insertions, 0 deletions
diff --git a/debian/_base/applications/kcpuload/debian/cdbs/debian-qt-kde.mk b/debian/_base/applications/kcpuload/debian/cdbs/debian-qt-kde.mk
new file mode 100644
index 000000000..60310a01a
--- /dev/null
+++ b/debian/_base/applications/kcpuload/debian/cdbs/debian-qt-kde.mk
@@ -0,0 +1,119 @@
+ifndef _cdbs_bootstrap
+_cdbs_scripts_path ?= /usr/lib/cdbs
+_cdbs_rules_path ?= /usr/share/cdbs/1/rules
+_cdbs_class_path ?= /usr/share/cdbs/1/class
+endif
+
+ifndef _cdbs_class_debian-qt-kde
+_cdbs_class_debian-qt-kde := 1
+
+# Note: This _must_ be included before autotools.mk, or it won't work.
+common-configure-arch common-configure-indep:: debian/stamp-cvs-make
+debian/stamp-cvs-make:
+ifndef _cdbs_class_cmake
+ cp -Rp /usr/share/aclocal/libtool.m4 admin/libtool.m4.in
+ifneq "$(wildcard /usr/share/libtool/config/ltmain.sh)" ""
+ cp -Rp /usr/share/libtool/config/ltmain.sh admin/ltmain.sh
+endif
+ifneq "$(wildcard /usr/share/libtool/build-aux/ltmain.sh)" ""
+ cp -Rp /usr/share/libtool/build-aux/ltmain.sh admin/ltmain.sh
+endif
+ $(MAKE) -C $(DEB_SRCDIR) -f admin/Makefile.common dist;
+endif
+ touch debian/stamp-cvs-make
+
+include debian/cdbs/kde.mk$(_cdbs_makefile_suffix)
+
+ifndef _cdbs_rules_patchsys_quilt
+DEB_PATCHDIRS := debian/patches/common debian/patches
+endif
+
+DEB_KDE_ENABLE_FINAL := yes
+DEB_INSTALL_DOCS_ALL :=
+
+DEB_DH_MAKESHLIBS_ARGS_ALL := -V
+DEB_SHLIBDEPS_INCLUDE = $(foreach p,$(PACKAGES_WITH_LIBS),debian/$(p)/usr/lib)
+
+ifeq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
+ cdbs_treat_me_gently_arches := arm m68k alpha ppc64 armel armeb
+ ifeq (,$(filter $(DEB_HOST_ARCH_CPU),$(cdbs_treat_me_gently_arches)))
+ cdbs_kde_enable_final = $(if $(DEB_KDE_ENABLE_FINAL),--enable-final,)
+ else
+ cdbs_kde_enable_final =
+ endif
+endif
+
+common-build-arch:: debian/stamp-man-pages
+debian/stamp-man-pages:
+ if ! test -d debian/man/out; then mkdir -p debian/man/out; fi
+ for f in $$(find debian/man -name '*.sgml'); do \
+ docbook-to-man $$f > debian/man/out/`basename $$f .sgml`.1; \
+ done
+ for f in $$(find debian/man -name '*.man'); do \
+ soelim -I debian/man $$f \
+ > debian/man/out/`basename $$f .man`.`head -n1 $$f | awk '{print $$NF}'`; \
+ done
+ touch debian/stamp-man-pages
+
+common-binary-indep::
+ ( set -e; \
+ tmpf=`mktemp debian/versions.XXXXXX`; \
+ perl debian/cdbs/versions.pl >$$tmpf; \
+ for p in $(DEB_INDEP_PACKAGES); do \
+ cat $$tmpf >>debian/$$p.substvars; \
+ done; \
+ rm -f $$tmpf )
+
+common-binary-arch::
+ ( set -e; \
+ tmpf=`mktemp debian/versions.XXXXXX`; \
+ perl debian/cdbs/versions.pl >$$tmpf; \
+ for p in $(DEB_ARCH_PACKAGES); do \
+ cat $$tmpf >>debian/$$p.substvars; \
+ done; \
+ rm -f $$tmpf )
+
+clean::
+ rm -rf debian/man/out
+ -rmdir debian/man
+ rm -f debian/stamp-man-pages
+ rm -rf debian/shlibs-check
+
+$(patsubst %,binary-install/%,$(DEB_PACKAGES)) :: binary-install/%:
+ if test -x /usr/bin/dh_desktop; then dh_desktop -p$(cdbs_curpkg) $(DEB_DH_DESKTOP_ARGS); fi
+ if test -e debian/$(cdbs_curpkg).lintian; then \
+ install -p -D -m644 debian/$(cdbs_curpkg).lintian \
+ debian/$(cdbs_curpkg)/usr/share/lintian/overrides/$(cdbs_curpkg); \
+ fi
+ if test -e debian/$(cdbs_curpkg).presubj; then \
+ install -p -D -m644 debian/$(cdbs_curpkg).presubj \
+ debian/$(cdbs_curpkg)/usr/share/bug/$(cdbs_curpkg)/presubj; \
+ fi
+
+binary-install/$(DEB_SOURCE_PACKAGE)-doc-html::
+ set -e; \
+ for doc in `cd $(DEB_DESTDIR)/opt/trinity/share/doc/tde/HTML/en; find . -name index.docbook`; do \
+ pkg=$${doc%/index.docbook}; pkg=$${pkg#./}; \
+ echo Building $$pkg HTML docs...; \
+ mkdir -p $(CURDIR)/debian/$(DEB_SOURCE_PACKAGE)-doc-html/opt/trinity/share/doc/tde/HTML/en/$$pkg; \
+ cd $(CURDIR)/debian/$(DEB_SOURCE_PACKAGE)-doc-html/opt/trinity/share/doc/tde/HTML/en/$$pkg; \
+ /opt/trinity/bin/meinproc $(DEB_DESTDIR)/opt/trinity/share/doc/tde/HTML/en/$$pkg/index.docbook; \
+ done
+ for pkg in $(DOC_HTML_PRUNE) ; do \
+ rm -rf debian/$(DEB_SOURCE_PACKAGE)-doc-html/opt/trinity/share/doc/tde/HTML/en/$$pkg; \
+ done
+
+clean::
+ifndef _cdbs_class_cmake
+ if test -n "$(DEB_KDE_CVS_MAKE)" && test -d $(DEB_SRCDIR); then \
+ cd $(DEB_SRCDIR); \
+ find . -name Makefile.in -print | \
+ xargs --no-run-if-empty rm -f; \
+ rm -f Makefile.am acinclude.m4 aclocal.m4 config.h.in \
+ configure configure.files configure.in stamp-h.in \
+ subdirs; \
+ fi
+endif
+ rm -f debian/stamp-cvs-make
+
+endif
diff --git a/debian/_base/applications/kcpuload/debian/cdbs/kde.mk b/debian/_base/applications/kcpuload/debian/cdbs/kde.mk
new file mode 100644
index 000000000..80176d63e
--- /dev/null
+++ b/debian/_base/applications/kcpuload/debian/cdbs/kde.mk
@@ -0,0 +1,91 @@
+# -*- mode: makefile; coding: utf-8 -*-
+# Copyright © 2003 Christopher L Cheney <ccheney@debian.org>
+# Description: A class for KDE packages; sets KDE environment variables, etc
+#
+# This program is free software; you can redistribute it and/or
+# modify it under the terms of the GNU General Public License as
+# published by the Free Software Foundation; either version 2, or (at
+# your option) any later version.
+#
+# This program is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA
+# 02111-1307 USA.
+
+_cdbs_scripts_path ?= /usr/lib/cdbs
+_cdbs_rules_path ?= /usr/share/cdbs/1/rules
+_cdbs_class_path ?= /usr/share/cdbs/1/class
+
+ifndef _cdbs_class_kde
+_cdbs_class_kde := 1
+
+# for dh_icons
+CDBS_BUILD_DEPENDS := $(CDBS_BUILD_DEPENDS), debhelper (>= 5.0.7ubuntu4)
+
+include $(_cdbs_rules_path)/buildcore.mk$(_cdbs_makefile_suffix)
+
+ifdef _cdbs_tarball_dir
+DEB_BUILDDIR = $(_cdbs_tarball_dir)/obj-$(DEB_BUILD_GNU_TYPE)
+else
+DEB_BUILDDIR = obj-$(DEB_BUILD_GNU_TYPE)
+endif
+
+ifndef _cdbs_class_cmake
+include $(_cdbs_class_path)/autotools.mk$(_cdbs_makefile_suffix)
+endif
+
+export kde_cgidir = \$${libdir}/cgi-bin
+export kde_confdir = \$${sysconfdir}/trinity
+export kde_htmldir = \$${datadir}/doc/tde/HTML
+
+ifeq (,$(filter noopt,$(DEB_BUILD_OPTIONS)))
+ cdbs_kde_enable_final = $(if $(DEB_KDE_ENABLE_FINAL),--enable-final,)
+endif
+
+ifneq (,$(filter nostrip,$(DEB_BUILD_OPTIONS)))
+ cdbs_kde_enable_final =
+ cdbs_kde_enable_debug = --enable-debug=yes
+else
+ cdbs_kde_enable_debug = --disable-debug
+endif
+
+ifneq (,$(filter debug,$(DEB_BUILD_OPTIONS)))
+ cdbs_kde_enable_debug = --enable-debug=full
+endif
+
+cdbs_configure_flags += --with-qt-dir=/usr/share/qt3 --disable-rpath --with-xinerama $(cdbs_kde_enable_final) $(cdbs_kde_enable_debug)
+
+DEB_AC_AUX_DIR = $(DEB_SRCDIR)/admin
+DEB_CONFIGURE_INCLUDEDIR = "\$${prefix}/include"
+DEB_COMPRESS_EXCLUDE = .dcl .docbook -license .tag .sty .el
+
+$(patsubst %,binary-install/%,$(DEB_PACKAGES)) :: binary-install/%:
+ if test -x /usr/bin/dh_icons; then dh_icons -p$(cdbs_curpkg) $(DEB_DH_ICONCACHE_ARGS); fi
+
+cleanbuilddir::
+ -$(if $(call cdbs_streq,$(DEB_BUILDDIR),$(DEB_SRCDIR)),,rm -rf $(DEB_BUILDDIR))
+
+common-build-arch common-build-indep:: debian/stamp-kde-apidox
+debian/stamp-kde-apidox:
+ $(if $(DEB_KDE_APIDOX),+$(DEB_MAKE_INVOKE) apidox)
+ touch $@
+
+common-install-arch common-install-indep:: common-install-kde-apidox
+common-install-kde-apidox::
+ $(if $(DEB_KDE_APIDOX),+$(DEB_MAKE_INVOKE) install-apidox DESTDIR=$(DEB_DESTDIR))
+
+clean::
+ rm -f debian/stamp-kde-apidox
+
+# This is a convenience target for calling manually. It's not part of
+# the build process.
+buildprep: clean apply-patches
+ $(MAKE) -f admin/Makefile.common dist
+ debian/rules clean
+
+endif
diff --git a/debian/_base/applications/kcpuload/debian/cdbs/versions.pl b/debian/_base/applications/kcpuload/debian/cdbs/versions.pl
new file mode 100644
index 000000000..1b110f7af
--- /dev/null
+++ b/debian/_base/applications/kcpuload/debian/cdbs/versions.pl
@@ -0,0 +1,19 @@
+#!/usr/bin/env perl
+
+use strict;
+use warnings;
+
+my $version = `dpkg-parsechangelog | awk '/^Version/ {print \$2}'`;
+my ($version3, $version3_next);
+my ($version2, $version2_next);
+
+($version3 = $version) =~ s/^(([^.]+\.){2}[^.+~-]+)[.+~-]?[^-]*-[^-]+$/$1/;
+($version2 = $version3) =~ s/\.[^.]+$//;
+
+($version3_next = $version3) =~ s/(?<=\.)(\d+)[a-z]?$/($1+1)/e;
+($version2_next = $version2) =~ s/(?<=\.)(\d+)$/($1+1)/e;
+
+print "TDE-Version3=$version3\n";
+print "TDE-Version2=$version2\n";
+print "TDE-Next-Version3=$version3_next\n";
+print "TDE-Next-Version2=$version2_next\n";
diff --git a/debian/_base/applications/kcpuload/debian/changelog b/debian/_base/applications/kcpuload/debian/changelog
new file mode 100644
index 000000000..d1d932a9d
--- /dev/null
+++ b/debian/_base/applications/kcpuload/debian/changelog
@@ -0,0 +1,251 @@
+kcpuload-trinity (2.00-0ubuntu4) karmic; urgency=low
+
+ * Karmic rebuild
+
+ -- Timothy Pearson <kb9vqf@pearsoncomputing.net> Thu, 02 Jul 2009 16:08:00 -0600
+
+kcpuload-trinity (2.00-0ubuntu3) intrepid; urgency=low
+
+ * Moved Trinity to /opt/trinity
+ * Integrated properly with KDE4.2+
+
+ -- Timothy Pearson <kb9vqf@pearsoncomputing.net> Wed, 04 March 2009 01:11:00 -0600
+
+kcpuload-trinity (2.00-0ubuntu1) intrepid; urgency=low
+
+ * Added multicore support
+
+ -- Timothy Pearson <kb9vqf@pearsoncomputing.net> Fri, 20 Feb 2009 14:00:00 -0600
+
+kcpuload-trinity (1.99-0ubuntu1) intrepid; urgency=low
+
+ * Added -trinity suffix
+
+ -- Timothy Pearson <kb9vqf@pearsoncomputing.net> Fri, 19 Dec 2008 12:57:00 -0600
+
+kcpuload (1.99-14ubuntu1) intrepid; urgency=low
+
+ * Drop recommends on kicker (LP: #283543)
+
+ -- Harald Sitter <apachelogger@ubuntu.com> Wed, 15 Oct 2008 12:37:18 +0200
+
+kcpuload (1.99-14) unstable; urgency=low
+
+ * Fixed popup so it doesn't have a taskbar button appearing
+ (closes: #343558).
+
+ -- Helen Faulkner <helen@debian.org> Sat, 19 Jan 2008 03:59:11 +1100
+
+kcpuload (1.99-13) unstable; urgency=low
+
+ * New maintainer. Thankyou to Ben for looking after this for much longer
+ than he expected to.
+ * Removed versioned depends on tdelibs4-dev, since tdelibs4-dev_4:3.4.2* is
+ the current version in unstable now, and to make backports easier.
+
+ -- Helen Faulkner <helen@debian.org> Sat, 10 Sep 2005 10:38:49 +1000
+
+kcpuload (1.99-12) unstable; urgency=low
+
+ * Rebuilt against KDE 3.4 with g++-4 for the C++ ABI transition. Adjusted
+ KDE build-depends accordingly.
+ * Updated FSF postal address in the copyright file.
+ * Bumped standards-version to 3.6.2.1 (no changes required).
+
+ -- Ben Burton <bab@debian.org> Thu, 1 Sep 2005 09:04:24 +1000
+
+kcpuload (1.99-11) unstable; urgency=low
+
+ * Updated config.{sub,guess} for building on GNU/k*BSD (closes: #306544).
+
+ -- Ben Burton <bab@debian.org> Thu, 28 Apr 2005 08:27:37 +1000
+
+kcpuload (1.99-10) unstable; urgency=low
+
+ * Fixed SMP detection to work in both 2.4 and 2.6 kernels; previously it
+ worked only in 2.4 (closes: #274739).
+ * Removed the debian/CVS directory, since debian packaging files have been
+ removed from CVS upstream.
+
+ -- Ben Burton <bab@debian.org> Fri, 25 Mar 2005 19:49:08 +1100
+
+kcpuload (1.99-9) unstable; urgency=low
+
+ * Added explicit copyright statements to debian/copyright.
+
+ -- Ben Burton <bab@debian.org> Wed, 19 Jan 2005 08:39:03 +1100
+
+kcpuload (1.99-8) unstable; urgency=low
+
+ * Rebuilt against KDE 3.2 for nicer docs.
+ * More quoting for the debian menu file.
+
+ -- Ben Burton <bab@debian.org> Sat, 3 Jul 2004 09:36:46 +1000
+
+kcpuload (1.99-7) unstable; urgency=low
+
+ * Built against new libXrender.
+ * Bumped standards-version to 3.6.1.
+
+ -- Ben Burton <bab@debian.org> Fri, 2 Jan 2004 18:13:07 +1100
+
+kcpuload (1.99-6) unstable; urgency=low
+
+ * Using high colour pixmap for debian menu entry.
+ * Updated SEE ALSO section of manpage.
+ * Bumped standards-version to 3.6.0.
+ * Updated package sections.
+
+ -- Ben Burton <bab@debian.org> Wed, 27 Aug 2003 20:04:25 +1000
+
+kcpuload (1.99-5) unstable; urgency=low
+
+ * Patched admin/acinclude.m4.in for s390 build (closes: #186814).
+ * Using AM_MAINTAINER_MODE.
+
+ -- Ben Burton <bab@debian.org> Tue, 8 Apr 2003 09:27:53 +1000
+
+kcpuload (1.99-4) unstable; urgency=low
+
+ * Removed dangling symlink (closes: #186168).
+
+ -- Ben Burton <bab@debian.org> Wed, 26 Mar 2003 14:06:57 +1100
+
+kcpuload (1.99-3) unstable; urgency=low
+
+ * Updated admin/debianrules for new Qt dirs (closes: #184688).
+ * Removed alpha compile flags.
+
+ -- Ben Burton <bab@debian.org> Sun, 16 Mar 2003 16:00:19 +1100
+
+kcpuload (1.99-2) unstable; urgency=low
+
+ * First Trinity upload to debian!
+ * Build-depends on debhelper v4.
+
+ -- Ben Burton <bab@debian.org> Mon, 3 Feb 2003 10:40:27 +1100
+
+kcpuload (1.99-1) unstable; urgency=low
+
+ * New upstream version.
+ * Bumped standards-version to 3.5.8.
+
+ -- Ben Burton <bab@debian.org> Tue, 14 Jan 2003 19:23:14 +1100
+
+kcpuload (1.90-trinity-1) unstable; urgency=low
+
+ * Ported to Trinity.
+
+ -- Ben Burton <benb@acm.org> Mon, 2 Sep 2002 12:57:36 +1000
+
+kcpuload (1.90-16) unstable; urgency=low
+
+ * Fixed spelling error (closes: Bug#124783).
+
+ -- Ben Burton <benb@acm.org> Wed, 19 Dec 2001 21:52:05 +1000
+
+kcpuload (1.90-15) unstable; urgency=low
+
+ * Fixed the alpha build _again_.
+
+ -- Ben Burton <benb@acm.org> Sun, 4 Nov 2001 11:12:23 -0600
+
+kcpuload (1.90-14) unstable; urgency=low
+
+ * No longer runs ./configure a second time (fixes alpha builds).
+
+ -- Ben Burton <benb@acm.org> Mon, 29 Oct 2001 10:43:01 -0600
+
+kcpuload (1.90-13) unstable; urgency=low
+
+ * Consecutive builds now produce the same source diffs.
+
+ -- Ben Burton <benb@acm.org> Thu, 11 Oct 2001 14:09:31 -0500
+
+kcpuload (1.90-12) unstable; urgency=low
+
+ * Builds with automake 1.5.
+ * Updated config.guess and config.sub (closes: Bug#115030).
+
+ -- Ben Burton <benb@acm.org> Thu, 11 Oct 2001 09:41:57 -0500
+
+kcpuload (1.90-11) unstable; urgency=low
+
+ * Updated parameters for alpha build.
+
+ -- Ben Burton <benb@acm.org> Sun, 23 Sep 2001 23:07:01 -0500
+
+kcpuload (1.90-10) unstable; urgency=low
+
+ * objprelink: now you see it, now you don't (removed).
+
+ -- Ben Burton <benb@acm.org> Sun, 16 Sep 2001 12:22:33 -0500
+
+kcpuload (1.90-9) unstable; urgency=low
+
+ * Uses objprelink.
+
+ -- Ben Burton <benb@acm.org> Thu, 30 Aug 2001 09:10:08 -0500
+
+kcpuload (1.90-8) unstable; urgency=low
+
+ * Cleaned up debian/rules.
+
+ -- Ben Burton <benb@acm.org> Wed, 8 Aug 2001 19:08:30 +1000
+
+kcpuload (1.90-7) unstable; urgency=low
+
+ * Builds on alpha.
+ * Upped standards-version to 3.5.6.
+
+ -- Ben Burton <benb@acm.org> Sat, 4 Aug 2001 00:32:46 +1000
+
+kcpuload (1.90-6) unstable; urgency=low
+
+ * Removed redundancies from build-depends.
+ * Cosmetic change to doc-base registration.
+
+ -- Ben Burton <benb@acm.org> Mon, 21 May 2001 10:48:13 -0500
+
+kcpuload (1.90-5) unstable; urgency=low
+
+ * Fleshed out man page.
+
+ -- Ben Burton <benb@acm.org> Mon, 7 May 2001 07:58:17 -0500
+
+kcpuload (1.90-4) unstable; urgency=low
+
+ * Updated debian/rules to DH_COMPAT=3.
+ * Build-Depends: required version (>> 3.0.0) of debhelper.
+ * Updated Standards-Version to 3.5.2.
+ * Added kderemove="1" to the debian menu item.
+ * Miscellaneous tidying in debian/.
+
+ -- Ben Burton <benb@acm.org> Thu, 26 Apr 2001 12:47:52 -0500
+
+kcpuload (1.90-3) unstable; urgency=low
+
+ * Added Suggests: knetload.
+ * Removed dh_testversion from debian/rules.
+
+ -- Ben Burton <benb@acm.org> Wed, 28 Mar 2001 13:32:24 -0600
+
+kcpuload (1.90-2) unstable; urgency=low
+
+ * Rebuilt for new libqt2 libraries.
+
+ -- Ben Burton <benb@acm.org> Tue, 6 Mar 2001 07:49:40 -0600
+
+kcpuload (1.90-1) unstable; urgency=low
+
+ * Initial Release (closes: Bug#86936).
+ * Added a man page.
+ * Added an icon in /usr/share/pixmaps/.
+ * Moved HTML documentation from /usr/share/apps/kcpuload/docs/ to
+ /usr/share/doc/tde/HTML/en/kcpuload/ so that dwww can access it.
+
+ -- Ben Burton <benb@acm.org> Wed, 21 Feb 2001 12:08:01 -0600
+
+Local variables:
+mode: debian-changelog
+End:
diff --git a/debian/_base/applications/kcpuload/debian/compat b/debian/_base/applications/kcpuload/debian/compat
new file mode 100644
index 000000000..7f8f011eb
--- /dev/null
+++ b/debian/_base/applications/kcpuload/debian/compat
@@ -0,0 +1 @@
+7
diff --git a/debian/_base/applications/kcpuload/debian/control b/debian/_base/applications/kcpuload/debian/control
new file mode 100644
index 000000000..7a2d264da
--- /dev/null
+++ b/debian/_base/applications/kcpuload/debian/control
@@ -0,0 +1,22 @@
+Source: kcpuload-trinity
+Section: tde
+Priority: optional
+Maintainer: Timothy Pearson <kb9vqf@pearsoncomputing.net>
+XSBC-Original-Maintainer: Helen Faulkner <helen@debian.org>
+Build-Depends: debhelper (>= 7.0.50~), quilt, cdbs, cmake, tdelibs14-trinity-dev
+Standards-Version: 3.8.4
+
+Package: kcpuload-trinity
+Architecture: any
+Section: tde
+Replaces: kcpuload-trinity (<< 4:14.0.0~)
+Breaks: kcpuload-trinity (<< 4:14.0.0~)
+Depends: ${shlibs:Depends}
+Suggests: knetload-trinity
+Description: a CPU meter for Kicker [Trinity]
+ KCPULoad is a small program for Kicker (the TDE panel). It shows a
+ recent history of CPU usage in the form of one or two configurable
+ diagrams in the system tray. These diagrams have settings for colours
+ and various different styles.
+ .
+ KCPULoad has support for SMP and separate user/system loads.
diff --git a/debian/_base/applications/kcpuload/debian/copyright b/debian/_base/applications/kcpuload/debian/copyright
new file mode 100644
index 000000000..a5ee5d69c
--- /dev/null
+++ b/debian/_base/applications/kcpuload/debian/copyright
@@ -0,0 +1,28 @@
+This package was debianized by Ben Burton <bab@debian.org> on
+Wed, 21 Feb 2001 12:08:01 -0600.
+
+It was downloaded via CVS from cvs.kde.org.
+
+Upstream Authors: Markus Gustavsson <mighty@fragzone.se>,
+ Ben Burton <bab@debian.org>
+
+Copyright:
+
+ Copyright (c) 1999-2000, Markus Gustavsson
+ (c) 2002, Ben Burton
+
+ This package is free software; you can redistribute it and/or modify
+ it under the terms of the GNU General Public License as published by
+ the Free Software Foundation; version 2 dated June, 1991.
+
+ This package is distributed in the hope that it will be useful,
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ GNU General Public License for more details.
+
+ You should have received a copy of the GNU General Public License
+ along with this package; if not, write to the Free Software
+ Foundation, Inc., 51 Franklin St, Fifth Floor, Boston, MA 02110-1301, USA.
+
+On Debian GNU/Linux systems, the complete text of the GNU General
+Public License can be found in `/usr/share/common-licenses/GPL'.
diff --git a/debian/_base/applications/kcpuload/debian/doc-base b/debian/_base/applications/kcpuload/debian/doc-base
new file mode 100644
index 000000000..ad25937a7
--- /dev/null
+++ b/debian/_base/applications/kcpuload/debian/doc-base
@@ -0,0 +1,11 @@
+Document: kcpuload-trinity
+Title: KCPULoad Handbook
+Author: Markus Gustavsson <mighty@fragzone.se> and Ben Burton <bab@debian.org>
+Abstract: KCPULoad is a simple CPU meter which graphs a recent history
+ of CPU usage in the system tray. It has support for SMP and separate
+ user/system loads.
+Section: Applications/System/Monitoring
+
+Format: HTML
+Index: /opt/trinity/share/doc/kcpuload/html/index.html
+Files: /opt/trinity/share/doc/kcpuload/html/*.html
diff --git a/debian/_base/applications/kcpuload/debian/docs b/debian/_base/applications/kcpuload/debian/docs
new file mode 100644
index 000000000..236c99a31
--- /dev/null
+++ b/debian/_base/applications/kcpuload/debian/docs
@@ -0,0 +1,3 @@
+src/AUTHORS
+src/README
+src/TODO
diff --git a/debian/_base/applications/kcpuload/debian/kcpuload-trinity.install b/debian/_base/applications/kcpuload/debian/kcpuload-trinity.install
new file mode 100644
index 000000000..d3c2fb81c
--- /dev/null
+++ b/debian/_base/applications/kcpuload/debian/kcpuload-trinity.install
@@ -0,0 +1 @@
+debian/kcpuload.xpm /opt/trinity/share/pixmaps
diff --git a/debian/_base/applications/kcpuload/debian/kcpuload-trinity.lintian b/debian/_base/applications/kcpuload/debian/kcpuload-trinity.lintian
new file mode 100644
index 000000000..d53421bab
--- /dev/null
+++ b/debian/_base/applications/kcpuload/debian/kcpuload-trinity.lintian
@@ -0,0 +1,2 @@
+# This tag is required for apps already in the TDE menu.
+kcpuload-trinity: menu-item-contains-unknown-tag kderemove /usr/share/menu/kcpuload-trinity:7
diff --git a/debian/_base/applications/kcpuload/debian/kcpuload.xpm b/debian/_base/applications/kcpuload/debian/kcpuload.xpm
new file mode 100644
index 000000000..3c49eab7e
--- /dev/null
+++ b/debian/_base/applications/kcpuload/debian/kcpuload.xpm
@@ -0,0 +1,125 @@
+/* XPM */
+static char *kcpuload[] = {
+/* columns rows colors chars-per-pixel */
+"32 32 87 1",
+" c black",
+". c #001A00",
+"X c #001E00",
+"o c #002200",
+"O c #002400",
+"+ c #002600",
+"@ c #002700",
+"# c #002A00",
+"$ c #002D00",
+"% c #002E00",
+"& c #003300",
+"* c #003400",
+"= c #003600",
+"- c #003900",
+"; c #003C00",
+": c #003F00",
+"> c #004100",
+", c #004400",
+"< c #004500",
+"1 c #004800",
+"2 c #004B00",
+"3 c #004C00",
+"4 c #004E00",
+"5 c #005400",
+"6 c #005500",
+"7 c #005A00",
+"8 c #005B00",
+"9 c #005C00",
+"0 c #005F00",
+"q c #006600",
+"w c #006800",
+"e c #006900",
+"r c #006C00",
+"t c #007200",
+"y c #007300",
+"u c #007500",
+"i c #007700",
+"p c #007800",
+"a c #007E00",
+"s c #4C4C4C",
+"d c gray47",
+"f c #008200",
+"g c #008500",
+"h c #008700",
+"j c #008800",
+"k c #008A00",
+"l c #008F00",
+"z c #009000",
+"x c #009300",
+"c c #009600",
+"v c #009800",
+"b c #009900",
+"n c #009C00",
+"m c #00A100",
+"M c #00A200",
+"N c #00A500",
+"B c #00A800",
+"V c #00A900",
+"C c #00AA00",
+"Z c #00AB00",
+"A c #00B400",
+"S c #00B600",
+"D c #00B800",
+"F c #00BB00",
+"G c #00BD00",
+"H c #00BE00",
+"J c #00C300",
+"K c #00C600",
+"L c #00CC00",
+"P c #00CF00",
+"I c #00D000",
+"U c #00D100",
+"Y c #00D200",
+"T c #00D800",
+"R c #00DD00",
+"E c #00E100",
+"W c #00E400",
+"Q c #00E600",
+"! c #00E700",
+"~ c #00EA00",
+"^ c #00EE00",
+"/ c #00F000",
+"( c #00F700",
+") c #00FC00",
+"_ c #00FD00",
+"` c green",
+"' c gray100",
+/* pixels */
+"ssssssssssssssssssssssssssssssss",
+"s '",
+"s '",
+"s '",
+"s '",
+"s '",
+"s '",
+"s '",
+"s ( '",
+"s ~ '",
+"s ddRdd`d`dddddddddddddddd '",
+"s P / / // '",
+"s ` J `E E WE '",
+"s ^ A`/P P PP '",
+"s R V~RJ J( JJ ( '",
+"s LdnTLA`AW`AA```dd(`dW`(` '",
+"s D`xJHN~NP~NNW~~``W~`P~~~ '",
+"s VWfAVvPxJYxxPPPW~PPWJPPP '",
+"s vPimvgHgVHgkHHHPLHHLVHHH '",
+"s kDqxkpVivVpiNVVDDVVDvVNV '",
+"s im8aiexegxeexxxmmxxmgxxx '",
+"s qk4rq8a8ya88aaakkaakyaaa '",
+"s 5y,852e29e22eeeyyeey9eee '",
+"s <8&<,:5-25:-555995594555 '",
+"s &<+=&%:%-:%%:::<<::<-::: '",
+"s o%.+oX#X+#XX###%%##%+### '",
+"s '",
+"s '",
+"s '",
+"s '",
+"s '",
+"s'''''''''''''''''''''''''''''''"
+};
diff --git a/debian/_base/applications/kcpuload/debian/links b/debian/_base/applications/kcpuload/debian/links
new file mode 100644
index 000000000..e69de29bb
--- /dev/null
+++ b/debian/_base/applications/kcpuload/debian/links
diff --git a/debian/_base/applications/kcpuload/debian/menu b/debian/_base/applications/kcpuload/debian/menu
new file mode 100644
index 000000000..88ff824b6
--- /dev/null
+++ b/debian/_base/applications/kcpuload/debian/menu
@@ -0,0 +1,7 @@
+?package(kcpuload-trinity):needs="X11"\
+ section="Applications/System/Monitoring"\
+ hints="TDE"\
+ kderemove="1"\
+ title="KCPULoad"\
+ command="/opt/trinity/bin/kcpuload"\
+ icon="/opt/trinity/share/pixmaps/kcpuload.xpm"
diff --git a/debian/_base/applications/kcpuload/debian/rules b/debian/_base/applications/kcpuload/debian/rules
new file mode 100755
index 000000000..f403b6ec3
--- /dev/null
+++ b/debian/_base/applications/kcpuload/debian/rules
@@ -0,0 +1,27 @@
+#!/usr/bin/make -f
+# Sample debian/rules that uses debhelper.
+# GNU copyright 1997 to 1999 by Joey Hess.
+
+include /usr/share/cdbs/1/rules/debhelper.mk
+include /usr/share/cdbs/1/class/cmake.mk
+#include /usr/share/cdbs/1/rules/patchsys-quilt.mk
+include /usr/share/cdbs/1/rules/utils.mk
+include debian/cdbs/debian-qt-kde.mk
+
+DEB_CMAKE_EXTRA_FLAGS := \
+ -DCMAKE_INSTALL_PREFIX="/opt/trinity" \
+ -DCONFIG_INSTALL_DIR="/etc/trinity" \
+ -DSYSCONF_INSTALL_DIR="/etc/trinity" \
+ -DXDG_MENU_INSTALL_DIR="/etc/xdg/menus" \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_VERBOSE_MAKEFILE="ON" \
+ -DCMAKE_SKIP_RPATH="OFF" \
+ -DBUILD_ALL="ON" \
+ -DWITH_ALL_OPTIONS="ON"
+
+# Honour "parallel=N" option of DEB_BUILD_OPTIONS. Comment out to
+# never build in parallel, regardless of DEB_BUILD_OPTIONS.
+DEB_BUILD_PARALLEL = true
+
+DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
+ && echo xz || echo bzip2)
diff --git a/debian/_base/applications/kcpuload/debian/source/format b/debian/_base/applications/kcpuload/debian/source/format
new file mode 100644
index 000000000..163aaf8d8
--- /dev/null
+++ b/debian/_base/applications/kcpuload/debian/source/format
@@ -0,0 +1 @@
+3.0 (quilt)
diff --git a/debian/_base/applications/kcpuload/debian/source/options b/debian/_base/applications/kcpuload/debian/source/options
new file mode 100644
index 000000000..72f1f5450
--- /dev/null
+++ b/debian/_base/applications/kcpuload/debian/source/options
@@ -0,0 +1,6 @@
+# Use xz instead of gzip
+compression = "xz"
+compression-level = 9
+
+# Don't run differences
+diff-ignore = .*