summaryrefslogtreecommitdiffstats
path: root/debian/_base/applications/system/knetstats
diff options
context:
space:
mode:
Diffstat (limited to 'debian/_base/applications/system/knetstats')
-rw-r--r--debian/_base/applications/system/knetstats/debian/cdbs/debian-tde.mk246
-rw-r--r--debian/_base/applications/system/knetstats/debian/cdbs/versions.pl19
-rw-r--r--debian/_base/applications/system/knetstats/debian/changelog34
-rw-r--r--debian/_base/applications/system/knetstats/debian/compat1
-rw-r--r--debian/_base/applications/system/knetstats/debian/control14
-rw-r--r--debian/_base/applications/system/knetstats/debian/copyright30
-rw-r--r--debian/_base/applications/system/knetstats/debian/knetstats.1.docbook113
-rw-r--r--debian/_base/applications/system/knetstats/debian/patches/series0
-rwxr-xr-xdebian/_base/applications/system/knetstats/debian/rules22
-rw-r--r--debian/_base/applications/system/knetstats/debian/source/format1
-rw-r--r--debian/_base/applications/system/knetstats/debian/source/options6
-rw-r--r--debian/_base/applications/system/knetstats/debian/watch3
12 files changed, 489 insertions, 0 deletions
diff --git a/debian/_base/applications/system/knetstats/debian/cdbs/debian-tde.mk b/debian/_base/applications/system/knetstats/debian/cdbs/debian-tde.mk
new file mode 100644
index 000000000..f36e3527c
--- /dev/null
+++ b/debian/_base/applications/system/knetstats/debian/cdbs/debian-tde.mk
@@ -0,0 +1,246 @@
+# -*- mode: makefile; coding: utf-8 -*-
+# Copyright © 2003 Christopher L Cheney <ccheney@debian.org>
+# Copyright © 2019 TDE Team
+# Description: A class for TDE packages; sets TDE environment variables, etc
+#
+# This program is free software; you can redistribute it and/or
+# modify it under the terms of the GNU General Public License as
+# published by the Free Software Foundation; either version 2, or (at
+# your option) any later version.
+#
+# This program is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA
+# 02111-1307 USA.
+
+ifndef _cdbs_bootstrap
+_cdbs_scripts_path ?= /usr/lib/cdbs
+_cdbs_rules_path ?= /usr/share/cdbs/1/rules
+_cdbs_class_path ?= /usr/share/cdbs/1/class
+endif
+
+ifndef _cdbs_class_debian-qt-kde
+_cdbs_class_debian-qt-kde := 1
+
+# for dh_icons
+CDBS_BUILD_DEPENDS := $(CDBS_BUILD_DEPENDS), debhelper (>= 5.0.7ubuntu4)
+
+# Note: This _must_ be included before autotools.mk, or it won't work.
+common-configure-arch common-configure-indep:: debian/stamp-cvs-make
+debian/stamp-cvs-make:
+ifndef _cdbs_class_cmake
+ cp -Rp /usr/share/aclocal/libtool.m4 admin/libtool.m4.in
+ifneq "$(wildcard /usr/share/libtool/config/ltmain.sh)" ""
+ cp -Rp /usr/share/libtool/config/ltmain.sh admin/ltmain.sh
+endif
+ifneq "$(wildcard /usr/share/libtool/build-aux/ltmain.sh)" ""
+ cp -Rp /usr/share/libtool/build-aux/ltmain.sh admin/ltmain.sh
+endif
+ $(MAKE) -C $(DEB_SRCDIR) -f admin/Makefile.common dist;
+endif
+ touch debian/stamp-cvs-make
+
+include $(_cdbs_rules_path)/buildcore.mk$(_cdbs_makefile_suffix)
+
+ifdef _cdbs_tarball_dir
+DEB_BUILDDIR = $(_cdbs_tarball_dir)/obj-$(DEB_BUILD_GNU_TYPE)
+else
+DEB_BUILDDIR = obj-$(DEB_BUILD_GNU_TYPE)
+endif
+
+ifndef _cdbs_class_cmake
+include $(_cdbs_class_path)/autotools.mk$(_cdbs_makefile_suffix)
+endif
+
+ifdef _cdbs_class_cmake
+ifneq "$(wildcard /usr/bin/ninja)" ""
+MAKE = ninja -v
+DEB_MAKE_ENVVARS += DESTDIR=$(DEB_DESTDIR)
+DEB_MAKE_INSTALL_TARGET = install
+DEB_CMAKE_NORMAL_ARGS += -GNinja
+endif
+endif
+
+ifndef _cdbs_rules_patchsys_quilt
+DEB_PATCHDIRS := debian/patches/common debian/patches
+endif
+
+export kde_cgidir = \$${libdir}/cgi-bin
+export kde_confdir = \$${sysconfdir}/trinity
+export kde_htmldir = \$${datadir}/doc/tde/HTML
+
+DEB_KDE_ENABLE_FINAL := yes
+DEB_INSTALL_DOCS_ALL :=
+
+DEB_DH_MAKESHLIBS_ARGS_ALL := -V
+DEB_SHLIBDEPS_INCLUDE = $(foreach p,$(PACKAGES_WITH_LIBS),debian/$(p)/usr/lib)
+
+DEB_AC_AUX_DIR = $(DEB_SRCDIR)/admin
+DEB_CONFIGURE_INCLUDEDIR = "\$${prefix}/include"
+DEB_COMPRESS_EXCLUDE = .dcl .docbook -license .tag .sty .el
+
+# The default gzip compressor has been changed in dpkg >= 1.17.0.
+deb_default_compress = $(shell LANG=C dpkg-deb --version | head -n1 | \
+ sed -e "s|.*version ||" -e "s| .*||" | \
+ xargs -r dpkg --compare-versions 1.17.0 lt \
+ && echo xz || echo gzip)
+ifeq ($(deb_default_compress),gzip)
+DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
+ && echo xz || echo bzip2)
+endif
+
+ifeq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
+ cdbs_treat_me_gently_arches := arm m68k alpha ppc64 armel armeb
+ ifeq (,$(filter $(DEB_HOST_ARCH_CPU),$(cdbs_treat_me_gently_arches)))
+ cdbs_kde_enable_final = $(if $(DEB_KDE_ENABLE_FINAL),--enable-final,)
+ else
+ cdbs_kde_enable_final =
+ endif
+endif
+
+ifneq (,$(filter nostrip,$(DEB_BUILD_OPTIONS)))
+ cdbs_kde_enable_final =
+ cdbs_kde_enable_debug = --enable-debug=yes
+else
+ cdbs_kde_enable_debug = --disable-debug
+endif
+
+ifneq (,$(filter debug,$(DEB_BUILD_OPTIONS)))
+ cdbs_kde_enable_debug = --enable-debug=full
+endif
+
+DEB_BUILD_PARALLEL ?= true
+
+cdbs_configure_flags += \
+ --with-qt-dir=/usr/share/qt3 \
+ --disable-rpath \
+ --with-xinerama \
+ $(cdbs_kde_enable_final) \
+ $(cdbs_kde_enable_debug)
+
+
+# This is a convenience target for calling manually.
+# It's not part of the build process.
+buildprep: clean apply-patches
+ifndef _cdbs_class_cmake
+ $(MAKE) -f admin/Makefile.common dist
+endif
+ debian/rules clean
+
+.tdepkginfo:
+ echo "# TDE package information" >.tdepkginfo
+ dpkg-parsechangelog | sed -n "s|^Source: |Name: |p" >>.tdepkginfo
+ dpkg-parsechangelog | sed -n "s|^Version: |Version: |p" >>.tdepkginfo
+ date +"DateTime: %m/%d/%Y %H:%M" -u -d "$$(dpkg-parsechangelog | sed -n 's|^Date: ||p')" >>.tdepkginfo
+
+post-patches:: .tdepkginfo
+
+common-build-arch:: debian/stamp-man-pages
+debian/stamp-man-pages:
+ if ! test -d debian/man/out; then mkdir -p debian/man/out; fi
+ for f in $$(find debian/man -name '*.sgml'); do \
+ docbook-to-man $$f > debian/man/out/`basename $$f .sgml`.1; \
+ done
+ for f in $$(find debian/man -name '*.man'); do \
+ soelim -I debian/man $$f \
+ > debian/man/out/`basename $$f .man`.`head -n1 $$f | awk '{print $$NF}'`; \
+ done
+ touch debian/stamp-man-pages
+
+common-binary-indep::
+ ( set -e; \
+ tmpf=`mktemp debian/versions.XXXXXX`; \
+ perl debian/cdbs/versions.pl >$$tmpf; \
+ for p in $(DEB_INDEP_PACKAGES); do \
+ cat $$tmpf >>debian/$$p.substvars; \
+ done; \
+ rm -f $$tmpf )
+
+common-binary-arch::
+ ( set -e; \
+ tmpf=`mktemp debian/versions.XXXXXX`; \
+ perl debian/cdbs/versions.pl >$$tmpf; \
+ for p in $(DEB_ARCH_PACKAGES); do \
+ cat $$tmpf >>debian/$$p.substvars; \
+ done; \
+ rm -f $$tmpf )
+ # update multi-arch path in install files
+ ls -d debian/* | \
+ grep -E "(install|links)$$" | \
+ while read a; do \
+ [ -d $$a ] || [ -f $$a.arch ] || \
+ ! grep -q "\$$(DEB_HOST_MULTIARCH)" $$a || \
+ sed -i.arch "s|\$$(DEB_HOST_MULTIARCH)|$(DEB_HOST_MULTIARCH)|g" $$a; \
+ done
+
+clean::
+ rm -rf debian/man/out
+ -rmdir debian/man
+ rm -f debian/stamp-man-pages
+ rm -rf debian/shlibs-check
+ # revert multi-arch path in install files
+ ls -d debian/* | \
+ grep -E "(install|links)$$" | \
+ while read a; do \
+ [ ! -f $$a.arch ] || \
+ mv $$a.arch $$a; \
+ done
+
+$(patsubst %,binary-install/%,$(DEB_PACKAGES)) :: binary-install/%:
+ if test -x /usr/bin/dh_icons; then dh_icons -p$(cdbs_curpkg) $(DEB_DH_ICONCACHE_ARGS); fi
+ if test -x /usr/bin/dh_desktop; then dh_desktop -p$(cdbs_curpkg) $(DEB_DH_DESKTOP_ARGS); fi
+ if test -e debian/$(cdbs_curpkg).lintian; then \
+ install -p -D -m644 debian/$(cdbs_curpkg).lintian \
+ debian/$(cdbs_curpkg)/usr/share/lintian/overrides/$(cdbs_curpkg); \
+ fi
+ if test -e debian/$(cdbs_curpkg).presubj; then \
+ install -p -D -m644 debian/$(cdbs_curpkg).presubj \
+ debian/$(cdbs_curpkg)/usr/share/bug/$(cdbs_curpkg)/presubj; \
+ fi
+
+binary-install/$(DEB_SOURCE_PACKAGE)-doc-html::
+ set -e; \
+ for doc in `cd $(DEB_DESTDIR)/opt/trinity/share/doc/tde/HTML/en; find . -name index.docbook`; do \
+ pkg=$${doc%/index.docbook}; pkg=$${pkg#./}; \
+ echo Building $$pkg HTML docs...; \
+ mkdir -p $(CURDIR)/debian/$(DEB_SOURCE_PACKAGE)-doc-html/opt/trinity/share/doc/tde/HTML/en/$$pkg; \
+ cd $(CURDIR)/debian/$(DEB_SOURCE_PACKAGE)-doc-html/opt/trinity/share/doc/tde/HTML/en/$$pkg; \
+ /opt/trinity/bin/meinproc $(DEB_DESTDIR)/opt/trinity/share/doc/tde/HTML/en/$$pkg/index.docbook; \
+ done
+ for pkg in $(DOC_HTML_PRUNE) ; do \
+ rm -rf debian/$(DEB_SOURCE_PACKAGE)-doc-html/opt/trinity/share/doc/tde/HTML/en/$$pkg; \
+ done
+
+common-build-indep:: debian/stamp-kde-apidox
+debian/stamp-kde-apidox:
+ $(if $(DEB_KDE_APIDOX),+$(DEB_MAKE_INVOKE) apidox)
+ touch $@
+
+common-install-indep:: common-install-kde-apidox
+common-install-kde-apidox::
+ $(if $(DEB_KDE_APIDOX),+DESTDIR=$(DEB_DESTDIR) $(DEB_MAKE_INVOKE) install-apidox)
+
+cleanbuilddir::
+ -$(if $(call cdbs_streq,$(DEB_BUILDDIR),$(DEB_SRCDIR)),,rm -rf $(DEB_BUILDDIR))
+
+clean::
+ifndef _cdbs_class_cmake
+ if test -n "$(DEB_KDE_CVS_MAKE)" && test -d $(DEB_SRCDIR); then \
+ cd $(DEB_SRCDIR); \
+ find . -name Makefile.in -print | \
+ xargs --no-run-if-empty rm -f; \
+ rm -f Makefile.am acinclude.m4 aclocal.m4 config.h.in \
+ configure configure.files configure.in stamp-h.in \
+ subdirs; \
+ fi
+endif
+ rm -f .tdepkginfo
+ rm -f debian/stamp-kde-apidox
+ rm -f debian/stamp-cvs-make
+
+endif
diff --git a/debian/_base/applications/system/knetstats/debian/cdbs/versions.pl b/debian/_base/applications/system/knetstats/debian/cdbs/versions.pl
new file mode 100644
index 000000000..75c9add4b
--- /dev/null
+++ b/debian/_base/applications/system/knetstats/debian/cdbs/versions.pl
@@ -0,0 +1,19 @@
+#!/usr/bin/env perl
+
+use strict;
+use warnings;
+
+my $version = `dpkg-parsechangelog | awk '/^Version/ {print \$2}'`;
+my ($version3, $version3_next);
+my ($version2, $version2_next);
+
+($version3 = $version) =~ s/^(([^.]+\.){2}[^.+~-]+)[.+~-]?[^-]*-[^-]+$/$1/;
+($version2 = $version3) =~ s/\.[^.]+$//;
+
+($version3_next = $version3) =~ s/(?<=\.)(\d+)[a-z]?$/($1+1)/e;
+($version2_next = $version2) =~ s/(?<=\.)(\d+)$/($1+1)/e;
+
+print "KDE-Version3=$version3\n";
+print "KDE-Version2=$version2\n";
+print "KDE-Next-Version3=$version3_next\n";
+print "KDE-Next-Version2=$version2_next\n";
diff --git a/debian/_base/applications/system/knetstats/debian/changelog b/debian/_base/applications/system/knetstats/debian/changelog
new file mode 100644
index 000000000..d1015cb26
--- /dev/null
+++ b/debian/_base/applications/system/knetstats/debian/changelog
@@ -0,0 +1,34 @@
+knetstats-trinity (1.6.1-0ubuntu4) karmic; urgency=low
+
+ * Karmic rebuild
+
+ -- Timothy Pearson <kb9vqf@pearsoncomputing.net> Wed, 04 Nov 2009 11:09:00 -0600
+
+knetstats (1.6.1-0ubuntu2) intrepid; urgency=low
+
+ * Remove kicker dependency
+
+ -- Harald Sitter <apachelogger@ubuntu.com> Sat, 06 Sep 2008 01:37:17 +0200
+
+knetstats (1.6.1-0ubuntu1) hardy; urgency=low
+
+ * New upstream release.
+ * debian/patches/kubuntu_02_clean_desktop_file.patch:
+ - Update to apply again.
+ - Comply with current fd.o standard.
+ * debian/patches/kubuntu_03_autoconf.patch: Drop. Now included upstream.
+ * debian/watch: Add.
+
+ -- William Grant <william.grant@ubuntu.org.au> Sat, 10 Nov 2007 12:55:46 +1100
+
+knetstats (1.6-0ubuntu1) edgy; urgency=low
+
+ * Initial Release.
+ * Added kubuntu_01_kdepot.patch for pot files extraction
+ to Rosetta
+ * Added kubuntu_02_clean_desktop_file.patch for good GenericNames
+ in desktop file
+ * Added kubuntu_03_autoconf for autoconf/autoheader 2.6
+
+ -- Anthony Mercatante <tonio@ubuntu.com> Sun, 27 Sep 2006 14:14:54 +0200
+
diff --git a/debian/_base/applications/system/knetstats/debian/compat b/debian/_base/applications/system/knetstats/debian/compat
new file mode 100644
index 000000000..7f8f011eb
--- /dev/null
+++ b/debian/_base/applications/system/knetstats/debian/compat
@@ -0,0 +1 @@
+7
diff --git a/debian/_base/applications/system/knetstats/debian/control b/debian/_base/applications/system/knetstats/debian/control
new file mode 100644
index 000000000..a6957e601
--- /dev/null
+++ b/debian/_base/applications/system/knetstats/debian/control
@@ -0,0 +1,14 @@
+Source: knetstats-trinity
+Section: kde
+Priority: optional
+Maintainer: Timothy Pearson <kb9vqf@pearsoncomputing.net>
+Build-Depends: debhelper (>= 7.0.50~), quilt, cdbs, kdelibs4-trinity-dev, docbook2x, automake, autoconf, libtool, libltdl-dev
+Standards-Version: 3.8.4
+Homepage: http://knetstats.sourceforge.net/
+
+Package: knetstats-trinity
+Architecture: any
+Depends: ${shlibs:Depends}
+Description: network interfaces monitor for the Trinity systray
+ A simple KDE network monitor that show rx/tx LEDs of any
+ network interface on a system tray icon
diff --git a/debian/_base/applications/system/knetstats/debian/copyright b/debian/_base/applications/system/knetstats/debian/copyright
new file mode 100644
index 000000000..bf7dbe0ed
--- /dev/null
+++ b/debian/_base/applications/system/knetstats/debian/copyright
@@ -0,0 +1,30 @@
+This package was debianized by Anthony Mercatante <tonio@ubuntu.com>
+on Wed, 27 Sep 2006 14:17:36 +0200
+
+It was downloaded from http://knetstats.sourceforge.net/
+
+Upstream author is
+ Hugo Parente Lima <hugo_pl@users.sourceforge.net>
+
+Copyright:
+
+ Copyright (C) 2004-2005-2006 by Hugo Parente Lima <hugo_pl@users.sourceforge.net>
+
+License:
+
+ This program is free software; you can redistribute it and/or modify
+ it under the terms of the GNU General Public License as published by
+ the Free Software Foundation; either version 2 of the License, or
+ (at your option) any later version.
+
+ This program is distributed in the hope that it will be useful,
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ GNU General Public License for more details.
+
+ You should have received a copy of the GNU General Public License
+ along with this program; if not, write to the Free Software Foundation,
+ Inc., 51 Franklin St - Fifth Floor, Boston, MA 02110-1301 USA
+
+ On Debian GNU/Linux systems, the complete text of the GNU General
+ Public License can be found in the /usr/share/common-licenses/GPL file.
diff --git a/debian/_base/applications/system/knetstats/debian/knetstats.1.docbook b/debian/_base/applications/system/knetstats/debian/knetstats.1.docbook
new file mode 100644
index 000000000..28b721f53
--- /dev/null
+++ b/debian/_base/applications/system/knetstats/debian/knetstats.1.docbook
@@ -0,0 +1,113 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE refentry PUBLIC "-//OASIS//DTD DocBook XML V4.2//EN"
+"http://www.oasis-open.org/docbook/xml/4.2/docbookx.dtd" [
+]>
+<refentry>
+ <refentryinfo>
+ <author>
+ <firstname>Mercatante</firstname>
+ <surname>Anthony</surname>
+ <email>tonio@ubuntu.com</email>
+ </author>
+ <copyright>
+ <year>2006</year>
+ <holder>Anthony Mercatante</holder>
+ </copyright>
+ <!-- XXX IMPORTANT XXX -->
+ <!-- Keep this date up to date: -->
+ <date>2006-09-27</date>
+ <!-- ^^^^^^^^^^ -->
+ </refentryinfo>
+ <refmeta>
+ <refentrytitle>knetstats</refentrytitle>
+ <manvolnum>1</manvolnum>
+ </refmeta>
+ <refnamediv>
+ <refname>knetstats</refname>
+ <refpurpose>network interfaces monitor for KDE's systray</refpurpose>
+ </refnamediv>
+ <refsynopsisdiv>
+ <cmdsynopsis>
+ <command>knetstats</command>
+ <arg choice="opt">
+ <option><replaceable>Qt-options</replaceable></option>
+ </arg>
+ <arg choice="opt">
+ <option><replaceable>KDE-options</replaceable></option>
+ </arg>
+ </cmdsynopsis>
+ </refsynopsisdiv>
+ <refsect1>
+ <title>DESCRIPTION</title>
+ <para>
+ network interfaces monitor for KDE's systray.
+ </para>
+ <para>
+ Knetstats is a simple KDE network monitor that show rx/tx LEDs of any network interface on a system tray icon
+ </para>
+ </refsect1>
+ <refsect1>
+ <title>OPTIONS</title>
+ <para>
+ All <productname>KDE</productname> and <productname>Qt</productname>
+ programs accept a some common command-line options. Password Manager has no
+ application-specific options.
+ </para>
+ <para>
+ <variablelist>
+ <title>Generic options:</title>
+ <varlistentry>
+ <term> <option>--help</option> </term>
+ <listitem> <para>Show help about options</para> </listitem>
+ </varlistentry>
+ <varlistentry>
+ <term> <option>--help-qt</option> </term>
+ <listitem> <para>Show Qt specific options</para> </listitem>
+ </varlistentry>
+ <varlistentry>
+ <term> <option>--help-kde</option> </term>
+ <listitem> <para>Show KDE specific options</para> </listitem>
+ </varlistentry>
+ <varlistentry>
+ <term> <option>--help-all</option> </term>
+ <listitem> <para>Show all options</para> </listitem>
+ </varlistentry>
+ <varlistentry>
+ <term> <option>--author</option> </term>
+ <listitem> <para>Show author information</para> </listitem>
+ </varlistentry>
+ <varlistentry>
+ <term> <option>-v</option>, <option>--version</option> </term>
+ <listitem> <para>Show version information</para> </listitem>
+ </varlistentry>
+ <varlistentry>
+ <term> <option>--license</option> </term>
+ <listitem> <para>Show license information</para> </listitem>
+ </varlistentry>
+ <varlistentry>
+ <term> <option>--</option> </term>
+ <listitem> <para>Indicates end of options</para> </listitem>
+ </varlistentry>
+ </variablelist>
+ <!-- TODO * add all the rest of the options, but maybe find an automated
+ way to keep it up to date -->
+ </para>
+ </refsect1>
+ <refsect1>
+ <title>COPYRIGHT</title>
+ <para>
+ This manual page was written by Anthony Mercatante
+ <email>tonio@ubuntu.com</email> for the
+ <productname>Debian</productname> system (but may be used by others).
+ Permission is granted to copy, distribute and/or modify this document
+ under the terms of the <acronym>GNU</acronym> General Public License,
+ Version 2 or any later version published by the Free Software Foundation.
+ </para>
+ <para>
+ On Debian systems, the complete text of the GNU General Public
+ License can be found in
+ <filename>/usr/share/common-licenses/GPL</filename>.
+ </para>
+ </refsect1>
+</refentry>
+
diff --git a/debian/_base/applications/system/knetstats/debian/patches/series b/debian/_base/applications/system/knetstats/debian/patches/series
new file mode 100644
index 000000000..e69de29bb
--- /dev/null
+++ b/debian/_base/applications/system/knetstats/debian/patches/series
diff --git a/debian/_base/applications/system/knetstats/debian/rules b/debian/_base/applications/system/knetstats/debian/rules
new file mode 100755
index 000000000..5a77222d6
--- /dev/null
+++ b/debian/_base/applications/system/knetstats/debian/rules
@@ -0,0 +1,22 @@
+#!/usr/bin/make -f
+
+include /usr/share/cdbs/1/rules/debhelper.mk
+include debian/cdbs/debian-tde.mk
+
+DEB_CONFIGURE_INCLUDEDIR := /opt/trinity/include/kde
+DEB_CONFIGURE_MANDIR := /opt/trinity/share/man
+DEB_CONFIGURE_PREFIX := /opt/trinity
+DEB_CONFIGURE_INFODIR := /opt/trinity/share/info
+
+cdbs_configure_flags := --with-qt-dir=/usr/share/qt3 --disable-rpath --with-xinerama $(cdbs_kde_enable_final) $(cdbs_kde_enable_debug)
+
+DEB_INSTALL_MANPAGES_knetstats-trinity = knetstats.1
+
+build/knetstats-trinity::
+ docbook2x-man debian/knetstats.1.docbook
+
+binary-install/knetstats-trinity::
+ mv debian/knetstats-trinity/usr/share/man debian/knetstats-trinity/opt/trinity/share/
+
+clean::
+ rm -f knetstats.1
diff --git a/debian/_base/applications/system/knetstats/debian/source/format b/debian/_base/applications/system/knetstats/debian/source/format
new file mode 100644
index 000000000..163aaf8d8
--- /dev/null
+++ b/debian/_base/applications/system/knetstats/debian/source/format
@@ -0,0 +1 @@
+3.0 (quilt)
diff --git a/debian/_base/applications/system/knetstats/debian/source/options b/debian/_base/applications/system/knetstats/debian/source/options
new file mode 100644
index 000000000..72f1f5450
--- /dev/null
+++ b/debian/_base/applications/system/knetstats/debian/source/options
@@ -0,0 +1,6 @@
+# Use xz instead of gzip
+compression = "xz"
+compression-level = 9
+
+# Don't run differences
+diff-ignore = .*
diff --git a/debian/_base/applications/system/knetstats/debian/watch b/debian/_base/applications/system/knetstats/debian/watch
new file mode 100644
index 000000000..8d12f40b0
--- /dev/null
+++ b/debian/_base/applications/system/knetstats/debian/watch
@@ -0,0 +1,3 @@
+version=3
+
+http://sf.net/knetstats/knetstats-(.*)\.tar\.bz2