summaryrefslogtreecommitdiffstats
path: root/debian/_base/applications
diff options
context:
space:
mode:
Diffstat (limited to 'debian/_base/applications')
-rwxr-xr-xdebian/_base/applications/fusion-icon/debian/rules6
-rwxr-xr-xdebian/_base/applications/tde-guidance/debian/rules6
2 files changed, 12 insertions, 0 deletions
diff --git a/debian/_base/applications/fusion-icon/debian/rules b/debian/_base/applications/fusion-icon/debian/rules
index 4f2025eca..46359aca2 100755
--- a/debian/_base/applications/fusion-icon/debian/rules
+++ b/debian/_base/applications/fusion-icon/debian/rules
@@ -15,6 +15,12 @@ endif
DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
&& echo xz || echo bzip2)
+post-patches::
+ # make sure that python binary exists
+ # since the existing code is still dependent on python2
+ # and cdbs uses python as the default binary name
+ test -x /usr/bin/python || ln -s python2 /usr/bin/python
+
binary-install/fusion-icon-trinity::
mkdir -p debian/fusion-icon-trinity/usr/local/lib
cp -Rp debian/fusion-icon-trinity/usr/local/* debian/fusion-icon-trinity/usr/
diff --git a/debian/_base/applications/tde-guidance/debian/rules b/debian/_base/applications/tde-guidance/debian/rules
index b4a195a5c..0cbf1123b 100755
--- a/debian/_base/applications/tde-guidance/debian/rules
+++ b/debian/_base/applications/tde-guidance/debian/rules
@@ -25,6 +25,12 @@ LDFLAGS_APPEND := -L/opt/trinity/lib
DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
&& echo xz || echo bzip2)
+post-patches::
+ # make sure that python binary exists
+ # since the existing code is still dependent on python2
+ # and cdbs uses python as the default binary name
+ test -x /usr/bin/python || ln -s python2 /usr/bin/python
+
install/tde-guidance-trinity::
# install icons to right place
install -D -p -m0644 $(DEB_DESTDIR)/opt/trinity/share/apps/guidance/pics/hi32-app-daemons.png \