summaryrefslogtreecommitdiffstats
path: root/debian/_base/tdetoys/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/_base/tdetoys/debian/rules')
-rwxr-xr-xdebian/_base/tdetoys/debian/rules34
1 files changed, 34 insertions, 0 deletions
diff --git a/debian/_base/tdetoys/debian/rules b/debian/_base/tdetoys/debian/rules
new file mode 100755
index 000000000..e4de8f31c
--- /dev/null
+++ b/debian/_base/tdetoys/debian/rules
@@ -0,0 +1,34 @@
+#! /usr/bin/make -f
+
+include /usr/share/cdbs/1/rules/debhelper.mk
+include /usr/share/cdbs/1/class/cmake.mk
+include debian/cdbs/debian-qt-kde.mk
+#include /usr/share/cdbs/1/rules/patchsys-quilt.mk
+include /usr/share/cdbs/1/rules/utils.mk
+
+DEB_CONFIGURE_INCLUDEDIR := /opt/trinity/include
+DEB_CONFIGURE_MANDIR := /opt/trinity/share/man
+DEB_CONFIGURE_PREFIX := /opt/trinity
+DEB_CONFIGURE_INFODIR := /opt/trinity/share/info
+
+cdbs_configure_flags := --with-qt-dir=/usr/share/qt3 --disable-rpath --with-xinerama $(cdbs_kde_enable_final) $(cdbs_kde_enable_debug)
+
+DEB_CONFIGURE_EXTRA_FLAGS := --prefix=/opt/trinity --with-extra-libs=/opt/trinity/lib --includedir="/opt/trinity/include" --mandir="/opt/trinity/share/man" --infodir="/opt/trinity/share/info"
+
+DEB_CMAKE_EXTRA_FLAGS := \
+ -DCMAKE_INSTALL_PREFIX="/opt/trinity" \
+ -DCONFIG_INSTALL_DIR="/etc/trinity" \
+ -DSYSCONF_INSTALL_DIR="/etc/trinity" \
+ -DXDG_MENU_INSTALL_DIR="/etc/xdg/menus" \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_VERBOSE_MAKEFILE="ON" \
+ -DCMAKE_SKIP_RPATH="OFF" \
+ -DBUILD_ALL="ON"
+
+DEB_DH_STRIP_ARGS := --dbg-package=tdetoys-trinity-dbg
+
+DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
+ && echo xz || echo bzip2)
+
+DEB_INSTALL_CHANGELOGS_kodo-trinity := kodo/ChangeLog
+DEB_INSTALL_CHANGELOGS_kteatime-trinity := kteatime/ChangeLog