summaryrefslogtreecommitdiffstats
path: root/debian/lenny/libraries/python-trinity
diff options
context:
space:
mode:
Diffstat (limited to 'debian/lenny/libraries/python-trinity')
-rw-r--r--debian/lenny/libraries/python-trinity/debian/control2
-rwxr-xr-xdebian/lenny/libraries/python-trinity/debian/rules5
2 files changed, 5 insertions, 2 deletions
diff --git a/debian/lenny/libraries/python-trinity/debian/control b/debian/lenny/libraries/python-trinity/debian/control
index cad02055c..7f37be0e1 100644
--- a/debian/lenny/libraries/python-trinity/debian/control
+++ b/debian/lenny/libraries/python-trinity/debian/control
@@ -4,7 +4,7 @@ Priority: optional
Maintainer: Timothy Pearson <kb9vqf@pearsoncomputing.net>
XSBC-Original-Maintainer: Ricardo Javier Cardenes Medina <rcardenes@debian.org>
Uploaders: Torsten Marek <shlomme@debian.org>, Debian Python Modules Team <python-modules-team@lists.alioth.debian.org>
-Build-Depends: debhelper (>= 5.0.38), libtqtinterface-dev, python, python-all-dev, python-all-dbg, sip4 (>= 4.10), python-sip4-dev (>= 4.10), python-tqt-dev, tdelibs4-trinity-dev, python-central (>= 0.6.11), dpatch, python-sip4, python-sip4-dbg, python-sip4-dev
+Build-Depends: debhelper (>= 5.0.38), libtqtinterface-dev, python, python-all-dev, python-all-dbg, sip4 (>= 4.10), python-sip4-dev (>= 4.10), python-tqt-dev, tdelibs4-trinity-dev, python-support (>= 0.6) | python-dev (>= 2.6.6-3~), dpatch, python-sip4, python-sip4-dbg, python-sip4-dev
Standards-Version: 3.8.4
Homepage: http://www.riverbankcomputing.co.uk/pytde/index.php
XS-Python-Version: all
diff --git a/debian/lenny/libraries/python-trinity/debian/rules b/debian/lenny/libraries/python-trinity/debian/rules
index 67af8c2d8..d4dac70f3 100755
--- a/debian/lenny/libraries/python-trinity/debian/rules
+++ b/debian/lenny/libraries/python-trinity/debian/rules
@@ -31,6 +31,9 @@ endif
PYTHONS := $(shell pyversions -vr debian/control)
DBG_PYTHONS := $(shell pyversions -vd)
+DEB_PYTHON_SYSTEM = $(if $(wildcard /usr/bin/dh_python2),,pysupport)
+DH_PYTHON2 = $(if $(wildcard /usr/bin/dh_python2),dh_python2,dh_pysupport)
+
GCCVER := $(shell gcc --version | sed -n '/^gcc (GCC)/s/.*(GCC) \(...\).*/\1/p')
ifneq (,$(filter $(GCCVER),4.2 4.3))
SPLIT=20
@@ -149,7 +152,7 @@ ifeq (,$(findstring -i, $(DH_OPTIONS)))
endif
dh_compress -X.py -X.ui -X.dtd
dh_fixperms
- DH_PYCENTRAL=nomove dh_pycentral
+ ${DH_PYTHON2}
dh_installdeb
dh_shlibdeps -l /opt/trinity/lib
dh_gencontrol