summaryrefslogtreecommitdiffstats
path: root/dilos/tdeedu/debian/patches
diff options
context:
space:
mode:
Diffstat (limited to 'dilos/tdeedu/debian/patches')
-rw-r--r--dilos/tdeedu/debian/patches/common/04_am_maintainer_mode.diff11
-rw-r--r--dilos/tdeedu/debian/patches/common/06_disable_no_undefined.diff18
-rw-r--r--dilos/tdeedu/debian/patches/common/kubuntu_01_kdepot.diff26
-rw-r--r--dilos/tdeedu/debian/patches/dilos.patch76
-rw-r--r--dilos/tdeedu/debian/patches/series4
5 files changed, 135 insertions, 0 deletions
diff --git a/dilos/tdeedu/debian/patches/common/04_am_maintainer_mode.diff b/dilos/tdeedu/debian/patches/common/04_am_maintainer_mode.diff
new file mode 100644
index 000000000..391a80285
--- /dev/null
+++ b/dilos/tdeedu/debian/patches/common/04_am_maintainer_mode.diff
@@ -0,0 +1,11 @@
+--- a/admin/configure.in.min
++++ b/admin/configure.in.min
+@@ -38,6 +38,8 @@
+ dnl Automake doc recommends to do this only here. (Janos)
+ AM_INIT_AUTOMAKE(@MODULENAME@, @VERSION@) dnl searches for some needed programs
+
++AM_MAINTAINER_MODE
++
+ KDE_SET_PREFIX
+
+ dnl generate the config header
diff --git a/dilos/tdeedu/debian/patches/common/06_disable_no_undefined.diff b/dilos/tdeedu/debian/patches/common/06_disable_no_undefined.diff
new file mode 100644
index 000000000..05c932c3c
--- /dev/null
+++ b/dilos/tdeedu/debian/patches/common/06_disable_no_undefined.diff
@@ -0,0 +1,18 @@
+--- a/admin/acinclude.m4.in
++++ b/admin/acinclude.m4.in
+@@ -1689,15 +1689,6 @@
+ KDE_USE_CLOSURE_TRUE="#"
+ KDE_USE_CLOSURE_FALSE=""
+ KDE_NO_UNDEFINED=""
+- case $host in
+- *-*-linux-gnu)
+- KDE_CHECK_COMPILER_FLAG([Wl,--no-undefined],
+- [KDE_CHECK_COMPILER_FLAG([Wl,--allow-shlib-undefined],
+- [KDE_NO_UNDEFINED="-Wl,--no-undefined -Wl,--allow-shlib-undefined"],
+- [KDE_NO_UNDEFINED=""])],
+- [KDE_NO_UNDEFINED=""])
+- ;;
+- esac
+ fi
+ AC_SUBST(KDE_USE_CLOSURE_TRUE)
+ AC_SUBST(KDE_USE_CLOSURE_FALSE)
diff --git a/dilos/tdeedu/debian/patches/common/kubuntu_01_kdepot.diff b/dilos/tdeedu/debian/patches/common/kubuntu_01_kdepot.diff
new file mode 100644
index 000000000..28c95742b
--- /dev/null
+++ b/dilos/tdeedu/debian/patches/common/kubuntu_01_kdepot.diff
@@ -0,0 +1,26 @@
+--- kde/admin/cvs.sh 2005-11-26 02:42:02.000000000 +0000
++++ kde/admin/cvs.sh 2005-11-26 02:42:26.000000000 +0000
+@@ -537,6 +537,8 @@
+ if test -z "$PREPARETIPS"; then PREPARETIPS=preparetips ; fi
+ export EXTRACTRC PREPARETIPS
+
++kdepotpath=/usr/include/tde/tde.pot
++
+ for subdir in $dirs; do
+ test -z "$VERBOSE" || echo "Making messages in $subdir"
+ (cd $subdir
+@@ -554,10 +556,10 @@
+ fi
+ perl -e '$mes=0; while (<STDIN>) { next if (/^(if\s|else\s|endif)/); if (/^messages:/) { $mes=1; print $_; next; } if ($mes) { if (/$\\(XGETTEXT\)/ && / -o/) { s/ -o \$\(podir\)/ _translatorinfo.cpp -o \$\(podir\)/ } print $_; } else { print $_; } }' < Makefile.am | egrep -v '^include ' > _transMakefile
+
+- kdepotpath=${includedir:-`tde-config --expandvars --install include`}/tde.pot
+- if ! test -f $kdepotpath; then
+- kdepotpath=`tde-config --expandvars --prefix`/include/tde.pot
+- fi
++# kdepotpath=${includedir:-`tde-config --expandvars --install include`}/tde.pot
++# if ! test -f $kdepotpath; then
++# kdepotpath=`tde-config --expandvars --prefix`/include/tde.pot
++# fi
+
+ $MAKE -s -f _transMakefile podir=$podir EXTRACTRC="$EXTRACTRC" PREPARETIPS="$PREPARETIPS" srcdir=. \
+ XGETTEXT="${XGETTEXT:-xgettext} --foreign-user -C -ci18n -ki18n -ktr2i18n -kI18N_NOOP -kI18N_NOOP2 -kaliasLocale -x $kdepotpath" messages
diff --git a/dilos/tdeedu/debian/patches/dilos.patch b/dilos/tdeedu/debian/patches/dilos.patch
new file mode 100644
index 000000000..9becb70e3
--- /dev/null
+++ b/dilos/tdeedu/debian/patches/dilos.patch
@@ -0,0 +1,76 @@
+Index: tdeedu/kig/misc/conic-common.cpp
+===================================================================
+--- tdeedu.orig/kig/misc/conic-common.cpp
++++ tdeedu/kig/misc/conic-common.cpp
+@@ -28,7 +28,7 @@
+ #include <cmath>
+ #include <algorithm>
+
+-#ifdef HAVE_IEEEFP_H
++#if defined(HAVE_IEEEFP_H) || defined(__dilos__)
+ #include <ieeefp.h>
+ #endif
+
+Index: tdeedu/cmake/modules/TDEMacros.cmake
+===================================================================
+--- tdeedu.orig/cmake/modules/TDEMacros.cmake
++++ tdeedu/cmake/modules/TDEMacros.cmake
+@@ -833,7 +833,7 @@ macro( tde_add_library _arg_target )
+
+ # set embedded archives
+ if( _embed )
+- list( INSERT _link 0 -Wl,-whole-archive ${_embed} -Wl,-no-whole-archive )
++ list( INSERT _link 0 -Wl,-zallextract ${_embed} -Wl,-zdefaultextract )
+ endif( _embed )
+
+ # set link libraries
+Index: tdeedu/kstars/kstars/indi/apogee/ApogeeLinux.h
+===================================================================
+--- tdeedu.orig/kstars/kstars/indi/apogee/ApogeeLinux.h
++++ tdeedu/kstars/kstars/indi/apogee/ApogeeLinux.h
+@@ -10,6 +10,10 @@
+ #ifndef APOGEELINUX_H
+ #define APOGEELINUX_H
+
++#ifdef __dilos__
++#include <sys/ioccom.h>
++#endif /* __dilos__ */
++
+ #define APISA_READ_USHORT _IOR('a', 0x01, unsigned int)
+ #define APISA_READ_LINE _IOR('a', 0x02, unsigned int)
+ #define APISA_WRITE_USHORT _IOW('a', 0x03, unsigned int)
+Index: tdeedu/kstars/kstars/indi/apogee/ApnCamera.h
+===================================================================
+--- tdeedu.orig/kstars/kstars/indi/apogee/ApnCamera.h
++++ tdeedu/kstars/kstars/indi/apogee/ApnCamera.h
+@@ -13,6 +13,17 @@
+ #if !defined(AFX_APNCAMERA_H__CF513996_359F_4103_BBA6_2C730AE2C301__INCLUDED_)
+ #define AFX_APNCAMERA_H__CF513996_359F_4103_BBA6_2C730AE2C301__INCLUDED_
+
++#ifdef __dilos__
++#include <stdio.h>
++#include <stdlib.h>
++#include <unistd.h>
++#include <string.h>
++#define ULONG ulong
++#define USHORT ushort
++#define PUSHORT short unsigned int *
++#define Sleep sleep
++#endif /*__dilos__ */
++
+ #include "Apogee.h"
+ #include "Apn.h"
+ #include "FpgaRegs.h"
+Index: tdeedu/kig/misc/cubic-common.cc
+===================================================================
+--- tdeedu.orig/kig/misc/cubic-common.cc
++++ tdeedu/kig/misc/cubic-common.cc
+@@ -21,7 +21,7 @@
+ #include "kignumerics.h"
+ #include "kigtransform.h"
+
+-#ifdef HAVE_IEEEFP_H
++#if defined(HAVE_IEEEFP_H) || defined(__dilos__)
+ #include <ieeefp.h>
+ #endif
+
diff --git a/dilos/tdeedu/debian/patches/series b/dilos/tdeedu/debian/patches/series
new file mode 100644
index 000000000..8e96568f3
--- /dev/null
+++ b/dilos/tdeedu/debian/patches/series
@@ -0,0 +1,4 @@
+common/04_am_maintainer_mode.diff
+common/06_disable_no_undefined.diff
+common/kubuntu_01_kdepot.diff
+dilos.patch