summaryrefslogtreecommitdiffstats
path: root/gentoo/trinity-base/kdegraphics-kfile-plugins
diff options
context:
space:
mode:
Diffstat (limited to 'gentoo/trinity-base/kdegraphics-kfile-plugins')
-rw-r--r--gentoo/trinity-base/kdegraphics-kfile-plugins/Manifest1
-rw-r--r--gentoo/trinity-base/kdegraphics-kfile-plugins/files/tdegraphics-poppler-tqt-remove-unnecessary-check.patch19
-rw-r--r--gentoo/trinity-base/kdegraphics-kfile-plugins/kdegraphics-kfile-plugins-3.5.13.1.ebuild30
-rw-r--r--gentoo/trinity-base/kdegraphics-kfile-plugins/metadata.xml8
4 files changed, 58 insertions, 0 deletions
diff --git a/gentoo/trinity-base/kdegraphics-kfile-plugins/Manifest b/gentoo/trinity-base/kdegraphics-kfile-plugins/Manifest
new file mode 100644
index 000000000..f0ba54e9a
--- /dev/null
+++ b/gentoo/trinity-base/kdegraphics-kfile-plugins/Manifest
@@ -0,0 +1 @@
+DIST kdegraphics-3.5.13.1.tar.gz 7526074 SHA256 19bd36e261bb6c5d2c9c1eba5f736c642b48422d917d44e576835f7ebb44906b SHA512 693e5ad70dbb00c587e588acfb81fc9475c3a4dbc86f41d6053c0584c533349a7564e34b870cb7bbc57361ac539da6f7d7f1b002ac3cfe8b0201db3eeb9147dd WHIRLPOOL fd2c46c517b3a0293880eaf35967295485555b936d0f1e80e0f2c261a1164cfcc5c4b2d943a12c073914d33b59974cc2dd92a78414614caa10f46dd048d518b4
diff --git a/gentoo/trinity-base/kdegraphics-kfile-plugins/files/tdegraphics-poppler-tqt-remove-unnecessary-check.patch b/gentoo/trinity-base/kdegraphics-kfile-plugins/files/tdegraphics-poppler-tqt-remove-unnecessary-check.patch
new file mode 100644
index 000000000..35448ab1e
--- /dev/null
+++ b/gentoo/trinity-base/kdegraphics-kfile-plugins/files/tdegraphics-poppler-tqt-remove-unnecessary-check.patch
@@ -0,0 +1,19 @@
+--- kfile-plugins/dependencies/poppler-tqt/ConfigureChecks.cmake.orig 2012-10-30 15:37:44.306343796 +0400
++++ kfile-plugins/dependencies/poppler-tqt/ConfigureChecks.cmake 2012-10-30 15:37:56.031354364 +0400
+@@ -1,11 +1,9 @@
+ # Poppler
+-if( BUILD_KPDF )
+- pkg_search_module( POPPLER poppler )
+- if( POPPLER_FOUND )
+- set( HAVE_POPPLER 1 )
+- else( )
+- tde_message_fatal( "poppler is required, but was not found on your system" )
+- endif( )
++pkg_search_module( POPPLER poppler )
++if( POPPLER_FOUND )
++ set( HAVE_POPPLER 1 )
++else( )
++ tde_message_fatal( "poppler is required, but was not found on your system" )
+ endif( )
+
+ tde_save( CMAKE_REQUIRED_INCLUDES CMAKE_REQUIRED_LIBRARIES )
diff --git a/gentoo/trinity-base/kdegraphics-kfile-plugins/kdegraphics-kfile-plugins-3.5.13.1.ebuild b/gentoo/trinity-base/kdegraphics-kfile-plugins/kdegraphics-kfile-plugins-3.5.13.1.ebuild
new file mode 100644
index 000000000..2a7c868ff
--- /dev/null
+++ b/gentoo/trinity-base/kdegraphics-kfile-plugins/kdegraphics-kfile-plugins-3.5.13.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+EAPI="5"
+TRINITY_MODULE_NAME="kdegraphics"
+
+inherit trinity-meta
+
+DESCRIPTION="kfile plugins from kdegraphics"
+KEYWORDS="x86 amd64"
+IUSE="tiff openexr pdf"
+
+DEPEND="
+ tiff? ( media-libs/tiff:= )
+ openexr? ( >=media-libs/openexr-1.2.2-r2 )
+ pdf? ( app-text/poppler )"
+RDEPEND="$DEPEND"
+
+PATCHES=( "$FILESDIR/tdegraphics-poppler-tqt-remove-unnecessary-check.patch" )
+TSM_EXTRACT_ALSO="kghostview/dscparse/"
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_with tiff TIFF)
+ $(cmake-utils_use_with openexr OPENEXR)
+ $(cmake-utils_use_with pdf PDF)
+ )
+
+ trinity-meta_src_configure
+}
diff --git a/gentoo/trinity-base/kdegraphics-kfile-plugins/metadata.xml b/gentoo/trinity-base/kdegraphics-kfile-plugins/metadata.xml
new file mode 100644
index 000000000..6e9f5e4a1
--- /dev/null
+++ b/gentoo/trinity-base/kdegraphics-kfile-plugins/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>fatzer2@gmail.com</email>
+ <name>Alexander Golubev</name>
+ </maintainer>
+</pkgmetadata>