summaryrefslogtreecommitdiffstats
path: root/gentoo/trinity-base/tdetoys-doc
diff options
context:
space:
mode:
Diffstat (limited to 'gentoo/trinity-base/tdetoys-doc')
l---------gentoo/trinity-base/tdetoys-doc/files/shared1
-rw-r--r--gentoo/trinity-base/tdetoys-doc/metadata.xml8
-rw-r--r--gentoo/trinity-base/tdetoys-doc/tdetoys-doc-9999.ebuild27
3 files changed, 36 insertions, 0 deletions
diff --git a/gentoo/trinity-base/tdetoys-doc/files/shared b/gentoo/trinity-base/tdetoys-doc/files/shared
new file mode 120000
index 000000000..af62be31d
--- /dev/null
+++ b/gentoo/trinity-base/tdetoys-doc/files/shared
@@ -0,0 +1 @@
+../../../eclass/trinity-shared-files/ \ No newline at end of file
diff --git a/gentoo/trinity-base/tdetoys-doc/metadata.xml b/gentoo/trinity-base/tdetoys-doc/metadata.xml
new file mode 100644
index 000000000..6e9f5e4a1
--- /dev/null
+++ b/gentoo/trinity-base/tdetoys-doc/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>fatzer2@gmail.com</email>
+ <name>Alexander Golubev</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/gentoo/trinity-base/tdetoys-doc/tdetoys-doc-9999.ebuild b/gentoo/trinity-base/tdetoys-doc/tdetoys-doc-9999.ebuild
new file mode 100644
index 000000000..e7497b8fd
--- /dev/null
+++ b/gentoo/trinity-base/tdetoys-doc/tdetoys-doc-9999.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+EAPI="5"
+TRINITY_MODULE_NAME="tdetoys"
+
+inherit trinity-meta
+
+DESCRIPTION="Documentaion for tdetoys-derived packages"
+KEYWORDS=
+IUSE=""
+RDEPEND="
+ >=trinity-base/khelpcenter-${PV}:${SLOT}"
+
+pkg_setup() {
+ # we should reduce MAKEOPTS -j parametr to no more than 4
+ local makeopts_j
+ makeopts_j="$(echo "$MAKEOPTS" | sed -n 's/\(^\|.*\s\)\(-j\s*[0-9]\+\)\(\s.*\|$\)/\2/p')"
+ if [ -n "$makeopts_j" -a "$makeopts_j" > 4 ]; then
+ export MAKEOPTS="${MAKEOPTS//"${makeopts_j}"/-j4}"
+
+ ewarn "This ebuild needs huge amoumt of memmory to compile in highly parallel"
+ ewarn "mode so it can chew it all. MAKEOPTS are reduced to \"$MAKEOPTS\"."
+ fi
+
+ trinity-meta_pkg_setup
+}