summaryrefslogtreecommitdiffstats
path: root/ubuntu/_base/applications/tde-guidance/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'ubuntu/_base/applications/tde-guidance/debian/rules')
-rwxr-xr-xubuntu/_base/applications/tde-guidance/debian/rules6
1 files changed, 6 insertions, 0 deletions
diff --git a/ubuntu/_base/applications/tde-guidance/debian/rules b/ubuntu/_base/applications/tde-guidance/debian/rules
index b4a195a5c..0cbf1123b 100755
--- a/ubuntu/_base/applications/tde-guidance/debian/rules
+++ b/ubuntu/_base/applications/tde-guidance/debian/rules
@@ -25,6 +25,12 @@ LDFLAGS_APPEND := -L/opt/trinity/lib
DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
&& echo xz || echo bzip2)
+post-patches::
+ # make sure that python binary exists
+ # since the existing code is still dependent on python2
+ # and cdbs uses python as the default binary name
+ test -x /usr/bin/python || ln -s python2 /usr/bin/python
+
install/tde-guidance-trinity::
# install icons to right place
install -D -p -m0644 $(DEB_DESTDIR)/opt/trinity/share/apps/guidance/pics/hi32-app-daemons.png \