summaryrefslogtreecommitdiffstats
path: root/ubuntu/_base/core/tdebase/debian
diff options
context:
space:
mode:
Diffstat (limited to 'ubuntu/_base/core/tdebase/debian')
-rw-r--r--ubuntu/_base/core/tdebase/debian/cdbs/debian-tde.mk10
-rwxr-xr-xubuntu/_base/core/tdebase/debian/rules3
2 files changed, 10 insertions, 3 deletions
diff --git a/ubuntu/_base/core/tdebase/debian/cdbs/debian-tde.mk b/ubuntu/_base/core/tdebase/debian/cdbs/debian-tde.mk
index 641c6c6cc..5b4e8bfd7 100644
--- a/ubuntu/_base/core/tdebase/debian/cdbs/debian-tde.mk
+++ b/ubuntu/_base/core/tdebase/debian/cdbs/debian-tde.mk
@@ -75,6 +75,16 @@ DEB_AC_AUX_DIR = $(DEB_SRCDIR)/admin
DEB_CONFIGURE_INCLUDEDIR = "\$${prefix}/include"
DEB_COMPRESS_EXCLUDE = .dcl .docbook -license .tag .sty .el
+# The default gzip compressor has been changed in dpkg >= 1.17.0.
+deb_default_compress = $(shell LANG=C dpkg-deb --version | head -n1 | \
+ sed -e "s|.*version ||" -e "s| .*||" | \
+ xargs -r dpkg --compare-versions 1.17.0 lt \
+ && echo xz || echo gzip)
+ifeq ($(deb_default_compress),gzip)
+DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
+ && echo xz || echo bzip2)
+endif
+
ifeq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
cdbs_treat_me_gently_arches := arm m68k alpha ppc64 armel armeb
ifeq (,$(filter $(DEB_HOST_ARCH_CPU),$(cdbs_treat_me_gently_arches)))
diff --git a/ubuntu/_base/core/tdebase/debian/rules b/ubuntu/_base/core/tdebase/debian/rules
index b7d8ae5db..37d40ecb7 100755
--- a/ubuntu/_base/core/tdebase/debian/rules
+++ b/ubuntu/_base/core/tdebase/debian/rules
@@ -75,9 +75,6 @@ DEB_FIXPERMS_EXCLUDE := \
DEB_DH_STRIP_ARGS := --dbg-package=tdebase-trinity-dbg
-DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
- && echo xz || echo bzip2)
-
DOC_HTML_PRUNE := ksplashml kcontrol khelpcenter tdesu knetattach tdeioslave kxkb tdedebugdialog kdcop
PACKAGES_WITH_LIBS := kate-trinity kcontrol-trinity tdebase-trinity-bin kicker-trinity konqueror-trinity ksplash-trinity \