summaryrefslogtreecommitdiffstats
path: root/kttsd/filters/Makefile.am
diff options
context:
space:
mode:
authortoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
committertoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
commit00bb99ac80741fc50ef8a289719373032f2391eb (patch)
tree3a5a9bf72f942784b38bf77dd66c534662fab5f2 /kttsd/filters/Makefile.am
downloadtdeaccessibility-00bb99ac80741fc50ef8a289719373032f2391eb.tar.gz
tdeaccessibility-00bb99ac80741fc50ef8a289719373032f2391eb.zip
Copy the KDE 3.5 branch to branches/trinity for new KDE 3.5 features.
BUG:215923 git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/kdeaccessibility@1054174 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'kttsd/filters/Makefile.am')
-rw-r--r--kttsd/filters/Makefile.am26
1 files changed, 26 insertions, 0 deletions
diff --git a/kttsd/filters/Makefile.am b/kttsd/filters/Makefile.am
new file mode 100644
index 0000000..8c068f0
--- /dev/null
+++ b/kttsd/filters/Makefile.am
@@ -0,0 +1,26 @@
+# Include paths. INCLUDES is maintained by KDevelop, AM_CPPFLAGS is the preferred variable,
+# so keep them synchronized.
+INCLUDES = \
+ -I$(top_srcdir)/kttsd/libkttsd \
+ -I$(kde_includes)/arts \
+ $(CFLAGS_GST) \
+ $(all_includes)
+
+SUBDIRS = stringreplacer xmltransformer sbd talkerchooser
+
+#########################################################################
+# APPLICATION SECTION
+#########################################################################
+# This is the program that gets installed. It's name is used for all
+# of the other Makefile.am variables.
+check_PROGRAMS = testfilter
+
+testfilter_SOURCES = main.cpp
+
+testfilter_LDFLAGS = $(all_libraries) $(KDE_RPATH)
+testfilter_LDADD = \
+ $(top_builddir)/kttsd/libkttsd/libkttsd.la \
+ $(LIB_KDECORE)
+
+kde_servicetypes_DATA = kttsd_filterplugin.desktop
+