summaryrefslogtreecommitdiffstats
path: root/ksayit/Freeverb_plugin/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'ksayit/Freeverb_plugin/CMakeLists.txt')
-rw-r--r--ksayit/Freeverb_plugin/CMakeLists.txt30
1 files changed, 30 insertions, 0 deletions
diff --git a/ksayit/Freeverb_plugin/CMakeLists.txt b/ksayit/Freeverb_plugin/CMakeLists.txt
new file mode 100644
index 0000000..ef2d096
--- /dev/null
+++ b/ksayit/Freeverb_plugin/CMakeLists.txt
@@ -0,0 +1,30 @@
+
+include_directories(
+ ${CMAKE_BINARY_DIR}
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_CURRENT_SOURCE_DIR}
+ ${TDE_INCLUDE_DIR}
+ ${TQT_INCLUDE_DIRS}
+ ${CMAKE_SOURCE_DIR}/ksayit/src
+ ${ARTS_INCLUDE_DIRS}
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+)
+
+##### Freeverb_plugin (module)
+
+tde_add_library( Freeverb_plugin MODULE AUTOMOC
+
+ SOURCES
+ freeverb_setup.ui
+ freeverbsetupimpl.cpp
+ ksayitfreeverblib.cpp
+ LINK
+ tdecore-shared
+ tdeui-shared
+ artskde artsflow artsflow_idl artsmoduleseffects soundserver_idl artsmodules
+
+ DESTINATION ${PLUGIN_INSTALL_DIR}
+)