summaryrefslogtreecommitdiffstats
path: root/kttsd/libkttsd/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'kttsd/libkttsd/CMakeLists.txt')
-rw-r--r--kttsd/libkttsd/CMakeLists.txt46
1 files changed, 46 insertions, 0 deletions
diff --git a/kttsd/libkttsd/CMakeLists.txt b/kttsd/libkttsd/CMakeLists.txt
new file mode 100644
index 0000000..55311ee
--- /dev/null
+++ b/kttsd/libkttsd/CMakeLists.txt
@@ -0,0 +1,46 @@
+
+include_directories(
+ ${CMAKE_BINARY_DIR}
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_CURRENT_SOURCE_DIR}
+ ${TDE_INCLUDE_DIR}
+ ${TQT_INCLUDE_DIRS}
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+)
+
+##### kttsd (shared)
+
+tde_add_library( kttsd SHARED AUTOMOC
+
+ SOURCES
+ selecttalkerwidget.ui
+ pluginproc.cpp
+ pluginconf.cpp
+ testplayer.cpp
+ stretcher.cpp
+ talkercode.cpp
+ filterproc.cpp
+ filterconf.cpp
+ utils.cpp
+ selecttalkerdlg.cpp
+ notify.cpp
+ LINK
+ tdecore-shared
+ tdeio-shared
+ tdeui-shared
+
+ VERSION 1.0.0
+
+ DESTINATION ${LIB_INSTALL_DIR}
+)
+
+
+##### other data
+
+install(
+ FILES kttsd_synthplugin.desktop
+ DESTINATION ${SERVICETYPES_INSTALL_DIR}
+)