summaryrefslogtreecommitdiffstats
path: root/noatun-plugins/nexscope/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'noatun-plugins/nexscope/CMakeLists.txt')
-rw-r--r--noatun-plugins/nexscope/CMakeLists.txt53
1 files changed, 53 insertions, 0 deletions
diff --git a/noatun-plugins/nexscope/CMakeLists.txt b/noatun-plugins/nexscope/CMakeLists.txt
new file mode 100644
index 0000000..e049ccf
--- /dev/null
+++ b/noatun-plugins/nexscope/CMakeLists.txt
@@ -0,0 +1,53 @@
+#################################################
+#
+# (C) 2013 Slávek Banko
+# slavek (DOT) banko (AT) axis.cz
+#
+# Improvements and feedback are welcome
+#
+# This file is released under GPL >= 2
+#
+#################################################
+
+include_directories(
+ ${CMAKE_BINARY_DIR}
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_CURRENT_SOURCE_DIR}
+ ${SDL_INCLUDE_DIRS}
+ ${TDE_INCLUDE_DIR}/tde
+ ${TDE_INCLUDE_DIR}
+ ${TQT_INCLUDE_DIRS}
+)
+
+link_directories(
+ ${SDL_LIBRARY_DIRS}
+ ${TDE_LIB_DIR}
+ ${TQT_LIBRARY_DIRS}
+)
+
+
+##### noatunnexscope (kpart) ##########
+
+tde_add_kpart( noatunnexscope AUTOMOC
+ SOURCES noatunplugin.cpp
+ LINK tdeio-shared noatun
+ DESTINATION ${PLUGIN_INSTALL_DIR}
+)
+
+
+##### noatunnexscope.bin (executable) #########################
+
+tde_add_executable( noatunnexscope.bin AUTOMOC
+ SOURCES
+ renderers.cpp bitmappool.cpp nex.cpp output.cpp input.cpp
+ gui.cpp regionwidget.cpp convolve.c
+ LINK tdeio-shared DCOP ${SDL_LIBRARIES} noatun m
+ DESTINATION ${BIN_INSTALL_DIR}
+)
+
+
+##### other data ################################
+
+install( FILES nexscope.plugin
+ DESTINATION ${DATA_INSTALL_DIR}/noatun
+)