summaryrefslogtreecommitdiffstats
path: root/kwin-styles/glow/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'kwin-styles/glow/Makefile.am')
-rw-r--r--kwin-styles/glow/Makefile.am22
1 files changed, 22 insertions, 0 deletions
diff --git a/kwin-styles/glow/Makefile.am b/kwin-styles/glow/Makefile.am
new file mode 100644
index 00000000..92d5a63a
--- /dev/null
+++ b/kwin-styles/glow/Makefile.am
@@ -0,0 +1,22 @@
+
+INCLUDES = $(all_includes)
+
+SUBDIRS = . config themes
+
+kde_module_LTLIBRARIES = kwin3_glow.la
+
+kwin3_glow_la_SOURCES = glowclient.cpp glowbutton.cpp
+kwin3_glow_la_LDFLAGS = $(all_libraries) $(KDE_PLUGIN) -module
+kwin3_glow_la_LIBADD = $(LIB_KDECORE) -lkdecorations
+
+METASOURCES = AUTO
+noinst_HEADERS = glowclient.h glowbutton.h resources.h
+
+linkdir = $(kde_datadir)/kwin/
+link_DATA = glow.desktop
+
+EXTRA_DIST = $(link_DATA)
+
+###KMAKE-start (don't edit or delete this block)
+
+###KMAKE-end