summaryrefslogtreecommitdiffstats
path: root/kwin-styles/smooth-blend/client/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'kwin-styles/smooth-blend/client/Makefile.am')
-rw-r--r--kwin-styles/smooth-blend/client/Makefile.am20
1 files changed, 20 insertions, 0 deletions
diff --git a/kwin-styles/smooth-blend/client/Makefile.am b/kwin-styles/smooth-blend/client/Makefile.am
new file mode 100644
index 00000000..bd64ee62
--- /dev/null
+++ b/kwin-styles/smooth-blend/client/Makefile.am
@@ -0,0 +1,20 @@
+AUTOMAKE_OPTIONS = foreign
+
+SUBDIRS = config
+
+KDE_CXXFLAGS = -DQT_PLUGIN
+
+INCLUDES = $(all_includes) -I$(kde_includes)/kwin
+
+kwindir = $(kde_datadir)/kwin/
+kwin_DATA = smoothblend.desktop
+
+noinst_HEADERS = smoothblend.h buttons.h
+
+kde_module_LTLIBRARIES = kwin3_smoothblend.la
+kwin3_smoothblend_la_SOURCES = smoothblend.cc
+kwin3_smoothblend_la_LIBADD = -lkdecorations
+kwin3_smoothblend_la_LDFLAGS = $(all_libraries) $(KDE_PLUGIN) -lkdecore -module
+kwin3_smoothblend_la_METASOURCES = AUTO
+
+DISTCLEANFILES = $(kwin3_smoothblend_la_METASOURCES)