summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMichele Calgaro <michele.calgaro@yahoo.it>2024-03-15 11:19:03 +0900
committerMichele Calgaro <michele.calgaro@yahoo.it>2024-03-15 12:03:39 +0900
commit7600dc73ffc3d294af78472c9e6f01358e9aeb8e (patch)
tree14e44a926f6dab7ca01609b3783ad2291db39200 /CMakeLists.txt
parent7e7c3b4d5f4d2793eff2edb278da4bee29097e04 (diff)
downloadtdebase-7600dc73ffc3d294af78472c9e6f01358e9aeb8e.tar.gz
tdebase-7600dc73ffc3d294af78472c9e6f01358e9aeb8e.zip
Use centralized cmake version
Signed-off-by: Michele Calgaro <michele.calgaro@yahoo.it>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt12
1 files changed, 6 insertions, 6 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index a7de8d9a3..a8321e9be 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -10,7 +10,12 @@
#
#################################################
-cmake_minimum_required( VERSION 3.5 )
+
+##### set project version ########################
+
+include( TDEVersion )
+cmake_minimum_required( VERSION ${TDE_CMAKE_MINIMUM_VERSION} )
+tde_set_project_version( )
##### general package setup #####################
@@ -40,11 +45,6 @@ include( CheckTypeSize )
include( TDEMacros )
-##### set version number ########################
-
-tde_set_project_version( )
-
-
##### setup install paths #######################
include( TDESetupPaths )