summaryrefslogtreecommitdiffstats
path: root/applnk/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'applnk/CMakeLists.txt')
-rw-r--r--applnk/CMakeLists.txt35
1 files changed, 20 insertions, 15 deletions
diff --git a/applnk/CMakeLists.txt b/applnk/CMakeLists.txt
index 86b65c6a..8b64a5a1 100644
--- a/applnk/CMakeLists.txt
+++ b/applnk/CMakeLists.txt
@@ -1,31 +1,36 @@
##### desktop files
-install(
- FILES languages.desktop
+tde_create_translated_desktop(
+ SOURCE languages.desktop
DESTINATION ${APPS_INSTALL_DIR}/Edutainment/Languages
- RENAME .directory
+ PO_DIR ${CMAKE_SOURCE_DIR}/translations/desktop_files/applnk-directories
+ OUTPUT_NAME .directory
)
-install(
- FILES mathematics.desktop
+tde_create_translated_desktop(
+ SOURCE mathematics.desktop
DESTINATION ${APPS_INSTALL_DIR}/Edutainment/Mathematics
- RENAME .directory
+ PO_DIR ${CMAKE_SOURCE_DIR}/translations/desktop_files/applnk-directories
+ OUTPUT_NAME .directory
)
-install(
- FILES science.desktop
+tde_create_translated_desktop(
+ SOURCE science.desktop
DESTINATION ${APPS_INSTALL_DIR}/Edutainment/Science
- RENAME .directory
+ PO_DIR ${CMAKE_SOURCE_DIR}/translations/desktop_files/applnk-directories
+ OUTPUT_NAME .directory
)
-install(
- FILES tools.desktop
+tde_create_translated_desktop(
+ SOURCE tools.desktop
DESTINATION ${APPS_INSTALL_DIR}/Edutainment/Tools
- RENAME .directory
+ PO_DIR ${CMAKE_SOURCE_DIR}/translations/desktop_files/applnk-directories
+ OUTPUT_NAME .directory
)
-install(
- FILES miscellaneous.desktop
+tde_create_translated_desktop(
+ SOURCE miscellaneous.desktop
DESTINATION ${APPS_INSTALL_DIR}/Edutainment/Miscellaneous
- RENAME .directory
+ PO_DIR ${CMAKE_SOURCE_DIR}/translations/desktop_files/applnk-directories
+ OUTPUT_NAME .directory
)