summaryrefslogtreecommitdiffstats
path: root/blinken/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'blinken/src/Makefile.am')
-rw-r--r--blinken/src/Makefile.am23
1 files changed, 23 insertions, 0 deletions
diff --git a/blinken/src/Makefile.am b/blinken/src/Makefile.am
new file mode 100644
index 00000000..a980ac81
--- /dev/null
+++ b/blinken/src/Makefile.am
@@ -0,0 +1,23 @@
+if include_ARTS
+artslib = -lartskde
+else
+artslib =
+endif
+
+bin_PROGRAMS = blinken
+
+INCLUDES = $(all_includes)
+
+blinken_LDFLAGS = $(all_libraries) $(KDE_RPATH)
+blinken_LDADD = $(LIB_KDEUI) $(LIB_KIO) $(artslib)
+
+blinken_SOURCES = main.cpp blinken.cpp artsplayer.cpp blinkengame.cpp number.cpp highscoredialog.cpp counter.cpp fontutils.cpp fontchecker.cpp button.cpp settings.kcfgc
+
+METASOURCES = AUTO
+
+xdg_apps_DATA = blinken.desktop
+
+kde_kcfg_DATA = blinken.kcfg
+
+messages: rc.cpp
+ $(XGETTEXT) *.cpp -o $(podir)/blinken.pot