summaryrefslogtreecommitdiffstats
path: root/kig/tdefile/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'kig/tdefile/CMakeLists.txt')
-rw-r--r--kig/tdefile/CMakeLists.txt9
1 files changed, 6 insertions, 3 deletions
diff --git a/kig/tdefile/CMakeLists.txt b/kig/tdefile/CMakeLists.txt
index ec7241ca..9d4ad579 100644
--- a/kig/tdefile/CMakeLists.txt
+++ b/kig/tdefile/CMakeLists.txt
@@ -44,7 +44,10 @@ tde_add_kpart( tdefile_kig AUTOMOC
##### other data
-install(
- FILES tdefile_drgeo.desktop tdefile_kig.desktop
+foreach( _tdefile tdefile_drgeo.desktop tdefile_kig.desktop )
+ tde_create_translated_desktop(
+ SOURCE ${_tdefile}
DESTINATION ${SERVICES_INSTALL_DIR}
-)
+ PO_DIR ${CMAKE_SOURCE_DIR}/translations/desktop_files/kig-tdefile
+ )
+endforeach()