summaryrefslogtreecommitdiffstats
path: root/kvoctrain/kvoctrain/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'kvoctrain/kvoctrain/CMakeLists.txt')
-rw-r--r--kvoctrain/kvoctrain/CMakeLists.txt11
1 files changed, 6 insertions, 5 deletions
diff --git a/kvoctrain/kvoctrain/CMakeLists.txt b/kvoctrain/kvoctrain/CMakeLists.txt
index 46b4f2cb..e44da25c 100644
--- a/kvoctrain/kvoctrain/CMakeLists.txt
+++ b/kvoctrain/kvoctrain/CMakeLists.txt
@@ -84,9 +84,10 @@ tde_add_executable( spotlight2kvtml AUTOMOC
##### other data
-install(
- FILES x-kvtml.desktop
+tde_create_translated_desktop(
+ SOURCE x-kvtml.desktop
DESTINATION ${MIME_INSTALL_DIR}/text
+ PO_DIR ${CMAKE_SOURCE_DIR}/translations/desktop_files/kvoctrain-desktops
)
install(
@@ -94,9 +95,9 @@ install(
DESTINATION ${DATA_INSTALL_DIR}/kvoctrain
)
-install(
- FILES kvoctrain.desktop
- DESTINATION ${XDG_APPS_INSTALL_DIR}
+tde_create_translated_desktop(
+ SOURCE kvoctrain.desktop
+ PO_DIR ${CMAKE_SOURCE_DIR}/translations/desktop_files/kvoctrain-desktops
)
install(