summaryrefslogtreecommitdiffstats
path: root/kgoldrunner/gamedata/Makefile.am
diff options
context:
space:
mode:
authortoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
committertoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
commitc90c389a8a8d9d8661e9772ec4144c5cf2039f23 (patch)
tree6d8391395bce9eaea4ad78958617edb20c6a7573 /kgoldrunner/gamedata/Makefile.am
downloadtdegames-c90c389a8a8d9d8661e9772ec4144c5cf2039f23.tar.gz
tdegames-c90c389a8a8d9d8661e9772ec4144c5cf2039f23.zip
Copy the KDE 3.5 branch to branches/trinity for new KDE 3.5 features.
BUG:215923 git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/kdegames@1054174 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'kgoldrunner/gamedata/Makefile.am')
-rw-r--r--kgoldrunner/gamedata/Makefile.am13
1 files changed, 13 insertions, 0 deletions
diff --git a/kgoldrunner/gamedata/Makefile.am b/kgoldrunner/gamedata/Makefile.am
new file mode 100644
index 00000000..a7fcca1e
--- /dev/null
+++ b/kgoldrunner/gamedata/Makefile.am
@@ -0,0 +1,13 @@
+gamedatadir = $(kde_datadir)/kgoldrunner/system
+gamedata_DATA = games.dat hi_level.dat hi_plws.dat hi_plwv.dat hi_wad.dat
+
+# Untar the file levels.tar and install levels/*.grl files. The "chown" and
+# "chmod" ensure that installer owns files: even if installer is "root". The
+# "|| true" commands make everything succeed when the installer is NOT "root".
+install-data-local:
+ $(mkinstalldirs) $(DESTDIR)$(gamedatadir)
+ pwd=`cd $(srcdir) && pwd` ;\
+ cd $(DESTDIR)$(gamedatadir) && tar -xf $$pwd/levels.tar ;\
+ chown -R root:root levels 2> /dev/null || true ;\
+ chmod 644 levels/* 2> /dev/null || true
+