summaryrefslogtreecommitdiffstats
path: root/kpoker/Makefile.am
diff options
context:
space:
mode:
authortoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
committertoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
commitc90c389a8a8d9d8661e9772ec4144c5cf2039f23 (patch)
tree6d8391395bce9eaea4ad78958617edb20c6a7573 /kpoker/Makefile.am
downloadtdegames-c90c389a8a8d9d8661e9772ec4144c5cf2039f23.tar.gz
tdegames-c90c389a8a8d9d8661e9772ec4144c5cf2039f23.zip
Copy the KDE 3.5 branch to branches/trinity for new KDE 3.5 features.
BUG:215923 git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/kdegames@1054174 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'kpoker/Makefile.am')
-rw-r--r--kpoker/Makefile.am20
1 files changed, 20 insertions, 0 deletions
diff --git a/kpoker/Makefile.am b/kpoker/Makefile.am
new file mode 100644
index 00000000..8c72a34f
--- /dev/null
+++ b/kpoker/Makefile.am
@@ -0,0 +1,20 @@
+SUBDIRS = sounds
+
+INCLUDES = -I$(top_srcdir)/libkdegames $(all_includes)
+METASOURCES = AUTO
+KDE_ICON = kpoker
+
+bin_PROGRAMS = kpoker
+kpoker_SOURCES = kpoker.cpp kpaint.cpp top.cpp main.cpp betbox.cpp \
+ optionsdlg.cpp player.cpp playerbox.cpp newgamedlg.cpp poker.cpp
+kpoker_LDFLAGS = $(all_libraries) $(KDE_RPATH)
+kpoker_LDADD = $(LIB_KDEGAMES)
+kpoker_DEPENDENCIES = $(LIB_KDEGAMES_DEP)
+
+xdg_apps_DATA = kpoker.desktop
+
+rcdir = $(kde_datadir)/kpoker
+rc_DATA = kpokerui.rc
+
+messages: rc.cpp
+ $(XGETTEXT) *.cpp -o $(podir)/kpoker.pot