summaryrefslogtreecommitdiffstats
path: root/ksmiletris/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexander Golubev <fatzer2@gmail.com>2016-02-25 06:23:55 +0300
committerSlávek Banko <slavek.banko@axis.cz>2016-03-14 23:04:06 +0100
commitc70db62d3671e524d23ac974d296eb218159b000 (patch)
tree08d8ed5d0c7c170a7940bcbb80989b99ead98447 /ksmiletris/CMakeLists.txt
parent133cc7035dbdcaf812d8370f729530fa60547f92 (diff)
downloadtdegames-c70db62d3671e524d23ac974d296eb218159b000.tar.gz
tdegames-c70db62d3671e524d23ac974d296eb218159b000.zip
Initial cmake conversion
Diffstat (limited to 'ksmiletris/CMakeLists.txt')
-rw-r--r--ksmiletris/CMakeLists.txt44
1 files changed, 44 insertions, 0 deletions
diff --git a/ksmiletris/CMakeLists.txt b/ksmiletris/CMakeLists.txt
new file mode 100644
index 00000000..c9f6779d
--- /dev/null
+++ b/ksmiletris/CMakeLists.txt
@@ -0,0 +1,44 @@
+# This file is genereted by trinity-automake-cmake-convert script by Fat-Zer
+
+add_subdirectory( data )
+add_subdirectory( wav )
+
+include_directories(
+ ${CMAKE_BINARY_DIR}
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_CURRENT_SOURCE_DIR}
+ ${CMAKE_SOURCE_DIR}/libtdegames
+ ${CMAKE_SOURCE_DIR}/libtdegames/highscore
+ ${TDE_INCLUDE_DIR}
+ ${TQT_INCLUDE_DIRS}
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+)
+
+
+##### ksmiletris (executable) ###################
+
+tde_add_executable( ksmiletris AUTOMOC
+ SOURCES main.cpp gamewindow.cpp gamewidget.cpp screenwidget.cpp
+ mirrorwidget.cpp npiecewidget.cpp
+ LINK tdecore-shared tdeui-shared tdeio-shared tdegames-shared
+ DESTINATION ${BIN_INSTALL_DIR}
+)
+
+
+##### icons #####################################
+
+tde_install_icons( ksmiletris )
+
+
+##### other data ################################
+
+install( FILES ksmiletrisui.rc
+ DESTINATION ${DATA_INSTALL_DIR}/ksmiletris
+)
+
+install( FILES ksmiletris.desktop
+ DESTINATION ${XDG_APPS_INSTALL_DIR}
+)