summaryrefslogtreecommitdiffstats
path: root/atlantik/libatlantikclient/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'atlantik/libatlantikclient/CMakeLists.txt')
-rw-r--r--atlantik/libatlantikclient/CMakeLists.txt34
1 files changed, 34 insertions, 0 deletions
diff --git a/atlantik/libatlantikclient/CMakeLists.txt b/atlantik/libatlantikclient/CMakeLists.txt
new file mode 100644
index 00000000..53d2a932
--- /dev/null
+++ b/atlantik/libatlantikclient/CMakeLists.txt
@@ -0,0 +1,34 @@
+#################################################
+#
+# (C) 2016 Alexander Golubev
+# fatzer2 (AT) gmail.com
+#
+# Improvements and feedback are welcome
+#
+# This file is released under GPL >= 2
+#
+##################################################
+
+
+include_directories(
+ ${CMAKE_BINARY_DIR}
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_CURRENT_SOURCE_DIR}
+ ${CMAKE_SOURCE_DIR}/atlantik/libatlantic
+ ${TDE_INCLUDE_DIR}
+ ${TQT_INCLUDE_DIRS}
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+)
+
+
+##### atlantikclient (shared) ###################
+
+tde_add_library( atlantikclient SHARED AUTOMOC
+ SOURCES atlantik_network.cpp monopdprotocol.cpp
+ VERSION 3.0.2
+ LINK tdeio-shared atlantic-shared
+ DESTINATION ${LIB_INSTALL_DIR}
+)