summaryrefslogtreecommitdiffstats
path: root/kpat/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'kpat/Makefile.am')
-rw-r--r--kpat/Makefile.am30
1 files changed, 30 insertions, 0 deletions
diff --git a/kpat/Makefile.am b/kpat/Makefile.am
new file mode 100644
index 00000000..1243bf9f
--- /dev/null
+++ b/kpat/Makefile.am
@@ -0,0 +1,30 @@
+
+INCLUDES = -I$(top_srcdir)/libkdegames $(all_includes)
+
+bin_PROGRAMS = kpat
+
+kpat_SOURCES = main.cpp cardmaps.cpp card.cpp dealer.cpp \
+ pwidget.cpp pile.cpp deck.cpp pile_algorithms.cpp kings.cpp freecell.cpp klondike.cpp simon.cpp grandf.cpp \
+ mod3.cpp idiot.cpp napoleon.cpp computation.cpp gypsy.cpp fortyeight.cpp \
+ yukon.cpp clock.cpp golf.cpp spider.cpp \
+ gamestatsimpl.cpp \
+ gamestats.ui
+kpat_LDFLAGS = $(all_libraries) $(KDE_RPATH)
+kpat_LDADD = $(LIB_KFILE) $(LIB_KDEGAMES) ./freecell-solver/libfcs.la
+kpat_DEPENDENCIES = $(LIB_KDEGAMES_DEP)
+
+METASOURCES = AUTO
+
+SUBDIRS = icons freecell-solver
+
+xdg_apps_DATA = kpat.desktop
+
+rcdir = $(kde_datadir)/kpat
+rc_DATA = kpatui.rc
+
+messages: rc.cpp
+ $(XGETTEXT) *.cpp -o $(podir)/kpat.pot
+
+bgdir = $(kde_datadir)/kpat/backgrounds
+bg_DATA = green.png
+