summaryrefslogtreecommitdiffstats
path: root/kcoloredit/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2020-06-09 17:49:10 +0200
committerSlávek Banko <slavek.banko@axis.cz>2020-06-09 17:49:10 +0200
commit837dbafbea0c7f7bc73d27fda684ea2dededd547 (patch)
tree66811931fed182f8fa6f59547c6511a897adb734 /kcoloredit/CMakeLists.txt
parent00b9084c635fe29e7c5942ff508be2ca65893659 (diff)
downloadtdegraphics-837dbafbea0c7f7bc73d27fda684ea2dededd547.tar.gz
tdegraphics-837dbafbea0c7f7bc73d27fda684ea2dededd547.zip
Desktop file translations:
+ Creation of POT template for desktop files added to CMakeL10n rules. + Added creation of translated desktop files during build. Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'kcoloredit/CMakeLists.txt')
-rw-r--r--kcoloredit/CMakeLists.txt9
1 files changed, 6 insertions, 3 deletions
diff --git a/kcoloredit/CMakeLists.txt b/kcoloredit/CMakeLists.txt
index ad3d5552..9fe840cc 100644
--- a/kcoloredit/CMakeLists.txt
+++ b/kcoloredit/CMakeLists.txt
@@ -25,9 +25,12 @@ link_directories(
tde_install_icons( kcoloredit kcolorchooser )
-install( FILES
- kcoloredit.desktop kcolorchooser.desktop
- DESTINATION ${XDG_APPS_INSTALL_DIR} )
+foreach( _desktop kcoloredit.desktop kcolorchooser.desktop )
+ tde_create_translated_desktop(
+ SOURCE ${_desktop}
+ PO_DIR ${CMAKE_SOURCE_DIR}/translations/desktop_files/kcoloredit-desktops
+)
+endforeach()
install( FILES
kcoloreditui.rc