summaryrefslogtreecommitdiffstats
path: root/kfaxview/Makefile.am
diff options
context:
space:
mode:
authortoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
committertoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
commit47d455dd55be855e4cc691c32f687f723d9247ee (patch)
tree52e236aaa2576bdb3840ebede26619692fed6d7d /kfaxview/Makefile.am
downloadtdegraphics-47d455dd55be855e4cc691c32f687f723d9247ee.tar.gz
tdegraphics-47d455dd55be855e4cc691c32f687f723d9247ee.zip
Copy the KDE 3.5 branch to branches/trinity for new KDE 3.5 features.
BUG:215923 git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/kdegraphics@1054174 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'kfaxview/Makefile.am')
-rw-r--r--kfaxview/Makefile.am38
1 files changed, 38 insertions, 0 deletions
diff --git a/kfaxview/Makefile.am b/kfaxview/Makefile.am
new file mode 100644
index 00000000..669fcd9b
--- /dev/null
+++ b/kfaxview/Makefile.am
@@ -0,0 +1,38 @@
+INCLUDES = -I$(top_srcdir)/kviewshell \
+ -I$(top_builddir)/kviewshell \
+ -I$(kde_includes)/kviewshell \
+ -I$(srcdir)/libkfaximage \
+ -I$(top_srcdir) $(all_includes)
+
+SUBDIRS = libkfaximage .
+
+KDE_ICON = kfaxview
+
+METASOURCES = AUTO
+
+bin_PROGRAMS = kfaxview
+kfaxview_SOURCES = main.cpp
+kfaxview_LDFLAGS = $(all_libraries) $(KDE_RPATH)
+kfaxview_LDADD = ../kviewshell/libifaces.la ../kviewshell/libkviewshell.la -lkparts
+
+# this is where the desktop file will go
+kde_services_DATA = kfaxmultipage.desktop kfaxmultipage_tiff.desktop
+
+# this is where the shell's XML-GUI resource file goes
+shellrcdir = $(kde_datadir)/kfaxview
+
+kde_module_LTLIBRARIES = kfaxviewpart.la
+kfaxviewpart_la_LDFLAGS = $(all_libraries) $(KDE_PLUGIN) -module
+kfaxviewpart_la_LIBADD = -lkdeprint -lkparts $(top_builddir)/kviewshell/libkmultipage.la libkfaximage/libkfaximage.la
+kfaxviewpart_la_SOURCES = faxmultipage.cpp faxrenderer.cpp
+
+partdir = $(kde_datadir)/kfaxview
+part_DATA = ../kviewshell/kviewshell.rc
+
+messages: rc.cpp
+ $(XGETTEXT) *.cpp -o $(podir)/kfaxview.pot
+
+xdg_apps_DATA = kfaxview.desktop
+
+# The next line switches the API documentation on
+include ../admin/Doxyfile.am