summaryrefslogtreecommitdiffstats
path: root/kolourpaint/CMakeLists.txt
diff options
context:
space:
mode:
authorsamelian <samelian@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2011-05-10 19:25:30 +0000
committersamelian <samelian@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2011-05-10 19:25:30 +0000
commit6e0e1a2a268b0c2cf4274ea0d9fcf0415f3c1d3d (patch)
tree39c2e6b4ccef1cc74f42368884356fa7f257265c /kolourpaint/CMakeLists.txt
parent07a14c41079b3cf9f8a089280db02874b770cfa5 (diff)
downloadtdegraphics-6e0e1a2a268b0c2cf4274ea0d9fcf0415f3c1d3d.tar.gz
tdegraphics-6e0e1a2a268b0c2cf4274ea0d9fcf0415f3c1d3d.zip
[kdegraphics/kolourpaint] added cmake support
git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/kdegraphics@1231305 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'kolourpaint/CMakeLists.txt')
-rw-r--r--kolourpaint/CMakeLists.txt65
1 files changed, 65 insertions, 0 deletions
diff --git a/kolourpaint/CMakeLists.txt b/kolourpaint/CMakeLists.txt
new file mode 100644
index 00000000..3f6e2daa
--- /dev/null
+++ b/kolourpaint/CMakeLists.txt
@@ -0,0 +1,65 @@
+#################################################
+#
+# (C) 2010-2011 Serghei Amelian
+# serghei (DOT) amelian (AT) gmail.com
+#
+# Improvements and feedback are welcome
+#
+# This file is released under GPL >= 2
+#
+#################################################
+
+add_subdirectory( cursors )
+add_subdirectory( pics )
+add_subdirectory( pixmapfx )
+add_subdirectory( tools )
+add_subdirectory( views )
+add_subdirectory( widgets )
+
+
+include_directories(
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_CURRENT_SOURCE_DIR}
+ ${CMAKE_CURRENT_SOURCE_DIR}/pixmapfx
+ ${CMAKE_CURRENT_SOURCE_DIR}/tools
+ ${CMAKE_CURRENT_SOURCE_DIR}/views
+ ${CMAKE_CURRENT_SOURCE_DIR}/widgets
+ ${TDE_INCLUDE_DIR}
+ ${TQT_INCLUDE_DIRS}
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+)
+
+
+##### other data ################################
+
+install( FILES kolourpaint.desktop DESTINATION ${XDG_APPS_INSTALL_DIR} )
+install( FILES kolourpaintui.rc DESTINATION ${DATA_INSTALL_DIR}/kolourpaint )
+
+
+##### kolourpaint (executable) ##################
+
+tde_file_to_cpp( COPYING kolourpaintlicense.h kpLicenseText )
+tde_file_to_cpp( VERSION kolourpaintversion.h kpVersionText )
+
+tde_add_executable( kolourpaint AUTOMOC
+ SOURCES
+ kolourpaint.cpp kpdocument.cpp kpdocumentmetainfo.cpp
+ kpdocumentsaveoptions.cpp kpdocumentsaveoptionswidget.cpp
+ kpview.cpp kpcolor.cpp kpcommandhistory.cpp kpmainwindow.cpp
+ kpmainwindow_edit.cpp kpmainwindow_help.cpp
+ kpmainwindow_image.cpp kpmainwindow_tools.cpp
+ kpmainwindow_file.cpp kpmainwindow_settings.cpp
+ kpmainwindow_statusbar.cpp kpmainwindow_text.cpp
+ kpmainwindow_view.cpp kpselection.cpp kpselectiondrag.cpp
+ kpselectiontransparency.cpp kpsinglekeytriggersaction.cpp
+ kptemppixmap.cpp kptextstyle.cpp kpthumbnail.cpp kptool.cpp
+ kpviewmanager.cpp kpviewscrollablecontainer.cpp kpwidgetmapper.cpp
+ LINK
+ kolourpainttools-static kolourpaintpixmapfx-static kolourpaintcursors-static
+ kolourpaintviews-static kolourpaintwidgets-static
+ kdeprint-shared
+ DESTINATION ${BIN_INSTALL_DIR}
+)