summaryrefslogtreecommitdiffstats
path: root/kpovmodeler/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2021-07-08 19:46:45 +0200
committerSlávek Banko <slavek.banko@axis.cz>2021-07-08 23:59:06 +0200
commit866f96c1f45c0d8302267c3bc3b286369cf9dcfe (patch)
tree41a55555919c666e03e7423b1a0a61fdafb58061 /kpovmodeler/CMakeLists.txt
parentd19460fd6eae693832e4c5160aa2071bf71062f6 (diff)
downloadtdegraphics-866f96c1f45c0d8302267c3bc3b286369cf9dcfe.tar.gz
tdegraphics-866f96c1f45c0d8302267c3bc3b286369cf9dcfe.zip
Use FindOpenGL instead of pkg_search_module( GLU ).
This resolves FTBFS on FreeBSD 13. Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'kpovmodeler/CMakeLists.txt')
-rw-r--r--kpovmodeler/CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/kpovmodeler/CMakeLists.txt b/kpovmodeler/CMakeLists.txt
index 6ec98ae4..b589117f 100644
--- a/kpovmodeler/CMakeLists.txt
+++ b/kpovmodeler/CMakeLists.txt
@@ -19,7 +19,7 @@ include_directories(
${CMAKE_BINARY_DIR}
${TDE_INCLUDE_DIR}
${TQT_INCLUDE_DIRS}
- ${GLU_INCLUDE_DIRS}
+ ${OPENGL_INCLUDE_DIRS}
${FREETYPE_INCLUDE_DIRS}
)
@@ -112,7 +112,7 @@ tde_add_library( kpovmodeler SHARED AUTOMOC
pmlibraryiconview.cpp pmlibraryobjectsearch.cpp pmpluginmanager.cpp
pmpartiface.skel
VERSION 0.0.0
- LINK tdeparts-shared ${GLU_LIBRARIES} ${XMU_LIBRARIES} ${FREETYPE_LIBRARIES}
+ LINK tdeparts-shared ${OPENGL_LIBRARIES} ${XMU_LIBRARIES} ${FREETYPE_LIBRARIES}
DESTINATION ${LIB_INSTALL_DIR}
)