summaryrefslogtreecommitdiffstats
path: root/kview/Makefile.am
diff options
context:
space:
mode:
authortoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
committertoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
commit47d455dd55be855e4cc691c32f687f723d9247ee (patch)
tree52e236aaa2576bdb3840ebede26619692fed6d7d /kview/Makefile.am
downloadtdegraphics-47d455dd55be855e4cc691c32f687f723d9247ee.tar.gz
tdegraphics-47d455dd55be855e4cc691c32f687f723d9247ee.zip
Copy the KDE 3.5 branch to branches/trinity for new KDE 3.5 features.
BUG:215923 git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/kdegraphics@1054174 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'kview/Makefile.am')
-rw-r--r--kview/Makefile.am25
1 files changed, 25 insertions, 0 deletions
diff --git a/kview/Makefile.am b/kview/Makefile.am
new file mode 100644
index 00000000..2acb3133
--- /dev/null
+++ b/kview/Makefile.am
@@ -0,0 +1,25 @@
+SUBDIRS = kimageviewer . config kviewcanvas kviewviewer modules photobook
+
+INCLUDES = -I$(top_srcdir)/kview $(all_includes)
+
+METASOURCES = AUTO
+
+bin_PROGRAMS =
+lib_LTLIBRARIES =
+kdeinit_LTLIBRARIES = kview.la
+
+noinst_HEADERS = kview.h
+
+kview_la_SOURCES = kview.cpp main.cpp
+kview_la_LDFLAGS = $(KDE_RPATH) $(all_libraries) -module -avoid-version
+kview_la_LIBADD = $(LIB_KPARTS) $(LIB_KUTILS)
+
+xdg_apps_DATA = kview.desktop
+
+KDE_ICON = kview
+
+rcdir = $(kde_datadir)/kview
+rc_DATA = kviewui.rc
+
+messages: rc.cpp
+ $(XGETTEXT) *.cpp *.h -o $(podir)/kview.pot