summaryrefslogtreecommitdiffstats
path: root/kview/config/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2020-06-09 17:49:10 +0200
committerSlávek Banko <slavek.banko@axis.cz>2020-06-09 17:49:10 +0200
commit837dbafbea0c7f7bc73d27fda684ea2dededd547 (patch)
tree66811931fed182f8fa6f59547c6511a897adb734 /kview/config/CMakeLists.txt
parent00b9084c635fe29e7c5942ff508be2ca65893659 (diff)
downloadtdegraphics-837dbafbea0c7f7bc73d27fda684ea2dededd547.tar.gz
tdegraphics-837dbafbea0c7f7bc73d27fda684ea2dededd547.zip
Desktop file translations:
+ Creation of POT template for desktop files added to CMakeL10n rules. + Added creation of translated desktop files during build. Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'kview/config/CMakeLists.txt')
-rw-r--r--kview/config/CMakeLists.txt7
1 files changed, 6 insertions, 1 deletions
diff --git a/kview/config/CMakeLists.txt b/kview/config/CMakeLists.txt
index d2649a1c..6485b86e 100644
--- a/kview/config/CMakeLists.txt
+++ b/kview/config/CMakeLists.txt
@@ -24,7 +24,12 @@ link_directories(
##### other data ################################
-install( FILES kviewgeneralconfig.desktop DESTINATION ${SERVICES_INSTALL_DIR}/tdeconfiguredialog )
+tde_create_translated_desktop(
+ SOURCE kviewgeneralconfig.desktop
+ DESTINATION ${SERVICES_INSTALL_DIR}/tdeconfiguredialog
+ PO_DIR ${CMAKE_SOURCE_DIR}/translations/desktop_files/kview-desktops
+)
+
install( FILES kview.setdlg DESTINATION ${DATA_INSTALL_DIR}/kview )