summaryrefslogtreecommitdiffstats
path: root/tdefile-plugins/dependencies/poppler-tqt/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2022-04-01 15:19:29 +0200
committerSlávek Banko <slavek.banko@axis.cz>2022-04-01 15:19:29 +0200
commit3c919351327ed35d2ad13a62d8d5aefccfed36a6 (patch)
tree5ce8c8cc6c6562b3644147abfdf4ef8ea8e87082 /tdefile-plugins/dependencies/poppler-tqt/CMakeLists.txt
parent37a6812fbebc918b17506cf6d51e3556c8cdc609 (diff)
downloadtdegraphics-3c919351327ed35d2ad13a62d8d5aefccfed36a6.tar.gz
tdegraphics-3c919351327ed35d2ad13a62d8d5aefccfed36a6.zip
Ensure the use of C++17 standard for Poppler >= 21.12.
Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'tdefile-plugins/dependencies/poppler-tqt/CMakeLists.txt')
-rw-r--r--tdefile-plugins/dependencies/poppler-tqt/CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/tdefile-plugins/dependencies/poppler-tqt/CMakeLists.txt b/tdefile-plugins/dependencies/poppler-tqt/CMakeLists.txt
index 28be343b..d95dc846 100644
--- a/tdefile-plugins/dependencies/poppler-tqt/CMakeLists.txt
+++ b/tdefile-plugins/dependencies/poppler-tqt/CMakeLists.txt
@@ -41,6 +41,7 @@ install( FILES
poppler-qt.h poppler-page-transition.h poppler-link-qt3.h
DESTINATION ${INCLUDE_INSTALL_DIR} )
+
##### poppler-tqt (shared) ############################
tde_add_library( poppler-tqt SHARED AUTOMOC
@@ -50,6 +51,12 @@ tde_add_library( poppler-tqt SHARED AUTOMOC
poppler-page-transition.cpp poppler-page-transition-private.h
poppler-private.cpp poppler-private.h
VERSION 0.0.0
+ CXX_FEATURES ${POPPLER_CXX_FEATURES}
LINK ${POPPLER_LIBRARIES} ${TQT_LIBRARIES}
DESTINATION ${LIB_INSTALL_DIR}
)
+
+
+##### install cmake export file #################
+
+tde_install_export( )