summaryrefslogtreecommitdiffstats
path: root/kghostview/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'kghostview/CMakeLists.txt')
-rw-r--r--kghostview/CMakeLists.txt14
1 files changed, 12 insertions, 2 deletions
diff --git a/kghostview/CMakeLists.txt b/kghostview/CMakeLists.txt
index 316f387e..11e30d20 100644
--- a/kghostview/CMakeLists.txt
+++ b/kghostview/CMakeLists.txt
@@ -28,8 +28,18 @@ link_directories(
#### other data #################################
tde_install_icons( kghostview )
-install( FILES kghostview.desktop DESTINATION ${XDG_APPS_INSTALL_DIR} )
-install( FILES kghostview_part.desktop DESTINATION ${SERVICES_INSTALL_DIR} )
+
+tde_create_translated_desktop(
+ SOURCE kghostview.desktop
+ PO_DIR kghostview-desktops
+)
+
+tde_create_translated_desktop(
+ SOURCE kghostview_part.desktop
+ DESTINATION ${SERVICES_INSTALL_DIR}
+ PO_DIR kghostview-desktops
+)
+
install( FILES kgv_part.rc kghostviewui.rc DESTINATION ${DATA_INSTALL_DIR}/kghostview )
install( FILES kghostview.kcfg DESTINATION ${KCFG_INSTALL_DIR} )
install( FILES kghostview.upd DESTINATION ${KCONF_UPDATE_INSTALL_DIR} )