summaryrefslogtreecommitdiffstats
path: root/kolourpaint/tools/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'kolourpaint/tools/CMakeLists.txt')
-rw-r--r--kolourpaint/tools/CMakeLists.txt38
1 files changed, 38 insertions, 0 deletions
diff --git a/kolourpaint/tools/CMakeLists.txt b/kolourpaint/tools/CMakeLists.txt
new file mode 100644
index 00000000..679fed5d
--- /dev/null
+++ b/kolourpaint/tools/CMakeLists.txt
@@ -0,0 +1,38 @@
+#################################################
+#
+# (C) 2010-2011 Serghei Amelian
+# serghei (DOT) amelian (AT) gmail.com
+#
+# Improvements and feedback are welcome
+#
+# This file is released under GPL >= 2
+#
+#################################################
+
+include_directories(
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_CURRENT_SOURCE_DIR}
+ ${CMAKE_CURRENT_SOURCE_DIR}/..
+ ${CMAKE_CURRENT_SOURCE_DIR}/../pixmapfx
+ ${CMAKE_CURRENT_SOURCE_DIR}/../widgets
+ ${CMAKE_CURRENT_SOURCE_DIR}/../cursors
+ ${TDE_INCLUDE_DIR}
+ ${TQT_INCLUDE_DIRS}
+)
+
+
+##### kolourpainttools (static) #################
+
+tde_add_library( kolourpainttools STATIC_PIC AUTOMOC
+ SOURCES
+ kptoolaction.cpp kptoolairspray.cpp kptoolautocrop.cpp
+ kptoolbrush.cpp kptoolclear.cpp kptoolcolorpicker.cpp
+ kptoolcolorwasher.cpp kptoolconverttograyscale.cpp kptoolcrop.cpp
+ kptoolcurve.cpp kptoolellipse.cpp kptoolellipticalselection.cpp
+ kptooleraser.cpp kptoolflip.cpp kptoolfloodfill.cpp
+ kptoolfreeformselection.cpp kptoolline.cpp kptoolpen.cpp
+ kptoolpolygon.cpp kptoolpolyline.cpp kptoolpreviewdialog.cpp
+ kptoolrectangle.cpp kptoolrectselection.cpp kptoolresizescale.cpp
+ kptoolrotate.cpp kptoolroundedrectangle.cpp kptoolselection.cpp
+ kptoolskew.cpp kptooltext.cpp
+)