summaryrefslogtreecommitdiffstats
path: root/tdefile-plugins/ps/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tdefile-plugins/ps/Makefile.am')
-rw-r--r--tdefile-plugins/ps/Makefile.am26
1 files changed, 26 insertions, 0 deletions
diff --git a/tdefile-plugins/ps/Makefile.am b/tdefile-plugins/ps/Makefile.am
new file mode 100644
index 00000000..7e7943c6
--- /dev/null
+++ b/tdefile-plugins/ps/Makefile.am
@@ -0,0 +1,26 @@
+## Makefile.am for the ps file meta info plugin
+
+# set the include path for X, qt and KDE
+INCLUDES = -I$(top_srcdir)/kghostview/dscparse $(all_includes)
+
+# these are the headers for your project
+noinst_HEADERS = tdefile_ps.h gscreator.h
+
+kde_module_LTLIBRARIES = tdefile_ps.la gsthumbnail.la
+
+tdefile_ps_la_SOURCES = tdefile_ps.cpp
+tdefile_ps_la_LDFLAGS = $(all_libraries) -module $(KDE_PLUGIN)
+tdefile_ps_la_LIBADD = $(LIB_KIO) ../../kghostview/libdscparse.la
+
+gsthumbnail_la_SOURCES = gscreator.cpp
+gsthumbnail_la_LIBADD = $(LIB_TDECORE) ../../kghostview/libdscparse.la
+gsthumbnail_la_LDFLAGS = $(all_libraries) -module $(KDE_PLUGIN)
+
+# let automoc handle all of the meta source files (moc)
+METASOURCES = AUTO
+
+messages:
+ $(XGETTEXT) *.cpp -o $(podir)/tdefile_ps.pot
+
+services_DATA = tdefile_ps.desktop gsthumbnail.desktop
+servicesdir = $(kde_servicesdir)