summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMichele Calgaro <michele.calgaro@yahoo.it>2018-08-26 21:05:50 +0900
committerMichele Calgaro <michele.calgaro@yahoo.it>2018-08-26 21:05:50 +0900
commit85278cadecf3d63a6a50e42c070b308ace065a50 (patch)
tree70fbad66d6c9043c60f42242edd689df82396623 /CMakeLists.txt
parenta18f9fcc94b6982fecb8b75ccb5c21b213e78706 (diff)
downloadtdeio-gopher-85278cadecf3d63a6a50e42c070b308ace065a50.tar.gz
tdeio-gopher-85278cadecf3d63a6a50e42c070b308ace065a50.zip
Fixed docbook building and translations.
Signed-off-by: Michele Calgaro <michele.calgaro@yahoo.it>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt9
1 files changed, 8 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index f1bbd30..0f2f584 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -41,6 +41,13 @@ include( TDESetupPaths )
tde_setup_paths( )
+##### user requested modules ####################
+
+option( BUILD_ALL "Build all" OFF )
+option( BUILD_DOC "Build doc" ${BUILD_ALL} )
+option( BUILD_TRANSLATIONS "Build translations" ${BUILD_ALL} )
+
+
##### configure checks ##########################
include( ConfigureChecks.cmake )
@@ -60,7 +67,7 @@ set( CMAKE_MODULE_LINKER_FLAGS "-Wl,--no-undefined" )
##### source directories ########################
add_subdirectory( src )
-#tde_conditional_add_subdirectory( BUILD_DOC doc )
+tde_conditional_add_subdirectory( BUILD_DOC doc )
#tde_conditional_add_subdirectory( BUILD_TRANSLATIONS po )