summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexander Golubev <fatzer2@gmail.com>2013-08-10 16:37:19 -0500
committerDarrell Anderson <humanreadable@yahoo.com>2013-08-10 22:31:50 -0500
commit12976397880bd538311859d4fe5e1a473c326e5e (patch)
tree21475c1cce35adcd781a517ca9e8edfad168ce3a /CMakeLists.txt
parent411486cc50448e91b53d28119ccec54c5c2305cd (diff)
downloadtdelibs-12976397880bd538311859d4fe5e1a473c326e5e.tar.gz
tdelibs-12976397880bd538311859d4fe5e1a473c326e5e.zip
Fix tdeioslaves FTBFS when compiled in standalone.
This resolves bug report 1617. Cmake doesn't define HAVE_BACKTRACE. This resolves bug report 1614.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 11c6149bb..15a829404 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -266,6 +266,7 @@ check_symbol_exists( gethostbyname2_r "netdb.h" HAVE_GETHOSTBYNAME2_R )
check_symbol_exists( gethostbyname_r "netdb.h" HAVE_GETHOSTBYNAME_R )
check_symbol_exists( gai_strerror "sys/types.h;sys/socket.h;netdb.h" HAVE_GAI_STRERROR )
check_symbol_exists( getaddrinfo "sys/types.h;sys/socket.h;netdb.h" HAVE_GETADDRINFO )
+check_symbol_exists( backtrace "execinfo.h" HAVE_BACKTRACE )
check_function_exists( usleep HAVE_USLEEP )
check_symbol_exists( usleep "unistd.h" HAVE_USLEEP_PROTO )