summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorTimothy Pearson <kb9vqf@pearsoncomputing.net>2012-01-09 01:54:13 -0600
committerTimothy Pearson <kb9vqf@pearsoncomputing.net>2012-01-09 01:54:13 -0600
commit24f144faf98249012e7b1657a5dfe93750f0dfde (patch)
tree4a9fb0aec5248ed3565054a7b41bcaaa1c58d341 /CMakeLists.txt
parent7508eafbec2436de2d49d4e93d8f4030ec48aa1f (diff)
downloadtdelibs-24f144faf98249012e7b1657a5dfe93750f0dfde.tar.gz
tdelibs-24f144faf98249012e7b1657a5dfe93750f0dfde.zip
Add inotify CMake support to tdelibs
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt21
1 files changed, 21 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index e26c252ce..ede0a3a4c 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -78,6 +78,7 @@ OPTION( WITH_AVAHI "Enable AVAHI support" OFF )
OPTION( WITH_ELFICON "Enable ELF embedded icon support" OFF )
OPTION( WITH_PCRE "Enable pcre regex support for kjs" ON )
OPTION( WITH_GCC_VISIBILITY "Enable fvisibility and fvisibility-inlines-hidden" OFF )
+OPTION( WITH_INOTIFY "Enable inotify support for kio" ON )
OPTION( WITH_ASPELL "Enable aspell support" OFF )
OPTION( WITH_HSPELL "Enable hspell support" OFF )
@@ -763,6 +764,26 @@ if( WITH_GCC_VISIBILITY )
endif( )
+##### check for inotify ###########################
+
+if( WITH_INOTIFY )
+ check_include_file( "inotify.h" INOTIFY_FOUND )
+ check_include_file( "sys/inotify.h" INOTIFY_SYS_FOUND )
+ if( NOT INOTIFY_FOUND )
+ if( NOT INOTIFY_SYS_FOUND )
+ message(FATAL_ERROR "\ninotify support was requested, but inotify was not found on your system" )
+ endif( NOT INOTIFY_SYS_FOUND )
+ endif( NOT INOTIFY_FOUND )
+ if( INOTIFY_FOUND )
+ set( HAVE_INOTIFY 1 )
+ endif( INOTIFY_FOUND )
+ if( INOTIFY_SYS_FOUND )
+ set( HAVE_INOTIFY 1 )
+ set( HAVE_SYS_INOTIFY 1 )
+ endif( INOTIFY_SYS_FOUND )
+endif( )
+
+
##### check for aspell ##########################
# we need ASPELL_DATADIR too