summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorOBATA Akio <obache@wizdas.com>2020-08-28 16:08:41 +0900
committerTDE Gitea <gitea@mirror.git.trinitydesktop.org>2020-08-31 09:52:13 +0000
commit8e542575e044baf23ae636d32f1c6d4e3b8dea18 (patch)
tree168005cca38ba0cc5bc25e514fe20d4b310db66d /CMakeLists.txt
parentac8c8ca54aaed1466255161a3d727dcfade4a7d9 (diff)
downloadtdelibs-8e542575e044baf23ae636d32f1c6d4e3b8dea18.tar.gz
tdelibs-8e542575e044baf23ae636d32f1c6d4e3b8dea18.zip
Add support of posix_openpt(2) to open master pseudo terminal device
Signed-off-by: OBATA Akio <obache@wizdas.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 48deed0c0..1b63914aa 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -422,6 +422,7 @@ check_function_exists( strcasecmp HAVE_STRCASECMP )
check_function_exists( strchr HAVE_STRCHR )
check_function_exists( strcmp HAVE_STRCMP )
check_function_exists( strrchr HAVE_STRRCHR )
+check_function_exists( posix_openpt HAVE_POSIX_OPENPT )
check_function_exists( ptsname HAVE_PTSNAME )
check_function_exists( unlockpt HAVE_UNLOCKPT )
check_function_exists( _getpty HAVE__GETPTY )