summaryrefslogtreecommitdiffstats
path: root/tdeabc/vcardparser/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tdeabc/vcardparser/CMakeLists.txt')
-rw-r--r--tdeabc/vcardparser/CMakeLists.txt11
1 files changed, 8 insertions, 3 deletions
diff --git a/tdeabc/vcardparser/CMakeLists.txt b/tdeabc/vcardparser/CMakeLists.txt
index 8e916aa0b..632c4fb9f 100644
--- a/tdeabc/vcardparser/CMakeLists.txt
+++ b/tdeabc/vcardparser/CMakeLists.txt
@@ -90,9 +90,14 @@ tde_add_executable( testvcardformatimpl
LINK ${TDEABC_TESTS_LINK}
)
-add_custom_target(testing ALL
- COMMAND echo "creating test infrastructure"
- DEPENDS testread
+add_custom_target(test ALL echo "performing tests on vcardparser"
+ COMMAND bash ./test.sh
+ DEPENDS testing
+ WORKING_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR}
+)
+
+add_custom_target(testing ALL echo "creating test infrastructure"
+ DEPENDS testvcardformatimpl testvcardformat testwrite2 testwrite testread2 testread
WORKING_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR}
)