summaryrefslogtreecommitdiffstats
path: root/kopete/protocols/gadu/CMakeLists.txt
diff options
context:
space:
mode:
authorsamelian <samelian@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2011-05-22 20:12:04 +0000
committersamelian <samelian@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2011-05-22 20:12:04 +0000
commitac87680632b4fb6582d1391b042eff7f0305c0a2 (patch)
treebfeee57d104a1bbc7c387d35190fa55d692115b7 /kopete/protocols/gadu/CMakeLists.txt
parentaca844682f86c04f6b67b23de2a820fb0c63a32e (diff)
downloadtdenetwork-ac87680632b4fb6582d1391b042eff7f0305c0a2.tar.gz
tdenetwork-ac87680632b4fb6582d1391b042eff7f0305c0a2.zip
[kdenetwork/kopete] added cmake support
git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/kdenetwork@1233119 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'kopete/protocols/gadu/CMakeLists.txt')
-rw-r--r--kopete/protocols/gadu/CMakeLists.txt50
1 files changed, 50 insertions, 0 deletions
diff --git a/kopete/protocols/gadu/CMakeLists.txt b/kopete/protocols/gadu/CMakeLists.txt
new file mode 100644
index 00000000..bb5326d4
--- /dev/null
+++ b/kopete/protocols/gadu/CMakeLists.txt
@@ -0,0 +1,50 @@
+#################################################
+#
+# (C) 2010-2011 Serghei Amelian
+# serghei (DOT) amelian (AT) gmail.com
+#
+# Improvements and feedback are welcome
+#
+# This file is released under GPL >= 2
+#
+#################################################
+
+include( ConfigureChecks.cmake )
+
+add_subdirectory( ui )
+add_subdirectory( icons )
+
+include_directories(
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_CURRENT_BINARY_DIR}/ui
+ ${CMAKE_BINARY_DIR}/kopete/libkopete/ui
+ ${CMAKE_SOURCE_DIR}/kopete/libkopete
+ ${CMAKE_SOURCE_DIR}/kopete/libkopete/ui
+ ${TDE_INCLUDE_DIR}
+ ${TQT_INCLUDE_DIRS}
+ ${GADU_INCLUDE_DIRS}
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+)
+
+
+##### other data ################################
+
+install( FILES kopete_gadu.desktop DESTINATION ${SERVICES_INSTALL_DIR} )
+
+
+##### kopete_gadu (module) ######################
+
+tde_add_kpart( kopete_gadu AUTOMOC
+ SOURCES
+ gaduaway.cpp gadueditcontact.cpp gaducommands.cpp
+ gadueditaccount.cpp gadusession.cpp gaducontact.cpp
+ gaduaddcontactpage.cpp gaduprotocol.cpp gaduaccount.cpp
+ gadupubdir.cpp gaduregisteraccount.cpp gaducontactlist.cpp
+ gadurichtextformat.cpp gadudccserver.cpp gadudcctransaction.cpp
+ gadudcc.cpp
+ LINK gaduui-static kopete-shared ${GADU_LIBRARIES}
+ DESTINATION ${PLUGIN_INSTALL_DIR}
+)